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Операции оценивания выражений. 

Команды преобразования выражений
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Знакомство с Maple

Что такое Maple?

Пользовательский интерфейс:
➢ Режим документа (Document Mode)
➢ Режим рабочего листа (Worksheet Mode)

Режимы ввода и их особенности
➢ текстовый (Text Mode)
➢ математический (Math Mode)

Переключение между режимами интерфейса Maple
Использование справки



Что такое Maple?
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 Maple – англ. «клен»

 Пакет компьютерной  алгебры, среда 

точных и приближенных вычислений

 В первую очередь, среда символьных 
(аналитических) вычислений, но также имеет 
средства для приближенных вычислений (численное 
решение ДУ, нахождение интегралов и др.)

 Развитая графика, визуализация

 Язык программирования, напоминающий Pascal

Разработчик: Waterloo Maple Inc. (концепция: University of 
Waterloo, Waterloo, Ontario, Canada, 1980)

Сайт: maplesoft.com



Версии Maple
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 Первый выпуск: Maple 1.0 (1982)
 На мехмате: Maple 11.0 (2007)
 Далее были: Maple 12-18 (2014), затем Maple 2015 и т.д. 

по годам

 Последняя версия: Maple 2022
 Есть профессиональная, академическая и студенческая 

версии (все платные, commercial software)

Maple 11.0
 Можно вводить математические выражения, используя 

стандартные обозначения
 Есть интерфейсы к C, C#, Fortran, Java, Matlab, 

VisualBasic, Excel
 Функциональность обеспечивается библиотеками



Основные черты и возможности Maple 11
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Режимы интерфейса в Maple

Document Mode Worksheet Mode

 Режим для создания 
документов с 
математическими 
вычислениями

 Скрывает все команды, 
используемые для 
выполнения вычислений

 Не требует знания 
синтаксиса Maple

 Традиционный интерфейс 
Maple для ввода команд

 Есть символ командной 
строки

 Весь синтаксис команд 
отображается
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Ввод математических выражений
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 Режимы ввода: Text Mode и Math Mode (переключение – [F5])

 Math mode : для ввода выражений в стиле «двумерной 

математики» 2D Math:

 Text Mode: в  режиме интерфейса Document Mode – для ввода 
текстовых комментариев , в режиме интерфейса Worksheet 
Mode – для ввод выражений в стиле «одномерной 

математики» 1D Math: 

2D-Math

 Навигация по выражению – с помощью кнопок 

 Выход из набора рациональной дроби или степени

 Знак умножения * можно опускать в случаях умножения числа 
на переменную              или переменную на переменную (между 
именами переменных ставится пробел):     



Использование палитр (Pallets) для ввода сложных 
математических выражений
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Дополнительные возможности для ввода и 
вычисления математических выражений
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Вызов контекстного меню

 Правая кнопка мыши

Автоматическое 

завершение команды

 [Ctrl]+[Space]

Кнопки пересчета вычислений

 Выполнение вычислений в выделенных строках или текущей 
строке: 

 Выполнение вычислений во всем документе:   



Обзор режима интерфейса Document Mode
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 File->New->Document Mode

 Включение маркеров документного блока View->Markers

Режим  ввода Text Mode

 Вертикальный курсор в документном блоке 

 Для ввода обычного текста, математические выражения не 
вычисляются

Режим ввода Math Mode

 Наклонный курсор в документном блоке 

 Ввод в виде 2D-Math 

 Все команды скрыты, показан только результат



Режим интерфейса Document Mode : 
вычисление выражений
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Вывод результата на той же строке

 [Ctrl]+[=]

 Правая кнопка мыши: Evaluate and Display Inline

Вывод результата на другой строке в центре

 [Enter]

 Правая кнопка мыши: Evaluate



Обзор режима интерфейса Worksheet Mode
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 File->New->Worksheet Mode

 Оба режима ввода текста – Math и Text – служат для ввода 
математических выражений и команд Maple

 Math – ввод в нотации 2D-Math 

 Text – ввод в нотации 1D-Math 

 Ввод текстовых комментариев: 

 Вставка рабочей группы: 

 Отделение команд друг от друга – ; или :

 Подавление вывода результата на экран – двоеточие в 
конце команды



Режим ввода Math Mode в Worksheet Mode
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 Наклонный курсор в рабочей группе

 Ввод выражений в виде 2D-Math

 Выполнение команд – по нажатию [Enter]

 Весь синтаксис команд отображается при использовании 
контекстного меню

 Вызов контекстного меню возможен как для введенного 
выражения, так и для результата



Режим ввода Text Mode в Worksheet Mode
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 Стиль старых версий Maple

 Вертикальный курсор в рабочей группе

 Ввод выражений в виде 1D-Math, введенное выражение должно 
заканчиваться точкой с запятой или двоеточием

 Вызов контекстного меню возможен только для результата!



Переключение между режимами интерфейса
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 В режиме Document Mode можно показать скрытые команды: 

View -> Expand Document Block: 

 В режиме Worksheet Mode можно скрыть все команды и 
показывать только результат: View-> Collapse Execution Group



Совмещение разных режимов интерфейса
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 Из режима Document Mode в режим Worksheet Mode

1. Вставка рабочей группы с помощью кнопки 

2. Вставка рабочей группы до или после курсора, используя 
вернее меню: Insert->Execution Group-> Before/After Cursor

 Из режима Worksheet Mode в режим Document Mode

Format-> Create Document Block

Format-> Remove Document Block

 Удаление элемента рабочей группы или документного блока

Edit->Delete Element



Использование справочной системы Maple
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 [F1] – быстрая справка Quick Help

 [F2] – справка по команде

 [Ctrl]+[F1] – открывает справочную систему

 [Ctrl]+[F2] – краткая справка Quick Reference



Синтаксис Maple

Синтаксис команд

Использование пакетов команд

Команда restart; операторы :=, #, %

Нумерация результатов и ссылки на них



Синтаксис команд Maple
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 Команды верхнего уровня доступны непосредственно

➢ command(arg1,arg2,…);

 Для команд из пакетов требуется подключение пакета:

➢ package[command](arg1,arg2,…);

➢ with(package): command(arg1,arg2,…);



Синтаксис Maple: использование пакетов с командами
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 Подключение пакета

➢ with(package):

command(arg1,arg2,…);

 Отключение пакета

unwith(package):

 Пример, когда требуется отключение пакета:  есть две 
одинаковых команды changecoords – верхнего уровня и в 
пакете plots



Важные операторы
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 Оператор присваивания :=

 Команда restart – очистка памяти

 Знак комментария # (игнорирование ввода)

 Вызов предыдущего результата %

➢ предпред- и предпредпредыдущего результата %% и %%%



Нумерация результатов и ссылки на них
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 Все результаты вычислений нумеруются (как в Worksheet 
Mode, так и в Document Mode), на них можно ссылаться

 Insert->Label или [Ctrl]+[L]

 Если нумерация не отображается: 

Tools->Options->Display->Show equation labels



Основные объекты, виды 
вычислений и типы данных в Maple

Основные объекты Maple
➢ Числа
➢ Константы
➢ Символьные объекты (имена)
➢ Переменные
Виды вычислений
Основные типы данных



Основные объекты в Maple
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 Простейшими объектами в Maple являются:

➢Числа

➢Константы

➢Символьные объекты (имена)

➢Переменные



 Из простых объектов Maple можно составлять 
выражения Maple, используя знаки математических 
операций (математические выражения), логических 
операций (логические выражения) и др.



Числа
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Константы
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 В Maple содержится несколько предопределенных 
именованных (символьных) констант. 

 К значению констант можно обратиться, используя их имена 
либо соответствующие им символы. 

 Константа в Maple – это объект, значение которого нельзя 
изменить с помощью оператора присваивания.

 Математические константы

 Логические константы  true, false, FAIL 

 Научные константы (доступны при подключении пакета 
Scientific Constants), категории: физические константы и 
константы свойств химических элементов и изотопов



Символьные объекты (имена)
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 Символьный объект - любая комбинация букв, цифр и 
знаков подчеркивания, начинающаяся с буквы, без 
использования знаков математических операций. В 
именах можно использовать буквы национального 
алфавита, включая русский. 

 Символом считается любая последовательность любых 
знаков, заключенных в обратные кавычки.



Переменные
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 Символы используются для описания переменных. 
Значение переменной задается с помощью оператора 
присваивания :

имя переменной := значение переменной

 В качестве имен переменных можно использовать любые 
пользовательские разрешенные имена или любую 
комбинацию знаков, заключенных в обратные кавычки. 

 Нельзя использовать зарезервированные имена, такие 
как имена констант Maple, названия команд Maple, 
системных переменных, логических операторов, 
служебных слов структур программирования и др. (даже 
когда они заключены в обратные кавычки)



Примеры задания переменных

29



Отмена присваивания
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 имя переменной := 'значение переменной'

 unassign('a')



Виды вычислений в Maple
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 символьные (точные) – аналитические 
преобразования выражений, содержащих символьные 
величины, переменные, функции и точные числа.

 численные (приближенные, floating-point 
computations) – используется арифметика конечной 
точности, при таких вычислениях используются 
приближенные значения точных величин, такие 
вычисления всегда содержат некоторую погрешность.



Обзор используемых в Maple кавычек
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В Maple существует около 200 типов данных, в том числе: 
 типы математических операций: 

 `+` (сложение)
 `*` (умножение)
 `^` (возведение в степень)

 типы сравнения: 
 `<` (меньше) 
 `<=` (меньше или равно)
 `<>` (не равно)

 типы логических операций
 числовые типы, например:

 integer – целое число
 float – число с плавающей точкой
 fraction – рациональная дробь 

 тип символ (symbol)

Основные типы данных
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 whattype(x) – выдает тип объекта x

 type(x,x_type) – проверяет объект x на соответствие типу x_type
и выдает одну из логических констант: true (истина), false
(ложь) или FAIL (не определено)

Команды определения типа данных
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 Тип переменной может меняться в зависимости от присвоенного ей 
значения:

Команды определения типа данных: примеры
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Операции оценивания выражений

➢Семейство команд eval
➢eval
➢evalf
➢evalb
➢evalc
➢evalm

➢Оценивание вещественных выражений
➢Оценивание комплексных выражений



 eval(x) – вычисление значения выражения x
 eval(expr, x = a) – вычисление значения выражения expr при 

x=a

 evalf(x) – вычисление приближенного значения выражения x
evalf[n](x) – приближенное значение x с выводом n цифр 
числа

 Переменная среды Digits – задает количество цифр в числах с 
плавающей точкой
Digits := n
(n – натуральное число, по умолчанию n=10)

 evalc(x) – вычисление значения  комплексного выражения
 evalb(x) – вычисление значения  логического выражения
 evalm(x) – вычисление значения  матричного выражения

Семейство команд eval
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Команды eval и evalf: примеры
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Другие команды семейства eval: примеры
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Оценивание вещественных выражений
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trunc(x) – вычисление целой части вещественного выражения x
frac(x) – вычисление дробной части вещественного выражения x
round(x) – округление вещественного выражения x



Оценивание комплексных выражений
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Re(z) – вещественная часть
Im(z) – мнимая часть
conjugate(z) – комплексно сопряженное выражение
polar(z) – модуль и аргумент
evalc(z) – вычисление значения комплексного выражения



Команды преобразования выражений

➢Стандартные математические функции
➢Команды для работы с целыми числами
➢Выделение правой и левой частей выражения, 
числителя и знаменателя дроби
➢Приведение дроби к нормальному виду
➢Разложение многочлена на множители
➢Приведение подобных
➢Раскрытие скобок
➢Преобразование и упрощение выражений



Стандартные математические функции
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Математическая запись Синтаксис Maple (1D-Math Input)

exp(x)

ln(x)

log10(x)

log[a](x)

abs(x)

sqrt(x)

signum(x)

root(x,n)

n!

Dirac(x)

xе

xln

x10log

xalog

x

x
xsgn

n x

!n
)(x



Тригонометрические и гиперболические функции
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Математическая запись Синтаксис Maple (1D-Math Input)

sin(x)

cos(x)

tan(x)

cot(x)

sinh(x)

cosh(x)

tanh(x)

coth(x)

sec(x)

csc(x)

xsin

xcos

tgx

ctgx

shx

chx

thx

ctgx

xsec

cosecx



Обратные тригонометрические и гиперболические 
функции
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Математическая запись Синтаксис Maple (1D-Math Input)

arcsin(x)

arccos(x)

arctan(x)

arccot(x)

arcsinh(x)

arccosh(x)

arctanh(x)

arccoth(x)

arcsec(x)

arccsc(x)

xarcsin

xarccos

arctgx

arcctgx

arcshx

arcchx

arcthx

arcctgx

xarcsec

arccosecx



Команды для работы с целыми числами
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isprime(n) – булева функция, проверяющая, является ли число простым
ifactor(n) – разложение на простые сомножители
irem(n,m) – вычисление остатка от деления n на m
iquo(n,m) – вычисление частного от деления n на m



Команды для работы с целыми числами
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igcd(n1,n2, …) – вычисление наибольшего общего делителя чисел n1, n2, …
ilcm(n1,n2, …) – вычисление наименьшего общего кратного чисел n1, n2, …
isqrt(n) – целый квадратный корень
iroot(n) – целый корень n-й степени



Команды извлечения корня
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root(x,n) – корень n-й степени алгебраического выражения (n- целое)
surd(x,n) – корень n-й степени от x, чей (в общем случае комплексный) аргумент 

наиболее близок к x
Если n – нечетное и 
x>=0, то surd(x,n) = x^(1/n)
x<0, то surd(x,n) = -(-x)^(1/n).



Выделение правой и левой частей выражения: rhs, lhs
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lhs(expr) – выделение левой части
rhs(expr) – выделение правой части



Выделение числителя и знаменателя рациональной 
дроби: numer, denom
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numer(x) – выделение числителя дроби (алгебр. выражения)
denom(x) – выделение знаменателя дроби (алгебр. выражения)



Приведение дроби (алгебраического выражения) к 
нормальному виду: normal
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normal(x) – приведение дроби (выражения) к нормальному виду
normal(x,expanded) – приведение дроби (выражения) к нормальному 

виду с раскрытием скобок в многочленах



Разложение многочлена на множители: factor
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factor(p) – разложение многочлена p на множители



Раскрытие скобок: expand
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expand(expr) – раскрытие скобок в алгебраическом выражении



Приведение подобных: collect
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collect(expr,var) – приведение подобных членов выражения
expr относительно переменной var



Преобразование выражений: combine
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combine(expr) – преобразование нескольких членов в один
combine(expr,param) – преобразование нескольких членов в 

один с использованием параметров: exp, trig, power и др.



Упрощение выражений: simplify
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▪ simplify(expr) – упрощение выражения
▪ simplify(expr,param) – упрощение выражения с использованием 

параметров: exp, trig, power и др.
▪ simplify(expr,assume=prop) – упрощение выражения в 

предположении свойства  prop


