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ВВЕДЕНИЕ 
 

Цель лабораторной работы – познакомить учащихся с основ-
ными приёмами компьютерного моделирования напряжённо де-
формированного состояния ферм в среде профессионального про-
граммного комплекса ANSYS. 

Фермой называется неизменяемая конструкция из прямых 
стержней, соединённых между собой шарнирами . Силы приклады-
ваются к шарнирам - узлам фермы. Закрепления осуществляются 
также в узлах. В стержнях фермы действуют только продольные 
(нормальные к поперечным сечениям) внутренние силы.  

Статический расчёт фермы заключается в определении пере-
мещений узлов, реакций опор, усилий в стержнях, напряжений и 
деформаций стержней. 

Реальная стержневая конструкция с жёсткими узлами –
сварными, болтовыми или заклёпочными соединениями - может 
рассматриваться как ферма, если размеры узлов значительно мень-
ше расстояний между узлами. В таких конструкциях, как и в фер-
мах, вдали от узлов действуют только продольные внутренние си-
лы. В области жёстких узлов картина внутренних сил более слож-
ная и может исследоваться только приближёнными методами со-
противления материалов или теории деформированного твёрдого 

тела.  
 

Р и с. 1. Конечно элементная модель фермы 
 

Рассмотрим ферму, показанную на рис. 1, имеющую n узлов и 
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m стержней, у которой оси стержней и силы лежат в одной плоско-
сти. Перемещения также ограничим этой плоскостью. Такая ферма 
называется плоской, или двумерной. 

Ферму сразу можно анализировать как конечно-элементную 
модель. Стержни являются одномерными конечными элементами, 
испытывающими только деформацию растяжения – сжатия, их на-
зывают ферменными конечными элементами. Шарнирные соеди-
нения являются узлами конечно-элементной модели. В качестве 
степеней свободы берутся узловые перемещения, которые полага-
ются малыми.  

Ферменный (одномерный) конечный элемент показан на рис.2. 
С ним связана местная (локальная) система координат yx, . Общая 
(глобальная) для всей фермы система координат x,y перенесена па-
раллельным переносом в узел i .  

Векторы узловых перемещений и узловых сил элемента в мест-
ной системе координат: 
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Р и с.2. Ферменный (одномерный) конечный  элемент 
 

Векторы узловых перемещений и узловых сил элемента в 
общей системе координат: 
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Вектор узловых перемещений всей фермы в общей системе 
координат: 
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Вектор всех внешних узловых сил, действующих на ферму, в 
общей системе координат: 
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В теории метода конечных элементов (МКЭ) [1,2] устанавлива-
ется связь между векторами узловых перемещений и узловых сил 
элемента в виде матричного соотношения 

     eee FUK  ,                                            (1) 
где   eК  -матрица жёсткости элемента. 

Условия равновесия узлов фермы с учётом предыдущего вы-
ражения порождают разрешающую систему уравнений МКЭ: 

    PUK  ,                                               (2) 
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где  К  -глобальная матрица жёсткости всей конечно-элементной 
модели, которая формируется из матриц жёсткости элементов. 

Для однозначного решения уравнений (2) необходимо в них 
учесть граничные условия по перемещениям, в частности, закреп-
ления. Конструкция должна закрепляться так, чтобы было невоз-
можным перемещение её как твёрдого тела. 

В результате решения системы уравнений (2) определяются уз-
ловые перемещения  U , через которые по формулам теории упру-
гости вычисляются все другие искомые величины. 

 
1.ПОСТАНОВКА ЗАДАЧИ 

 
Конструкция, закрепления и нагрузки исследуемой фермы по-

казаны на рис 1. P=1000 H, a=2 м, b=3м, h=2м, Площадь сечения 
стержней S=10 мм2 = 10-5 м2.Материал: сталь, модуль упругости 
Е=2*1011Н/м2, коэффициент Пуассона =0,3. 

Нужно определить перемещения фермы, усилия и напряжения 
в стержнях, а также реакции опор. 

 
2. МОДЕЛИРОВАНИЕ В ANSYS. 

 

Задаче присваивается имя ferma: 
U.M. > File > Change Jobname > [/FILNAM] = ferma 

New log.= Y > ok. 
Выбирается тип анализа: 

MM >Preference > Y structural >ok. 
 

2.1. Операции моделирование в препроцессоре 
 

Выбирается тип элемента –стержень Link 1 с плоским пере-
мещением 2D: 

М.М.> Рrepr.> Element Type > Add/Edit/ > Add > Link > 2D spar 
1 > ok. Закрывается окно Element Types > close. 

Задаются константы (площадь сечения S для элементов): 
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M.M.> Prepr.> Real Const.>Add/Edit >Add > ( Type1 Link1 ) > 
ok. В появившемся окне вводится площадь AREA =1.e –5 > ok. За-
крывается окно SET 1 > close. 

Задается тип материала и его свойства: 
M.M.> Prepr. > Material Props > Materials Models >Structural (  

click)-linear( click)>Elastic(  click)-Isotropic > набираются EX = 2.e11 
(модуль упругости), PRXY = 0.3 (коэффициент Пуассона) > оk. За-
крывается окно Define Materials > Materials >Exit. 

Сохраняется модель в бинарном файле ferma.db: 
Ans.Toolbar > SAVE_DB. 

Построение конечноэлементной модели прямым методом 
Строятся узлы: 

M.M.> Preper >Modeling > Create > Nodes >in Active CS >                  
NODE = 1 > X,Y,Z = 0.       0. > Apply; 
NODE = 2 > X,Y,Z =  2.       2. > Apply; и т.д. > ok. 

Строятся элементы-стержни: 
M.M > Prepr > Modeling > Creat > Elements > Auto Numbered > 

Tru Nodes > 
Click узел 1 > click узел 3 > Apply (на панели Elem.from.); 
Click узел 3 > click узел 2 > Apply, и т.д. строятся все элементы - 
стержни согласно рис.1 > ok. 

Нумерация узлов и элементов: 
U.M.> Plot Ctrls > Numbering > Y NODE > Elem/At.> Elem numbers 
> ok. 

Присвоение элементам атрибутов (в данной задаче выпол-
няется по умолчанию и можно эту операцию пропустить): 
M.M > Prepr > Modeling > Create > Elements > Elem Attributes > 
TYPE=1 LINK1,   MAT=1,   REAL=1,   ESYS = 0 > ok. 

Сохраняется модель: Ans.Toolbar > SAVE_DB. 
 

2.2. Операции моделирования в процессоре Solution 
 

Задаётся типа анализа (можно пропустить т.к. данный тип 
анализа принимается по умолчанию): 
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M.M > Solution > Analysis Type > New Analysis > ANTYPE = static 
> ok 

Ферма закрепляется: 
M.M > Solution >Define Loads> Apply > Structural > Diplasment > On 
nodes > Click узел 1 > apply > в появившемся окне выбирается All 
DOF,  const val, VALUE = 0 > apply, 
Click узел 6 > apply > в появившемся окне выбирается UY, const 
val, VALUE = 0 > ok.. 

Прикладываются нагрузки: 
M.M.> Solution > Define Load > Apply > Structural > Forse > on 
Nоdes > 
Click узел 2 >Apply > FY > Const Value,VALVE =-1.e3, Apply, 
Clcik узел 5 > ok > FY > Const Value ,VALVE =-1.e3, ok. 

Изображение опор и нагрузок: 
U.M > ProtCtrl > Sumbol > /PBC = All BC+Reaction > ok. 

Сохранение модели: Ans.Toolbar > SAVE_DB. 
Решение задачи: 

M.M > Solution > Solve > Carent LS > 
Закрывается панель /STATUS > File > Exit > закрывается панель 
Solve > ok. 

Сообщение Solution is done! (решение выполнено) > 
close (закрывается информационное окно). 

Сохранение модели: Ans.Toolbar >SAVE_DB. 
 

2.3. Просмотр результатов в постпроцессоре. 
 

Анализ перемещений фермы: 
General Postproc > Plot Resalts > deform. Shape > KUND = def + un-
def > ok 
U.M.> Plot > Replot. Появляется рисунок. 

Сохранение рисунка в графическом файле в рабочей папке: 
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General Postproc > PlotContrls > Hard Copy > to file появляется па-
нель > устанавливаются флажки Jpeg, Reverse Video и имя файла в 
окне save to > ok 

Анализ реакций: 
General Postproc.> List Results > Reaction Solu > Lab = All items > 
ok. Появляется таблица реакций, выход - file > close. Если требует-
ся сохранить таблицу в файле, то производятся команды - file > 
Save as > указывается папка и имя файла > нажимается кнопка 
«сохранить». 

Анализ усилий и напряжений в стержнях. 
General Post..> Elem. Table > Define Table > Add > в появившихся 
окнах набирается  Lab = sila, Item = By seguence > SMISC,1  (код 
для вывода сил) >Apply, 
Lab = Napr, Item = By seguence > LS,1 (код для вывода напряжений) 
>ok. Закрывается панель Elem.Table > close. 

Просмотр таблицы усилий и напряжений: 
General Post. > Elem.Table > List Elem.Table > Lab 1-9 = sila, Napr > 
ok > Появляется таблица сил и напряжений. Выход из таблицы или 
её сохранение производятся так же , как в случае просмотра табли-
цы реакций. 

Графическое представление сил в стержнях фермы: 
General Postproc > Plot Resalts > Contour Plot > Elem Table > всплы-
вает панель > устанавливается itlab item to be Plotted = sila > Apply > 
появляется рисунок фермы, где цветом определены силы в стерж-
нях. 

Графическое представление напряжений в стержнях:  
General Postproc > Plot Resalts > Contour Plot > Elem Table > всплы-
вает панель > устанавливается itlab item to be Plotted = Napr > Apply 
> появляется рисунок фермы, где цветом определены напряжения в 
стержнях. 
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3. ВЫПОЛНЕНИЕ САМОСТОЯТЕЛЬНОЙ РАБОТЫ 
 

По образцу предыдущего примера требуется выполнить моде-
лирование деформированного состояния своего варианта фермы, 
номер которого задаётся преподавателем. Схемы ферм для различ-
ных вариантов даны на рис.3 - 12. Необходимые параметры для 
разных вариантов задания приведены в таблице. 

 

4. ОФОРМЛЕНИЕ ОТЧЁТА. 
 

Отчёт должен включать следующие пункты. 
1. Постановка задачи для своего варианта: 

1.1. Силовая схема (конструкция, закрепления, силы); 
1.2. Исходные данные (величины сил, свойства материала); 
1.3. Что требуется найти. 

2. Короткое описание процедуры моделирования в ANSYS. 
3. Результаты решения задачи в ANSYS: 

3.1. Схема деформированной конструкции, наложенная на схе-
му недеформированной фермы, с указанием наибольшего 
смещения; 

3.2. На силовой схеме нужно показать распределение реакций и 
указать величин реакции; 

3.3. Таблица реакций. 
3.4. Таблица сил и напряжений в стержнях; 

4. Составить 3 уравнения равновесия плоской фермы и из этих 
уравнений найти реакции опор. Сравнить эти реакции с найден-
ными ранее при моделировании задачи в среде ANSYS. 

 
5.КОНТРОЛЬНЫЕ ВОПРОСЫ 

 

1. Какая конструкция называется фермой. 
2. Как нагружается и закрепляется ферма. 
3. Какой конечный элемент используется для расчёта ферм. 
4. Какие деформации имеет ферменный конечный элемент. 
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5. Степени свободы узла фермы. 
6. Векторы степеней свободы ферменных элементов и фермы. 
7. Векторы узловых сил ферменных элементов. 
8. Матричная запись разрешающей системы уравнений МКЭ. 
9. Основные операции  моделирования фермы в препроцессоре. 
10. Основные операции расчёта фермы в процессоре-решателе. 
11. Основные операции анализа фермы в постпроцессоре. 
12. Как определяется опасный стержень фермы. 
13. Каковы условия равновесия узла фермы. 
14. Условия равновесия плоской фермы как твёрдого тела. 
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Таблица 
ЗАДАНИЯ К РАСЧЁТУ ФЕРМ 

 

Размеры фермы, м Углы, град Силы, кН № 
ва-
ри-
анта 

№ 
Фер-
мы 

a b c d l α β P1 P2 P3 

1 1 1 1 2   30 45 2 3 4 
2 1 2 3 1   60 30 3 2 5 
3 2 2 2 3 2  45 60 1 2 3 
4 2 1 1 4 3  30 45 3 1 2 
5 3 2 2 1 3  60 45 2 1 3 
6 3 1 1 1 2  30 60 1 3 2 
7 4 2 2 1 1  60 30 1 2 3 
8 4 3 1 2 2  30 45 3 4 2 
9 5 1 1 1 1 2 45 60 4 2 1 

10 5 2 1 1 2 1 60 30 3 3 2 
11 6 2 2 1 1  30 45 2 1 1 
12 6 3 3 2 1  45 60 1 2 2 
13 7 1 2 4 2  60 30 3 1 2 
14 7 2 2 3 1  30 45 2 4 1 
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15 8 1 1 1 2 1 45 30 1 2 1 
16 8 2 2 1 1 2 60 45 1 3 2 
17 9 1 2 1 1  30 60 1 3 1 
18 9 2 3 1 2  45 30 2 1 3 
19 10 2 2 3   60 45 3 4 1 
20 10 1 3 2   30 60 1 2 3 

 
КОНСТРУКТИВНЫЕ СХЕМЫ ФЕРМ 

 
    Р и с. 3. Ферма №1                                            Р и с. 4. Ферма №2 

       Р и с. 5. Ферма №3                                     Р и с. 6. Ферма №4 

       Р и с. 7. Ферма №5                                     Р и с. 8. Ферма №6   
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            Р и с. 9. Ферма №7                             Р и с. 10. Ферма №8 
 
 
 
 
 

 

        Р и с. 11. Ферма №9                             Р и с. 12. Ферма №10 
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