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Preface

The Maple Software
The MapleTM software is a powerful system that you can use to solve complex
mathematical problems. You can also create professional quality documents,
presentations, and custom interactive computational tools in the Maple en-
vironment.

You can access the power of the Maple computational engine through a
variety of interfaces.

DescriptionInterface

Full-featured graphical user interface offering features
that help you create electronic documents that show all
your assumptions, the calculations, and any margin of
error in your results; or hide the computations to allow
your reader to focus on the problem setup and final res-
ults. The advanced formatting features help you create
the customized document you need. Because the docu-
ments are live, you can edit the parameters and, with the
click of a button, compute the new results.

The User Manual was created using the Standard
Worksheet interface to Maple. An interactive version of
this manual is available in the Standard Worksheet inter-
face. From the Help menu, select Manuals, Dictionary,
and more>Manuals>User Manual.

Standard Worksheet

Basic worksheet environment for older computers with
limited memory.

Classic Worksheet

Command-line interface, without graphical user inter-
faces features, for solving very large complex problems
or batch processing with scripts.

Command-line version

Graphical calculator interface to the Maple computational
engine. Using it, you can perform simple computations
and create customizable, zoomable graphs.

MaplesoftTM Graphing Calculator

(Microsoft® Windows® only)
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DescriptionInterface

Graphical user interface containing windows, textbox
regions, and other visual interfaces, which gives you
point-and-click access to the power of Maple. You can
perform calculations and plot functions without using
the worksheet or command-line interfaces.

MapletTM Applications

This manual describes how to use the Standard Worksheet interface. Some
features are not available in the Classic Worksheet interface and Command-
line version. The Standard Worksheet interface has two modes: Document
mode and Worksheet mode.

Document Mode - Using the Document mode, you can perform quick cal-
culations. You can enter a mathematical expression, and then evaluate, ma-
nipulate, solve, or plot with a few keystrokes or mouse clicks.

Worksheet Mode - The Worksheet mode is designed for:

• Interactive use through Maple commands, which may offer advanced
functionality or customized control not available using context menus
or other syntax-free methods

• Programmatic use of the powerful Maple language

Using either mode, you can create high quality interactive mathematical
presentations or documents.

In This Manual
This manual provides an overview of all Maple features including:

• Performing computations

• Creating plots and animations

• Creating interactive documents

• The Maple programming language

• Using and creating custom Maplet applications
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• File input and output, and using Maple with third party products

• Data structures

For a complete list of manuals, study guides, toolboxes, and other resources,
visit the Maplesoft Web site at http://www.maplesoft.com.

Audience
The information in this manual is intended for Maple users who have read
the Maple Getting Started Guide.

Conventions
This manual uses the following typographical conventions.

• bold font - Maple command, package name, option name, dialog, menu,
and text field

• italics - new or important concept

• Note - additional information relevant to the section

• Important - information that must be read and followed

Customer Feedback
Maplesoft welcomes your feedback. For suggestions and comments related
to this and other manuals, contact doc@maplesoft.com

Preface   •   xv
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1  Document Mode
Using the Maple software, you can create powerful interactive documents.
You can visualize and animate problems in two and three dimensions. You
can solve complex problems with simple point-and-click interfaces or easy-
to-modify interactive documents. You can also devise custom solutions using
the Maple programming language. While you work, you can document your
process, providing text descriptions.

1.1  Introduction
Maple has two modes: Document mode and Worksheet mode.

Document mode is designed for quickly performing calculations. You can
enter a mathematical expression, and then evaluate, manipulate, solve, or
plot it with a few keystrokes or mouse clicks. This chapter provides an
overview of Document mode.

Document mode sample:

Find the value of the derivative of  at .

Integrate  over the interval .

 = 

Worksheet mode is designed for interactive use through commands and
programming using the Maple language. The Worksheet mode supports the
features available in Document mode described in this chapter. After review-
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ing the information in this chapter, see Chapter 2, Worksheet Mode (page 35),
for information on using Worksheet mode.

Worksheet mode sample:

Find the value of the derivative of  at .

> 

(1.1)

> 

(1.2)

> 

Integrate  over the interval .

> 

Important: In any Maple document, you can use Document mode and
Worksheet mode.

Using either mode:
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• You have access to the full mathematical engine.

• You can create high quality interactive documents: easy-to-use compu-
tational tools, presentations, or publications.

Interactive document features include:

• Embedded graphical interface components, like buttons, sliders, and
check boxes

• Automatic execution of marked regions when a file is opened

• Tables

• Character and paragraph formatting styles

• Hyperlinks

These features are described in Chapter 6, Creating Mathematical Docu-
ments (page 231).

Note: This chapter was created using Document mode. All other chapters
were created using Worksheet mode.

1.2  In This Chapter
TopicsSection

• Text and Math Modes

• Rational Expressions

• Powers

• Products

• Shortcuts for Entering Mathematical Ex-
pressions

• Other Expressions

Simple Mathematical Expressions - Introduc-
tion to Math and Text modes, and how to
easily enter simple expressions
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TopicsSection

• Displaying the Value Inline

• Displaying the Value on the Following
Line

Evaluating Expressions - How to evaluate
expressions

• Updating a Single Computation

• Updating a Group of Computations

• Updating All Computations in a Docu-
ment

Editing Expressions and Regenerating Output
- How to update expressions and results

• Palettes

• Symbol Names

Entering Expressions - Overview of tools for
creating complex mathematical expressions

• Computing with Palettes

• Context Menus

• Assistants and Tutors

Performing Computations - Overview of
tools for computing and plotting

• Table of Document Mode ToolsDocument Mode Summary - Summary of
key Document mode features

• Table of Maple Help ResourcesGetting Help - A list of resources available
in the Maple Help System

1.3  Simple Mathematical Expres-
sions
In Document mode, you can enter two types of content: Text and Math. The
Text mode and Math mode icons at the left end of the toolbar indicate the
current mode. The toolbar is located near the top of the Maple window, im-
mediately below the menu bar.

To switch between Text and Math modes, press the F5 key. (Alternatively,
click the Text mode or Math mode toolbar icon.) Consequently, it is easy
to enter sentences containing text and inline mathematical expressions.
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Entering mathematical expressions, such as , , and ,

is natural in Math mode.

Rational Expressions (Fractions)

To enter a fraction:

1. Enter the numerator.

2. Press the forward slash (/) key.

3. Enter the denominator.

4. To exit the denominator, press the right arrow key.

Powers

To enter a power:

1. Enter the base.

2. Press the caret (^) key.

3. Enter the exponent, which displays in math as a superscript.

4. To exit the exponent, press the right arrow key.

Products

To enter a product:

1. Enter the first factor.

2. Press the asterisk (*) key, which displays in math as .

3. Enter the second factor.
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Implied Multiplication

In most cases, you do not need to include the multiplication operator, .

Insert a space character between two quantities to multiply them.

Note: In some cases, you do not need to enter the multiplication operator or
a space character. For example, Maple interprets a number followed by a
variable as multiplication.

Important: Maple interprets a sequence of letters, for example, xy, as a
single variable. To specify the product of two variables, you must insert a

space character (or multiplication operator), for example, x y or . For

more information, refer to the ?2DMathDetails help page.

Shortcuts for Entering Mathematical Expressions

Table 1.1 lists shortcut keys for entering and navigating mathematical expres-
sions.

Table 1.1: Shortcuts for Entering Mathematical Expressions

Automatically Generated in
Document

KeySymbol/Format

Example using fraction:

 (Math) versus 1/4

(Text)

F5Switch between
Math and Text
modes

/ (forward slash)Fraction

^ (caret)Exponent

_ (underscore)Subscript
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Automatically Generated in
Document

KeySymbol/Format

• Ctrl + Shift + ", Windows and
UNIX®

• Command + Shift + ", Macin-
tosh®

Overscript

Enter sqrt , and then press the com-
mand/symbol completion shortcut. (See
the following row in this table.)

Square root

• Ctrl + Space, Windows

• Escape, Macintosh

• Ctrl + Shift + Space, UNIX

Command/symbol
completion

Arrow keysNavigating an ex-
pression

For a complete list of shortcut keys, refer to the Math Shortcut and Hints
help page. To access this help page in the Maple software, in Math mode
enter ?MathShortcuts and then press Enter. For information on the Maple
Help System, see Getting Help (page 32).

Other Expressions

It is also easy to enter mathematical expressions, such as:

• Piecewise-continuous functions:

• Limits: 

1.3  Simple Mathematical Expressions   •   7



• Continued fractions: 

and more complex expressions. For information, see Entering Expres-
sions (page 10).

1.4  Evaluating Expressions
To evaluate a mathematical expression, place the cursor in the expression
and press Ctrl + = (Command + =, for Macintosh). That is, press and hold
the Ctrl (or Command) key, and then press the equal sign (=) key.

To the right of the expression, Maple inserts an equal sign and then the value
of the expression.

 = 

You can replace the inserted equal sign with text or mathematical content.

To replace the equal sign:

1. Select the equal sign. Press Delete.

2. Enter the replacement text or mathematical content.

For example, you can replace the equal sign with the text "is equal to".

 is equal to 

In mathematical content, pressing Enter evaluates the expression and displays
it centered on the following line. The cursor moves to a new line below the
output.
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By default, Maple labels output that is generated by pressing Enter. For in-
formation on equation labels, see Equation Labels (page 59). In this manual,
labels are generally not displayed.

In text, pressing Enter inserts a line break.

You can use the basic algebraic operators, such as  and , with most

expressions, including polynomials—see Polynomial Algebra (page 124)—and
matrices and vectors—see Linear Algebra (page 133).

 = 

 = 

1.5  Editing Expressions and Updat-
ing Output
One important feature of Maple is that your documents are live. That is, you
can edit expressions and quickly recalculate results.

To update one computation:

1. Edit the expression.

2. Press Ctrl + = (Command + =, for Macintosh) or Enter.

The result is updated.
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To update a group of computations:

1. Edit the expressions.

2. Select all edited expressions and the results to recalculate.

3. Click the Execute toolbar icon .

All selected results are updated.

To update all output in a Maple document:

• Click the Execute All toolbar icon .

All results in the document are updated.

1.6  Entering Expressions
Mathematical expressions can contain the following symbols.

• Numbers: integers, rational numbers, complex numbers, floating-point

values, finite field elements, , ∞, ...

• Operators: , , , /, , , , , ...

• Constants: π, e, ...

• Mathematical functions: sin(x), , Γ(2), ...

• Names (variables): x, y, z, α, β, ...

• Data structures: sets, lists, Arrays, Vectors, Matrices, ...

Maple contains over a thousand symbols. For some numbers, operators, and
names, you can press the corresponding key, for example, 9, =, >, or x. Most
symbols are not available on the keyboard, but you can insert them easily
using two methods.

To insert a symbol, you can use:
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• Palettes

• Symbol names

Palettes

Palettes are collections of related items that you can insert by clicking or
dragging. Palettes contain:

• Numbers and constants, like i (the imaginary unit), π, and ∞. For example,
see the Common Symbols palette (Figure 1.1).

• Layouts, like an item with a superscript and subscript. For example, see
the Layout palette (Figure 1.2).

• Mathematical operations, like a definite integral with placeholders for
the integrand, variable of integration, and endpoints of the interval of
integration. For example, see the Expression palette (Figure 1.3).

• Specialized tools. For example, see the Matrix palette (Figure 1.4). For
information on the Matrix palette, see Creating Matrices (page 133).

Figure 1.2: Layout PaletteFigure 1.1: Common Symbols Palette
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Figure 1.4: Matrix PaletteFigure 1.3: Expression Palette

Using Palettes

To insert a palette item:

1. In the palette, click the item to insert. The item is inserted at the cursor
location.

2. If the item has colored placeholders, specify values for them.

• To move to the next placeholder, press the Tab key.

Note: You can drag palette items to any location in the document.

For example, to insert the constant π:

• In the Common Symbols palette, click the π symbol.

or

• From the Common Symbols palette, drag the π symbol to the appropriate
location in the document.

Table 1.2 shows how to enter a definite integral.
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Table 1.2: Entering a Definite Integral

Result in DocumentAction

1. In the Expression palette, click the definite

integration item . Maple inserts the
definite integral. The left endpoint placeholder
is selected.

2. Enter 0, and then press Tab. The right end-
point placeholder is selected.

3. Enter 1, and then press Tab. The integrand
placeholder is selected.

4. Enter , and then press Tab. The variable

of integration placeholder is selected.

5. Enter x.

To evaluate the integral, press Ctrl+= (Command+=, for Macintosh) or
Enter. For more information, see Computing with Palettes (page 20).
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Defining a Mathematical Function

To define a function of one or two variables:

1. In the Expression palette, click one of the function definition items (Figure
1.5). Maple inserts the function definition.

2. Replace the placeholder f with the function name. Press Tab.

3. Replace the parameter placeholders, x or x1, x2, with the independent
variable names. Press Tab.

4. Replace the final placeholder, y, with the expression that defines the
function value. Press Enter.

Figure 1.5: Function Definition Palette Items

For example, define a function that doubles its input.

 = 

 = 

Note: To insert the right arrow symbol , you can also enter the characters
->.

Important: The expression  is different from the function .

For more information on functions, see Functional Operators (page 292).
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Viewing and Arranging Palettes

By default, palettes are displayed in palette docks at the sides of the Maple
window. If no palette dock is visible, use the following procedure.

To view palette docks:

• From the View menu, select Palettes, and then Expand Docks.

To expand a palette in a palette dock:

• Click the triangle at the left of the palette title.

To move a palette in a palette dock:

• Drag the palette (by clicking its title) to the new location.

Adding Palettes to the Palette Docks

Maple has over 20 palettes. By default, only a few palettes are in the palette
docks. To add a palette to a palette dock, use the following procedure.

To add a palette:

1. Right-click (Control-click, for Macintosh) a palette dock. Maple displays
a context menu—a menu that lists actions you can perform on the ob-
ject—near the palette.

2. From the context menu, select Show Palette, and then select the palette.

Handwriting Palette

Finding the right symbol to insert can be time consuming. The Handwriting
palette provides an efficient way to find and insert the right symbol. You
draw the symbol with your mouse and then Maple matches your input against
items available in the system. See Figure 1.6.
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Figure 1.6: Handwriting Palette

To use the Handwriting palette:

1. With your mouse, draw a symbol in the handwriting recognition region
(sketch area).

2. Click the  button. A list of potential matching symbols is
displayed. To view more symbols (where indicated), click the drop-down
arrows associated with the displayed symbols.

3. To insert a symbol, click the displayed symbol.

Symbol Names

Each symbol has a name, and some have aliases. By entering its name (or
an alias) in Math mode, you can insert the symbol.

Note: If you hover the mouse pointer over a palette item, a tooltip displays
the symbol's name.
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Using Symbol Names

To insert a symbol by entering its name:

1. In Math mode, enter the symbol name.

2. Press the symbol completion shortcut key. See Table 1.3.

Maple inserts the corresponding symbol.

Table 1.3: Symbol Completion Shortcut Keys

Shortcut KeyOperating System

Ctrl + SpaceWindows

EscapeMacintosh

Ctrl + Shift + SpaceUNIX

For example, to find the square root of :

1. Enter sqrt.

2. Press the completion shortcut key. Maple displays a pop-up list of exact

matches .

3. In the completion list, select . Maple inserts the symbol with the 

placeholder selected.

4. Enter 603729.

5. Press Ctrl + = (Command + =, for Macintosh).

 = 
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Using Partial Symbol Names

To enter a symbol quickly, you can enter the first few characters of its name
and then press the completion shortcut key (see Table 1.3).

• If a unique symbol name matches the characters entered, Maple inserts
the corresponding symbol.

• If multiple symbol names match the characters entered, Maple displays
the completion list, which lists all matches. To select an item, click its
name or symbol.

For example, if you enter i and then press the completion shortcut key, Maple
displays:

For example, to multiply two complex numbers:

• Use the symbol name and completion list to enter the imaginary unit,

.

 = 

Example: Indefinite Integral

You can enter any expression using symbol names and the completion list.

For example, to enter the indefinite integral :
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1. In Math mode, enter int. Press the completion shortcut key.

2. From the completion list, select the indefinite integral item .

3. Enter sin(x).

4. Enter d. Press the completion shortcut key.

5. From the completion list, select d (differential).

6. Enter x.

Note: From the int completion list, you can directly insert .

1.7  Performing Computations
Using the Document mode, you can access the power of the advanced Maple
mathematical engine without learning Maple syntax. In addition to solving
problems, you can also easily plot expressions.

The primary tools for syntax-free computation are:

• Palettes

• Context menus

• Assistants and tutors

Note: The Document mode is designed for quick calculations, but it also
supports Maple commands. For information on commands, see Com-
mands (page 39) in Chapter 2, Worksheet Mode (page 35).

Important: In Document mode, you can execute a statement only if you
enter it in Math mode. To use a Maple command, you must enter it in Math
mode.
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Computing with Palettes

As discussed in Palettes (page 11), some palettes contain mathematical op-
erations.

To perform a computation using a palette mathematical operation:

1. In a palette that contains operators, such as the Expression palette, click
an operator item.

2. In the inserted item, specify values in the placeholders.

3. To execute the operation and display the result, press Ctrl+= (Com-
mand+=, for Macintosh) or Enter.

For example, to evaluate  inline:

1. Using the Expression palette, enter the definite integral. See Table
1.2 (page 12).

2. Press Ctrl+= (Command+=, for Macintosh).

 = 

Context Menus

A context menu is a pop-up menu that lists the operations and actions you
can perform on a particular expression. See Figure 1.7.
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Figure 1.7: Context Menu

To display the context menu for an expression:

• Right-click (Control-click, for Macintosh) the expression.

The context menu is displayed beside the mouse pointer.

You can evaluate expressions using context menus.

• The Evaluate and Display Inline operation (see Figure 1.7) is equivalent
to pressing Ctrl+= (Command+=, for Macintosh). That is, it inserts an
equal sign (=) and then the value of the expression.

• The Evaluate operation (see Figure 1.7) is equivalent to pressing Enter.
That is, it evaluates the expression and displays the result centered on
the following line.

For more information on evaluation, see Evaluating Expressions (page 8).

From the context menu, you can also select operations different from evalu-
ation. To the right of the expression, Maple inserts a right arrow symbol (→)
and then the result.
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For example, use the Approximate operation to approximate a fraction:

You can perform a sequence of operations by repeatedly using context menus.

For example, to compute the second derivative of  use the Differ-

entiate operation on the expression, and then again on the output:

The following subsections provide detailed instructions on performing a few
of the numerous operations available using context menus. Figures in the
subsections show related context menus or palettes.

Approximating the Value of an Expression

To approximate a fraction numerically:

1. Enter a fraction.

2. Display the context menu. See Figure 1.8.

3. From the context menu, select Approximate, and then the number of
significant digits to use: 5, 10, 20, 50, or 100.
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Figure 1.8: Approximating the Value of a Fraction

You can replace the inserted right arrow with text or mathematical content.

To replace the right arrow ( ):

1. Select the arrow. Press Delete.

2. Enter the replacement text or mathematical content.

Note: To replace the the right arrow with text, you must first press F5 to
switch to Text mode.

For example, you can replace the arrow with the text "is approximately equal
to" or the symbol ≈.

 is approximately equal to 
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Solving an Equation

You can find an exact (symbolic) solution or an approximate (numeric)
solution of an equation. For more information on symbolic and numeric
computations, see Symbolic and Numeric Computation (page 66).

To solve an equation:

1. Enter an equation.

2. Display the context menu.

3. From the context menu, select Solve or Solve Numerically.

For more information on solving equations, including solving inequations,
differential equations, and other types of equations, see Solving Equa-
tions (page 77).

Using Units

You can create expressions with units. To specify a unit for an expression,
use the Units palettes. The Units (FPS) palette (Figure 1.9) contains import-
ant units from the foot-pound-second (FPS) system of units used in the United
States. The Units (SI) palette (Figure 1.10) contains important units from
the international system (SI) of units.
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Figure 1.10: SI Units PaletteFigure 1.9: FPS Units Palette

To insert an expression with a unit:

1. Enter the expression.

2. In a unit palette, click a unit symbol.

Note: To include a reciprocal unit, divide by the unit.

To evaluate an expression that contains units:

1. Enter the expression using the units palettes to insert units.

2. Right-click (Control-click, for Macintosh) the expression.

3. From the context menu, select Units and then Simplify.

For example, compute the electric current passing through a wire that con-
ducts 590 coulombs in 2.9 seconds.

For more information on using units, see Units (page 96).
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Assistants and Tutors

Assistants and tutors provide point-and-click interfaces with buttons, text
input regions, and sliders.

Assistants

Assistants help you accomplish many tasks, such as solving ordinary differ-
ential equations (ODEs) and ODE systems, creating plots, curve fitting, im-
porting data, and building an installer (Figure 1.11).

• From the Tools menu, select Assistants, and then one of the topic sub-
menus.

Figure 1.11: Installer Builder Assistant

Tutors

Over 40 interactive tutors help student users gain insight and understanding
of topics in courses such as precalculus, calculus, multivariate calculus,
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vector calculus, and linear algebra. Some tutors help you work through a
problem step-by-step.

• From the Tools menu, select Tutors, and then one of the topic submenus.

For example, you can create a plot of the compositions of two functions using
the Function Composition Tutor.

To use the Function Composition Tutor:

1. From the Tools menu, select Tutors, Precalculus, and then Compositions.
The Function Composition Tutor is displayed. See Figure 1.12.

2. In the f(x) = and g(x) =  text fields, enter the two functions.

3. Click the Display button. The tutor displays the compositions g(f(x)) and
f(g(x)).

4. To insert the plot into your document, click the Close button.
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Figure 1.12: Function Composition Tutor

Using a Context Menu to Launch the Plot Builder

You can plot a mathematical expression using the Interactive Plot Builder.

The Plot Builder can be launched from the Tools menu or the context menu
for an expression.

To create a plot using a context menu:

1. Enter or compute a mathematical expression with one or two independent
variables.
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2. Right-click (Control-click, for Macintosh) the expression to plot.

3. From the context menu, select Plots, and then Plot Builder. The Interact-
ive Plot Builder is displayed. See Figure 1.13.

4. In the Select Plot Type dialog, select the plot type, for example, 3-D plot
or 2-D contour plot.

5. To immediately create a plot, click the Plot button. To customize the plot
before generating it, click the Options button.

Figure 1.13: Interactive Plot Builder: Select Plot Type Dialog

For example, Figure 1.14 shows a plot of .
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Figure 1.14: 3-D Plot of an Expression

For more information on plots, see Plots and Animations (page 187).

1.8  Document Mode Summary
The key features of Document mode are summarized in Table 1.4.
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Table 1.4: Summary of Document Mode Tools

MethodsAction

• Math editing shortcut keys, including
symbol name completion

• Palettes

Entering Mathematical Expressions

For example:

• Ctrl + = (Command + =, for Macintosh)

• From the context menu, select Evaluate
and Display Inline.

Evaluating Mathematical Expressions

(Result Inline)*

For example:

 = 

• Enter key

• From the context menu, select Evaluate.

Evaluating Mathematical Expressions

(Result Centered on Following Line)

For example:

• Context menus

• Assistants

• Tutors

Performing Computations and Other Op-
erations on Expressions

For example, differentiate an expression:

• Execute toolbar icon 

• Execute All toolbar icon 

Executing a Group of Evaluations, Com-
putations, or Other Operations

* Inline evaluation is available in Document mode and document blocks. For information
on document blocks, see Document Blocks (page 247).
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1.9  Getting Help
The Maple Help System contains resources to help you use Maple. See Table
1.5.

Table 1.5: Maple Help Resources

DescriptionResource

An interactive overview of Maple.

• From the Help menu, select Take a Tour of Maple.

Maple Tour

Online manuals, including the Maple Getting Started Guide
and this manual. You can execute examples, copy content into
other documents, and search the contents using the Maple Help
System.

The Maple Getting Started Guide provides extensive informa-
tion for new users on using Maple and the resources available
on the Maplesoft Web site (http://www.maplesoft.com). Each
procedure and concept is accompanied by visual depictions of
actions to help you identify Maple resources and tools.

• From the Help menu, select Manuals, Dictionary, and
more>Manuals.

Online Manuals

A list of key commands and concepts.

• From the Help menu, select Quick Help. Alternatively,
press F1. For additional information, click an item in the
Quick Help.

Quick Help

A table of commands and information for new users that opens
in a new window. It contains hyperlinks to help pages for more
information.

• From the Help menu, select Quick Reference. Alternat-
ively, press Ctrl + F2 (Command + F2, for Macintosh).

Quick Reference
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DescriptionResource

Help for Maple features, commands, packages, and more. Help
pages include examples and screenshots to help you quickly
learn.

• From the Help menu, select Maple Help. You can search
for a help topic, perform a text search, or browse the Table
of Contents. You can also open a help page by entering
?<topic_name> at the input prompt (in Worksheet mode)
or in Math mode (in Document mode).

Help Pages

Set of commands with placeholders that you can use to quickly
perform a task.

• From the Tools menu, select Tasks, and then Browse.

Task Templates

Executable documents that demonstrate the power and flexib-
ility of the Maple interactive document or provide an overview
of computations in a particular field.

• From the Help menu, select Manuals, Dictionary, and
more, and then Applications and Examples.

Applications and Example
Worksheets

Over 5000 definitions, including 300 figures and plots.

• From the Help menu, select Manuals, Dictionary, and
more, and then Dictionary.

Mathematics and Engineer-
ing Dictionary

For a complete list of resources, refer to the ?MapleResources help page.

For more information on the Maple Help System, refer to the Maple Getting
Started Guide.
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2  Worksheet Mode
The Worksheet mode of the Standard Worksheet interface is designed for:

• Interactive use through Maple commands, which may offer advanced
functionality or customized control not available using context menus
or other syntax-free methods

• Programming using the powerful Maple language

Using Worksheet mode, you have access to most of the Maple features de-
scribed in Chapter 1 including:

• Math and Text modes

• Palettes

• Context menus

• Assistants and tutors

For information on these features, see Chapter 1, Document Mode (page 1).
(For a summary, see Table 1.4 (page 30).)

Note: Using a document block, you can use all Document mode features in
Worksheet mode. For information on document blocks, see Document
Blocks (page 247).

Note: This chapter and the following chapters were created using Worksheet
mode.
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2.1  In This Chapter
TopicsSection

• The Input Prompt (>)

• Suppressing Output

• 2-D and 1-D Math Input

• Input Separators

Input Prompt - Where you enter input

• The Maple Library

• Top-Level Commands

• Package Commands

Commands - Thousands of routines for per-
forming computations and other operations

• Using PalettesPalettes - Items that you can insert by click-
ing or dragging

• Using Context MenusContext Menus - Pop-up menus of common
operations

• Launching Assistants and Tutors

• Example: Using the Interactive Plot
Builder

Assistants and Tutors - Graphical interfaces
with buttons and sliders

• Viewing Task Templates

• Inserting a Task Template

• Performing the Task

Task Templates - Sets of commands with
placeholders that you can insert and use to
perform a task

• Inserting a Text Region

• Formatting Text

Text Regions - Areas in the document in
which you can enter text

• Assigning to Names

• Unassigning Names

• Valid Names

Names - References to the expressions you
assign to them
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TopicsSection

• Displaying Equation Labels

• Referring to a Previous Result

• Execution Groups with Multiple Outputs

• Label Numbering Schemes

• Features of Equation Labels

Equation Labels - Automatically generated
labels that you can use to refer to expressions

2.2  Input Prompt
In Worksheet mode, you enter input at the Maple input prompt (>). The de-
fault mode for input is Math mode (2-D Math).

To evaluate input:

• Press Enter.

Maple displays the result (output) below the input.

For example, to find the value of , enter the expression, and then

press Enter.

> 

For example, compute the sum of two fractions.

> 
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Suppressing Output

To suppress the output, enter a colon (:) at the end of the input.

> 

A set of Maple input and its output are referred to as an execution group.

1-D Math Input

You can also insert input using Text mode (1-D Math). The input is entered
as a one-dimensional sequence of characters. 1-D Math input is red.

To enter input using 1-D Math:

• At the input prompt, press F5 to switch from 2-D Math to 1-D Math.

123^2 - 29857/120;>

Important: 1-D Math input must end with a semicolon or colon. If you use
a semicolon, Maple displays the output. If you use a colon, Maple suppresses
the output.

123^2 - 29857/120:>

To set the default input mode to 1-D Math:

1. From the Tools menu, select Options. The Options dialog is displayed.
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2. On the Display tab, in the Input display drop-down list, select Maple
Notation.

3. Click Apply to Session (to set for only the current session) or Apply
Globally (to set for all Maple sessions).

To convert 2-D Math input to 1-D Math input:

1. Select the 2-D Math input.

2. From the Format menu, select Convert To, and then 1-D Math Input.

Important: In Document mode, you can execute a statement only if you
enter it in Math mode.

Input Separators

In 1-D and 2-D Math input, you can use a semicolon or colon to separate
multiple inputs in the same input line.

> 

If you do not specify a semicolon or colon, Maple interprets it as a single
input.

> 

2.3  Commands
Maple contains a large set of commands and a powerful programming lan-
guage. Most Maple commands are written using the Maple programming
language.
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You can enter commands using 1-D or 2-D Math. You must use 1-D Math
input when programming in Maple. Basic Programming (page 321) provides
an introduction to Maple programming.

To learn how to use Maple commands, use task templates. See Task Tem-
plates (page 51).

The Maple Library

Commands are contained in the Maple library, which is divided into two
groups: the top-level commands and packages.

• The top-level commands are the most frequently used Maple commands.

• Packages contain related specialized commands in areas such as student
calculus, linear algebra, vector calculus, and code generation.

For a complete list of packages and commands, refer to the index help pages.
To access the index overview help page, enter ?index, and then press Enter.
For information on the Maple Help System, see Getting Help (page 32).

Top-Level Commands

To use a top-level command, enter its name followed by parentheses (( ))
containing any parameters. This is referred to as a calling sequence for the
command.

command(arguments)

Note: In 1-D Math input, include a semicolon or colon at the end of the
calling sequence.

For example, to differentiate an expression, use the diff command. The re-
quired parameters are the expression to differentiate, which must be specified
first, and the independent variable.
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> 

For a complete list of functions (commands that implement mathematical
functions), for example, BesselI and AiryAi, available in the library, refer
to the ?initialfunctions help page. (To display this help page, enter ?initial-
functions at the input prompt.)

> 

For detailed information on the properties of a function, use the Function-
Advisor command.

> 

For detailed information on how to use a function in Maple, refer to its help
page.

For example:

> 

Note: In 1-D and 2-D Math input, when accessing a help page using ?, you
do not need to include a trailing semicolon or colon.

Package Commands

To use a package command, the calling sequence must include the package
name, and the command name enclosed in brackets ([ ]).
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package[command](arguments)

If you are frequently using the commands in a package, load the package.

To load a package:

• Use the with command, specifying the package as an argument.

The with command displays a list of the package commands loaded (unless
you suppress the output by entering a colon at the end of the calling se-
quence).

After loading a package, you can use its commands as top-level commands,
that is, without specifying the package name.

For example, use the NLPSolve command from the Optimization package
to find a local minimum of an expression and the value of the independent
variable at which the minimum occurs.

> 

> 

> 

For more information on optimization, see Optimization (page 166).

42   •   2  Worksheet Mode



To unload a package:

• Use the unwith command, specifying the package as an argument.

> 

To use the examples in this manual, you may be required to use the unwith
command between examples.

Some packages contain commands that have the same name as a top-level
command. When you load one of these packages, Maple returns a warning.

For example, the plots package contains a changecoords command. Maple
also contains a top-level changecoords command.

> 

Warning, the name changecoords has been redefined

In general, this manual does not include the warning messages Maple returns.

To use the top-level command, unload the package. (For alternative methods
of accessing the top-level command, see the ?with help page.)
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2.4  Palettes
Palettes are collections of related items that you can insert by clicking or
dragging. See Figure 2.1.

Figure 2.1: Expression Palette

You can use palettes to enter input.

For example, evaluate a definite integral using the definite integration item

 in the Expression palette.

In 2-D Math, clicking the definite integration item inserts:

> 

1. Enter values in the placeholders. To move to the next placeholder, press

Tab. Note: If pressing the Tab key inserts a tab, click the Tab icon  in
the toolbar.
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2. To evaluate the integral, press Enter.

> 

In 1-D Math, clicking the definite integration item inserts the corresponding
command calling sequence.

int(f,x=a..b);>

Specify the problem values (using the Tab to move to the next placeholder),
and then press Enter.

int(tanh(x), x = 0..1):>

Note: Some palette items cannot be inserted into 1-D Math because they are
not defined in the Maple language. When the cursor is in 1-D Math input,
unavailable palette items are dimmed.

For more information on palettes, see Palettes (page 11) and Performing
Computations (page 19) in Chapter 1.
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2.5  Context Menus
A context menu is a pop-up menu that lists the operations and actions you
can perform on a particular expression. See Figure 2.2.

Figure 2.2: Integer Context Menu

In Worksheet mode, you can use context menus to perform operations on 2-
D Math and output.

To use a context menu:

1. Right-click (Control-click, for Macintosh) the expression. The context
menu is displayed.

2. From the context menu, select an operation.

Maple inserts a new execution group containing:

• The calling sequence that performs the operation

• The result of the operation
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For example:

To determine a rational expression (fraction) that approximates a
floating-point number:

1. Right-click (Control-click, for Macintosh) the floating-point number.

2. From the context menu, select Conversions, and then Rational.

The inserted calling sequence includes an equation label reference to the
number you are converting.

> 

(2.1)

> 

For information on equation labels and equation label references, see Equa-
tion Labels (page 59).

For more information on context menus, see Context Menus (page 20) in
Chapter 1.
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2.6  Assistants and Tutors
Assistants and tutors provide point-and-click interfaces, with buttons, text
input regions, and sliders. See Figure 2.3.

Figure 2.3: Interactive Plot Builder: Select Plot Type Dialog

Launching an Assistant or Tutor

To launch an assistant or tutor:

1. Open the Tools menu.

2. Select Assistants or Tutors.

3. Navigate to and select one of the assistants or tutors.
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Example: Using the Interactive Plot Builder

To plot an expression using the Interactive Plot Builder:

1. From the Tools menu, select Assistants, and then Plot Builder. Maple
inserts the following command in the document and launches the Interactive
Plot Builder.

> 

2. In the Interactive Plot Builder: Specify Expressions window (Figure
2.4), click Add. The Add/Edit Expression dialog is displayed.

Figure 2.4: Interactive Plot Builder: Specify Expressions Window
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3. In the Add/Edit Expression dialog, enter the expression to plot using 1-
D Math. See Figure 2.5.

Figure 2.5: Interactive Plot Builder: Add/Edit Expression Dialog

4. Repeat steps 2 and 3 for each expression to add to the plot.

5. After adding the expressions, in the Interactive Plot Builder: Specify
Expressions window (Figure 2.4), click Done.

6. In the Interactive Plot Builder: Select Plot Type dialog (Figure 2.3),
select the type of plot, for example, 3-D Plot or  3-D Contour Plot, and

specify the variable ranges, for example, .

7. To immediately create a plot, click Plot. To customize the plot before
generating it, click Options. Set the plot options, and then click Plot.

Maple inserts the plot in the document.
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For more information on assistants and tutors, see Assistants and Tu-
tors (page 26) in Chapter 1.

2.7  Task Templates
Maple can solve a diverse set of problems. The task template facility helps
you quickly find and use the commands required to perform common tasks.

After inserting a task template, specify the parameters of your problem in
the placeholders, and then execute the commands, or click a button.

Viewing Task Templates

The Task Browser (Figure 2.6) organizes task templates by subject.

To launch the Task Browser:

• From the Tools menu, select Tasks, and then Browse.
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You can also browse the task templates in the Table of Contents of the Maple
Help System.

Figure 2.6: Task Browser

Inserting a Task Template

To insert a task template from the Task Browser or Help Navigator:

1. Navigate to the task.

2. Click one of the insertion or copy buttons.
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• Click the Insert Default Content button. Maple inserts the default con-
tent. The default content level is set using the Options dialog. For details,
see the following steps.

• Click the Insert Minimal Content button. Maple inserts only the com-
mands and embedded components, for example, a button to launch the
related assistant or tutor.

• Click the Copy Task to Clipboard button. Place the cursor where you
want to insert the task, and then paste the task. Maple inserts the default
content. Use this method to quickly insert a task multiple times.

To change the default content level, use the Options dialog.

1. From the Tools menu, select Options. The Options dialog opens.

2. In the Options dialog, select the Display tab.

3. In the Task content to insert drop-down list, select All Content, Standard
Content, or Minimal Content.

• Minimal Content - Only the commands and embedded components

• Standard Content - Commands, embedded components, and instructions
for using the template

• All Content - All content in the task template, including hyperlinks to
related help pages

Maple stores a list of the most recently inserted task templates.

To insert a recently inserted task:

• From the Tools menu, select Tasks, and then the task name.

Maple inserts the default content.

Performing the Task

After you insert a task template, enter the parameters for your task, and then
compute the result.
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To use an inserted task template:

1. Specify values for the parameters in placeholders or using graphical inter-
face components. You can move to the next placeholder by pressing Tab.

2. Execute all commands in the task by:

• Placing the cursor in the first task command, and then pressing Enter
repeatedly to execute each command.

• Selecting all the template commands, and then clicking the execute

toolbar icon .

3. If the template contains a button that computes the result, click it.

For more information on task templates, refer to the Maple Getting Started
Guide or the ?tasks help page.

2.8  Text Regions
To add descriptive text in Worksheet mode, use a text region.

To insert a text region:

• In the toolbar, click the Text region icon .

The default mode in a text region is Text mode.

In a text region, you can:

• Enter text with inline mathematical content by switching between Text
and Math modes. To toggle between Text mode and Math mode, press
F5.  Note: The mathematical content in a text region is not evaluated.
To enter mathematical content that is evaluated, enter it at an Input
Prompt (page 37).

• Insert any palette item. Palette items are inserted in Math mode (2-D
Math).
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You can format text in a text region. Features include:

• Character styles

• Paragraph styles

• Sections and subsections

• Tables

For more information on formatting documents, see Creating Mathematical
Documents (page 231).

2.9  Names
Instead of re-entering an expression every time you need it, you can assign
it to a name or add an equation label to it. Then you can quickly refer to the
expression using the name or an equation label reference. For information
on labels, see the following section Equation Labels (page 59).

Assigning to Names

You can assign any Maple expression to a name: numeric values, data
structures, procedures (a type of Maple program), and other Maple objects.

Initially, the value of a name is itself.

> 

The assignment operator (:=) associates an expression with a name.

> 
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Recall that you can enter  using the following two methods.

• Use the Common Symbols palette

• In 2-D Math enter pi, and then press the symbol completion short cut
key. See Shortcuts for Entering Mathematical Expressions (page 6).

When Maple evaluates an expression that contains a name, it replaces the
name with its value. For example:

> 

For information on Maple evaluation rules, see Evaluating Expres-
sions (page 310).

Mathematical Functions

To define a function, assign it to a name.

For example, define a function that computes the cube of its argument.

> 

For information on creating functions, see Defining a Mathematical Func-
tion (page 14).

> 

Note: To insert the right arrow, enter the characters ->. In 2-D Math, Maple
replaces -> with the right arrow symbol . In 1-D Math, the characters
are not replaced.
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For example, define a function that squares its argument.

square := x -> x^2:>

square(32);>

For more information on functions, see Functional Operators (page 292).

Protected Names

Protected names are valid names that are predefined or reserved.

If you attempt to assign to a protected name, Maple returns an error.

> 

Error, attempting to assign to `sin` which is protected

For more information, refer to the ?type/protected and ?protect help pages.

Unassigning Names

The unassign command resets the value of a name to itself. Note: You must
enclose the name in right single quotes ('').

> 

> 

Right single quotes (unevaluation quotes) prevent Maple from evaluating
the name. For more information on unevaluation quotes, see Delaying
Evaluation (page 317) or refer to the ?uneval help page.

See also Unassigning a Name Using Unevaluation Quotes (page 319).
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Unassigning All Names

The restart command clears the Maple internal memory. The effects include
unassigning all names and unloading all packages. For more information,
refer to the ?restart help page.

Note: To use the examples in this manual, you may be required to use the
unassign or restart command between examples.

Valid Names

A Maple name must be one of the following.

• A sequence of alphanumeric and underscore (_) characters that begins
with an alphabetical character. Note: To enter an underscore character
in 2-D Math, enter a backslash character followed by an underscore
character, that is, \_.

• A sequence of characters enclosed in left single quotes (``).

Important: Do not begin a name with an underscore character. Maple re-
serves names that begin with an underscore for use by the Maple library.

Examples of valid names:

• a

• a1

• polynomial

• polynomial1_divided_by_polynomial2

• `2a`

• `x#y`

• `x y`
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2.10  Equation Labels
Maple marks the output of each execution group with a unique equation label.

Note: The equation label is displayed to the right of the output.

> 

(2.2)

Using equation labels, you can refer to the result in other computations.

> 

(2.3)

Displaying Equation Labels

Important: By default, equation labels are displayed. If equation label display
is turned off, complete both the following operations.

• From the Format menu, select Labels, and then ensure that Worksheet
is selected.

• In the Options dialog (Tools>Options), on the Display tab, ensure that
Show equation labels is selected.

Referring to a Previous Result

Instead of re-entering previous results in computations, you can use equation
label references. Each time you need to refer to a previous result, insert an
equation label reference.
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To insert an equation label reference:

• From the Insert menu, select Label. (Alternatively, press Ctrl+L. For
Macintosh, Command+L.)

• In the Insert Label dialog, enter the label value, and then click OK.

Maple inserts the reference.

For example:

To integrate the product of (2.2) and (2.3):

1. In the Expression palette, click the indefinite integration item .
The item is inserted and the cursor moves to the integrand placeholder.

2. Press Ctrl+L (Command+L, for Macintosh).

3. In the Insert Label dialog, enter 2.2. Click OK.

4. Press *.

5. Press Ctrl+L (Command+L, for Macintosh).

6. In the Insert Label dialog, enter 2.3. Click OK.

7. To move to the variable of integration placeholder, press Tab.

8. Enter x. Press Enter.

> 
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Execution Groups with Multiple Outputs

An equation label is associated with the last output within an execution
group.

> 

(2.4)

> 

Label Numbering Schemes

You can number equation labels in two ways:

• Flat - Each label is a single number, for example, 1, 2, or 3.

• Sections - Each label is numbered according to the section in which it
occurs. For example, 2.1 is the first equation in the second section, and
1.3.2 is the second equation in the third subsection of the first section.

To change the equation label numbering scheme:

• From the Format menu, select Labels, and then Label Display. In the
Format Labels dialog (Figure 2.7), select one of the formats.

• Optionally, enter a prefix.
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Figure 2.7: Format Labels Dialog: Adding a Prefix

Features of Equation Labels

Although equation labels are not descriptive names, labels offer other import-
ant features.

• Each label is unique, whereas a name may be inadvertently assigned
more than once for different purposes.

• Maple labels the output values sequentially. If you remove or insert an
output, Maple automatically renumbers all equation labels and updates
the label references.

• If you change the equation label format (see Label Numbering
Schemes (page 61)), Maple automatically updates all equation labels and
label references.

For information on assigning to, using, and unassigning names, see
Names (page 55).

For more information on equation labels, refer to the ?equationlabels help
page.

The following chapters describe how to use Maple to perform tasks such as
solving differential (and other types of) equations, producing plots and anim-
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ations, and creating mathematical documents. The chapters were created
using Worksheet mode. Except where noted, all features are available in
both Worksheet mode and Document mode.
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3  Performing Computations
This chapter discusses key concepts related to performing computations with
Maple. It discusses important features that are relevant to all Maple users.
After learning about these concepts, you will learn how to use Maple to solve
problems in specific areas in the following chapter.

3.1  In This Chapter
TopicsSection

• Exact Computations

• Floating-Point Computations

• Converting Exact Quantities to Floating-
Point Values

• Sources of Error

Symbolic and Numeric Computation - An
overview of exact and floating-point compu-
tation

• Important Integer Commands

• Non-Base 10 Numbers

• Finite Rings and Fields

• Gaussian Integers

Integer Operations - How to perform integer
computations

• Equations and Inequations

• Ordinary Differential Equations

• Partial Differential Equations

• Integer Equations

• Integer Equations in a Finite Field

• Linear Systems

• Recurrence Relations

Solving - How to solve standard mathematic-
al equations
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TopicsSection

Units

• Conversions

• Applying Units to an Expression

• Performing Computations with Units

• Changing the Current System of Units

• Extensibility

Scientific Constants

• Scientific Constants

• Element and Isotope Properties

• Value, Units, and Uncertainty

• Performing Computations

• Modification and Extensibility

Uncertainty Propagation

• Quantities with Uncertainty

• Performing Computations with Quantities
with Uncertainty

Units, Scientific Constants, and Uncertainty
- How to construct and compute with expres-
sions that have units, scientific constants, or
uncertainty

• Real Number Domain

• Assumptions on Variables

Restricting the Domain - How to restrict the
domain for computations

3.2  Symbolic and Numeric Computa-
tion
Symbolic computation is the mathematical manipulation of expressions in-
volving symbolic or abstract quantities, such as variables, functions, and

operators; and exact numbers, such as integers, rationals, π, and . The

goal of such manipulations may be to transform an expression to a simpler
form or to relate the expression to other, better understood formulas.
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Numeric computation is the manipulation of expressions in the context of
finite-precision arithmetic. Expressions involving exact numbers, for example,

, are replaced by close approximations using floating-point numbers,

for example 1.41421. These computations generally involve some error.
Understanding and controlling this error is often of as much importance as
the computed result.

In Maple, numeric computation is normally performed if you use floating-
point numbers (numbers containing a decimal point) or the evalf command.
The plot command (see Plots and Animations (page 187)) uses numeric
computation, while commands such as int, limit, and gcd (see Integer Oper-
ations (page 71) and Mathematical Computations (page 121)) generally use
only symbolic computation to achieve their results.

Exact Computations

In Maple, integers, rational numbers, mathematical constants such as π and
∞, and mathematical structures such as matrices with these as entries are

treated as exact quantities. Names, such as , , , and

mathematical functions, such as sin(x) and LambertW(k, z), are symbolic
objects. Names can be assigned exact quantities as their values, and functions
can be evaluated at symbolic or exact arguments.

> 

Important: Unless requested to do otherwise (see the following section),
Maple evaluates expressions containing exact quantities to exact results, as
you would do if you were performing the calculation by hand, and not to
numeric approximations, as you normally obtain from a standard hand-held
calculator.
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> 

> 

> 

Floating-Point Computations

In some situations, a numeric approximation of an exact quantity is required.
For example, the plot command requires the expression it is plotting to
evaluate to numeric values that can be rendered on the screen: π cannot be

so rendered, but  can be. Maple distinguishes approximate from

exact quantities by the presence or absence of a decimal point:  is ap-

proximate, while  is exact.

Note: An alternative representation of floating-point numbers, called e-

notation, may not include an explicit decimal point: 1e5 , 3e-2

.

In the presence of a floating-point (approximate) quantity in an expression,
Maple generally computes using numeric approximations. Arithmetic in-
volving mixed exact and floating-point quantities results in a floating-point
result.

> 
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If a mathematical function is passed a floating-point argument, it normally
attempts to produce a floating-point approximation to the result.

> 

Converting Exact Quantities to Floating-Point
Values

To convert an exact quantity to a numeric approximation of that quantity,
use the evalf command or the Approximate context menu operation (see
Approximating the Value of an Expression (page 22)).

> 

By default, Maple computes such approximations using 10 digit arithmetic.
You can modify this in one of two ways:

• Locally, you can pass the precision as an index to the evalf call.

> 

• Globally, you can set the value of the Digits environment variable.

> 
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> 

For more information, see the ?evalf and ?Digits help pages.

Note: When appropriate, Maple performs floating-point computations directly
using your computer's underlying hardware.

Sources of Error

By its nature, floating-point computation normally involves some error.
Controlling the effect of this error is the subject of active research in Numer-
ical Analysis. Some sources of error are:

• An exact quantity may not be exactly representable in decimal form:

 and  are examples.

• Small errors can accumulate after many arithmetic operations.

• Subtraction of nearly equal quantities can result in essentially no useful

information. For example, consider the computation  for

> 

No correct digits remain. If, however, you use Maple to analyze this expres-
sion, and replace this form with a representation that is more accurate for

small values of , a fully accurate 10-digit result can be obtained.

> 
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> 

For information on evaluating an expression at a point, see Substituting a
Value for a Subexpression (page 310). For information on creating a series
approximation, see Series (page 159).

For more information on floating-point numbers, refer to the ?float and
?type/float help pages.

3.3  Integer Operations
In addition to the basic arithmetic operators, Maple has many specialized
commands for performing more complicated integer computations, such as
factoring an integer, testing whether an integer is a prime number, and de-
termining the greatest common divisor (GCD) of a pair of integers.

Note: Many integer operations are available as task templates
(Tools>Tasks>Browse).

You can quickly perform many integer operations using context menus. Se-
lecting an integer, and then right-clicking (for Macintosh, Control-clicking)
displays a context menu with integer commands, for example, Integer
Factors, which applies the ifactor command. See Figure 3.1.
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Figure 3.1: Context Menu for an Integer

In Worksheet mode, Maple uses an equation label reference in the ifactor
calling sequence.

> 

(3.1)

> 

For more information on equation labels, see Equation Labels (page 59).

For more information on using context menus in Worksheet mode, see
Context Menus (page 46). For information on using context menus in Docu-
ment mode, see Context Menus (page 20).

You can also enter the ifactor command and specify the integer to factor as
an argument.
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> 

Maple has many other integer commands, including those listed in Table
3.1.

Table 3.1: Select Integer Commands

DescriptionCommand

absolute value (displays in 2-D math as )abs

factorial (displays in 2-D math as )factorial

factorizationifactor

greatest common divisorigcd

quotient of integer divisioniquo

remainder of integer divisionirem

integer approximation of nth rootiroot

test primalityisprime

integer approximation of square rootisqrt

maximum and minimum of a setmax, min

modular arithmetic (See Finite Rings and
Fields (page 75)

mod

set of positive divisorsnumtheory[divisors]

> 

> 
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> 

> 

For information on finding integer solutions to equations, see Integer
Equations (page 93).

Non-Base 10 Numbers and Other Number Systems

Maple supports:

• Non-base 10 numbers

• Finite ring and field arithmetic

• Gaussian integers

Non-Base 10 Numbers

To represent an expression in another base, use the convert command.

> 

> 

For information on enclosing keywords in right single quotes ('), see
Delaying Evaluation (page 317).

You can also use the convert/base command.
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> 

Note: The convert/base command returns a list of digit values in order of
increasing significance.

Finite Rings and Fields

Maple supports computations over the integers modulo m.

The mod operator evaluates an expression over the integers modulo m.

> 

By default, the mod operator uses positive representation (modp command).
Symmetric representation is available using the mods command.

> 

> 

For information on setting symmetric representation as the default, refer to
the ?mod help page.

The modular arithmetic operators are listed in Table 3.2.
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Table 3.2: Modular Arithmetic Operators

ExampleOperatorOperation

> +Addition

> -Subtraction

> *Multiplication (displays in 2-D Math as )

> ^(-1)Multiplicative inverse (displays in 2-D Math as
a superscript)

> /Division (displays in 2-D Math as  )

> &^Exponentiation1

1To enter a caret (^) in 2-D Math, enter a backslash character followed by a caret, that is,
\^.

For information on solving an equation modulo an integer, see Integer
Equations in a Finite Field (page 94).

The mod operator also supports polynomial and matrix arithmetic over finite
rings and fields. For more information, refer to the ?mod help page.
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Gaussian Integers

Gaussian integers are complex numbers in which the real and imaginary
parts are integers.

The GaussInt package contains commands that perform Gaussian integer
operations.

The GIfactor command returns the Gaussian integer factorization.

> 

You can enter the imaginary unit using the following two methods.

• In the Common Symbols palette, click the i or j item. See
Palettes (page 11).

• Enter i or j, and then press the symbol completion key. See Symbol
Names (page 16).

Note: In 1-D Math input, enter the imaginary unit as an uppercase i (I).

The GIsqrt command approximates the square root in the Gaussian integers.

> 

For more information on Gaussian integers including a list of GaussInt
package commands, refer to the ?GaussInt help page.

3.4  Solving Equations
You can solve a variety of equation types, including those described in Table
3.3.
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Table 3.3: Overview of Solution Methods for Important Equation Types

Solution MethodEquation Type

solve and fsolve commandsEquations and inequations

ODE Analyzer Assistant (and dsolve command)Ordinary differential equations

pdsolve commandPartial differential equations

isolve commandInteger equations

msolve commandInteger equations in a finite field

LinearAlgebra[LinearSolve] commandLinear systems

rsolve commandRecurrence relations

Note: Many solve operations are available as task templates
(Tools>Tasks>Browse) and in context menus. This section focuses on other
methods.

Solving Equations and Inequations

Using Maple, you can symbolically solve equations and inequations. You
can also solve equations numerically.

To solve an equation or set of equations using context menus:

1. Right-click (for Macintosh, Control-click) the equations.

2. From the context menu, select Solve (or Solve Numerically). See Figure
3.2.

78   •   3  Performing Computations



Figure 3.2: Context Menu for an Equation

In Worksheet mode, Maple inserts a calling sequence that solves the equation
followed by the solutions.

If you select Solve, Maple computes exact solutions.

> 

(3.2)

> 

If you select Solve Numerically, Maple computes floating-point solutions.
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> 

(3.3)

> 

For information on solving equations and inequations symbolically using
the solve command, see the following section. For information on solving
equations numerically using the fsolve command, see Numerically Solving
Equations (page 83).

Symbolically Solving Equations and Inequations

The solve command is a general solver that determines exact symbolic
solutions to equations or inequations. The solutions to a single equation or
inequation are returned as an expression sequence. If Maple does not find
any solutions, the solve command returns the empty expression sequence.

> 

It is recommended that you verify the solutions returned by the solve com-
mand. For details, see Working with Solutions (page 86).

To return the solutions as a list, enclose the calling sequence in brackets ([
]).

> 
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Expressions You can specify expressions instead of equations. The solve
command automatically equates them to zero.

> 

W represents the Lambert W function.

Multiple Equations To solve multiple equations or inequations, specify
them as a set or list.

> 

> 

Solving for Specific Unknowns By default, the solve command returns
solutions for all unknowns. You can specify the unknowns for which to
solve.

> 

To solve for multiple unknowns, specify them as a list.
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> 

Transcendental Equations In general, the solve command returns one
solution to transcendental equations.

> 

> 

To produce all solutions, set the _EnvAllSolutions environment variable to
true.

Note: To enter an underscore character (_) in 2-D Math, enter \_.

> 

> 

Maple uses variables of the form _ZN~, where N is a positive integer, to
represent arbitrary integers. The tilde (~) indicates that it is a quantity with
an assumption. For information about names with assumptions, see Assump-
tions on Variables (page 116).

RootOf Structure The solve command may return solutions, for example,
to higher order polynomial equations, in an implicit form using RootOf
structures.

82   •   3  Performing Computations



> 

(3.4)

These RootOf structures are placeholders for the roots of the equation

. The index parameter numbers and orders the four

solutions.

Like any symbolic expression, you can convert RootOf structures to a
floating-point value using the evalf command.

> 

Some equations are difficult to solve symbolically. For example, polynomial
equations of order five and greater do not in general have a solution in terms
of radicals. If the solve command does not find any solutions, it is recommen-
ded that you use the Maple numerical solver, fsolve. For information, see
the following section, Numerically Solving Equations.

For more information on the solve command, including how to solve equa-
tions defined as procedures and how to find parametric solutions, refer to
the ?solve/details help page.

For information on verifying and using solutions returned by the solve
command, see Working with Solutions (page 86).

Numerically Solving Equations

The fsolve command solves equations numerically. The behavior of the
fsolve command is similar to that of the solve command.
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> 

> 

(3.5)

Note: You can also numerically solve equations using the context menus.
See Solving Equations and Inequations (page 78).

It is recommended that you verify the solutions returned by the fsolve com-
mand. For details, see Working with Solutions (page 86).

Multiple Equations To solve multiple equations, specify them as a set. The
fsolve command solves for all unknowns.

> 

Univariate Polynomial Equations  In general, the fsolve command finds
one solution. However, for a univariate polynomial equation, the fsolve
command returns all real roots.

> 

> 

Controlling the Number of Solutions To limit the number of roots returned,
specify the maxsols option.

> 
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To find additional solutions to a general equation, use the avoid option to
ignore known solutions.

> 

Complex Solutions To search for a complex solution, or find all complex
and real roots for a univariate polynomial, specify the complex option.

> 

If the fsolve command does not find any solutions, it is recommended that
you specify a range in which to search for solutions, or specify an initial
value.

Range To search for a solution in a range, specify the range in the calling
sequence. The range can be real or complex.

> 

The syntax for specifying a region in the complex plane is lower-left
point..upper-right point.

> 

Initial Values You can specify a value for each unknown. The fsolve com-
mand uses these as initial values for the unknowns in the numerical method.

> 
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(3.6)

For more information and examples, refer to the ?fsolve/details help page.

For information on verifying and using solutions returned by the fsolve
command, see the following section, Working with Solutions.

Working with Solutions

Verifying It is recommended that you always verify solutions (that the solve
and fsolve commands return) using the eval command.

> 

> 

(3.7)

> 

> 

> 

(3.8)

> 

For more information, see Substituting a Value for a Subexpression (page 310).
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Assigning the Value of a Solution to a Variable To assign the value of a
solution to the corresponding variable as an expression, use the assign
command.

For example, consider the numeric solution to equation2 , 

(3.6), found using the starting value .

> 

> 

Creating a Function from a Solution The assign command assigns a value
as an expression to a name. It does not define a function. To convert a
solution to a function, use the unapply command.

Consider one of the solutions for q to the equation .

> 

> 

You can evaluate this function at symbolic or numeric values.

> 
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> 

> 

For more information on defining and using functions, see Functional Oper-
ators (page 292).

Other Specialized Solvers

In addition to equations and inequations, Maple can solve other equations
including:

• Ordinary differential equations (ODEs)

• Partial differential equations (PDEs)

• Integer equations

• Integer equations in a finite field

• Linear systems

• Recurrence relations

Ordinary Differential Equations (ODEs)

Maple can solve ODEs and ODE systems, including initial value and
boundary value problems, symbolically and numerically.

ODE Analyzer Assistant The ODE Analyzer Assistant is a point-and-click
interface to the Maple ODE solving routines.

To launch the ODE Analyzer:

• From the Tools menu, select Assistants, and then ODE Analyzer.
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Maple inserts the dsolve[interactive]() calling sequence in the document.
The ODE Analyzer Assistant (Figure 3.3) is displayed.

Figure 3.3: ODE Analyzer Assistant

In the main ODE Analyzer Assistant window, you can define ODEs, initial
or boundary value conditions, and parameters. To define derivatives, use the

diff command. For example, diff(x(t), t) corresponds to , and

diff(x(t), t, t) corresponds to . For more information on the diff

command, see The diff Commanddiff (page 155).

After defining an ODE, you can solve it numerically or symbolically.

To solve a system numerically using the ODE Analyzer Assistant:

1. Ensure that the conditions guarantee uniqueness of the solution.

2. Ensure that all parameters have fixed values.

3. Click the Solve Numerically button.
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4. In the Solve Numerically window (Figure 3.4), you can specify the nu-
meric method and relevant parameters and error tolerances to use for solving
the problem.

5. To compute solution values at a point, click the Solve button.

Figure 3.4: ODE Analyzer Assistant: Solve Numerically Dialog

To solve a system symbolically using the ODE Analyzer Assistant:

1. Click the Solve Symbolically button.

2. In the Solve Symbolically window (Figure 3.5), you can specify the
method and relevant method-specific options to use for solving the problem.

3. To compute the solution, click the Solve button.
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Figure 3.5: ODE Analyzer Assistant: Solve Symbolically Dialog

When solving numerically or symbolically, you can view a plot of the solution
by clicking the Plot button.

• To plot the solution to a symbolic problem, all conditions and parameters
must be set.

• To customize the plot, click the Plot Options button to open the Plot
Options window.

To view the corresponding Maple commands as you solve the problem or
plot the solution, select the Show Maple commands check box.
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You can control the return value of the ODE Analyzer using the On Quit,
Return drop-down list. You can select to return nothing, the displayed plot,
the computed numeric procedure (for numeric solutions), the solution (for
symbolic solutions), or the Maple commands needed to produce the solution
values and the displayed plot.

For more information, refer to the ?ODEAnalyzer help page.

The dsolve Command

The ODE Analyzer provides a point-and-click interface to the Maple dsolve
command.

For ODEs or systems of ODEs, the dsolve command can find:

• Closed form solutions

• Numerical solutions

• Series solutions

In addition, the dsolve command can find:

• Formal power series solutions to linear ODEs with polynomial coeffi-
cients

• Formal solutions to linear ODEs with polynomial coefficients

To access all available functionality, use the dsolve command directly. For
more information, refer to the ?dsolve help page.

Partial Differential Equations (PDEs)

To solve a PDE or PDE system symbolically or numerically, use the pdsolve
command. PDE systems can contain ODEs, algebraic equations, and inequa-
tions.

For example, solve the following PDE symbolically.

> 
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(3.9)

> 

The solution is an arbitrary univariate function applied to .

Maple generally prints only the return value, errors, and warnings during a
computation. To print information about the techniques Maple uses, increase
the infolevel setting for the command.

To return all information, set infolevel to 5.

> 

> 

Checking arguments ...

Getting info and details about the PDE ... First set of solution methods (general
or quase general solution) Second set of solution methods (complete solutions)
Trying methods for first order PDEs HINT = strip Trying characteristic strip
method ... characteristic strip method successful. Second set of solution methods
successful

For more information on solving PDEs, including numeric solutions and
solving PDE systems, refer to the ?pdsolve help page.

Integer Equations

To find only integer solutions to an equation, use the isolve command. The
isolve command finds solutions for all variables. For more information, refer
to the ?isolve help page.
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> 

Integer Equations in a Finite Field

To solve an equation modulo an integer, use the msolve command. For more
information, refer to the ?msolve help page. The msolve command finds
solutions for all variables.

> 

Solving Linear Systems

To solve a linear system, use the LinearAlgebra[LinearSolve] command.
For more information, refer to the ?LinearAlgebra[LinearSolve] help page.
The LinearSolve command returns the vector x that satisfies A . x = B.

For example, construct an augmented matrix using the Matrix palette (see
Creating Matrices and Vectors (page 133)) in which the first four columns
contain the entries of A and the final column contains the entries of B.

> 

> 
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For more information on using Maple to solve linear algebra problems, see
Linear Algebra (page 133).

Solving Recurrence Relations

To solve a recurrence relation, use the rsolve command. For more informa-
tion, refer to the ?rsolve help page. The rsolve command finds the general
term of the function.

> 

3.5  Units, Scientific Constants, and
Uncertainty
In addition to manipulating exact symbolic and numeric quantities, Maple
can perform computations with units and uncertainties.

Maple supports hundreds of units, for example, miles, coulombs, and bars,
and provides facilities for adding custom units.
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Maple has a library of hundreds of scientific constants with units, including
element and isotope properties.

To support computations with uncertainties, Maple propagates errors through
computations.

Units

The Units package in Maple provides a library of units, and facilities for
using units in computations. It is fully extensible so that you can add units
as required.

Note: Some unit operations are available as task templates (see
Tools>Tasks>Browse) and through context menus.

Overview of Units

A dimension is a measurable quantity, for example, length or force. The set
of dimensions that are fundamental and independent are known as base di-
mensions.

In Maple, the base dimensions include length, mass, time, electric current,
thermodynamic temperature, amount of substance, luminous intensity, in-
formation, and currency. For a complete list, run Units[GetDimensions]().

Complex dimensions (or composite dimensions) measure other quantities in
terms of a combination of base dimensions. For example, the complex dimen-

sion force is a measurement of .

Each dimension, base or complex, has associated units. (Base units measure
a base dimension. Complex units measure a complex dimension.) Maple
supports over forty units of length, including feet, miles, meters, angstroms,
microns, and astronomical units. A length must be measured in terms of a
unit, for example, a length of 2 parsecs.

Table 3.4 lists some dimensions, their corresponding base dimensions, and
example units.
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Table 3.4: Sample Dimensions

Example UnitsBase DimensionsDimension

second, minute, hour, day, week, month,
year, millennium, blink, lune

timeTime

joule, electron volt, erg, watt hour, calor-
ie, Calorie, British thermal unit

Energy

volt, abvolt, statvoltElectric potential

For the complete list of units (and their contexts and symbols) available for
a dimension, refer to the corresponding help page, for example, the
?Units/length help page for the units of length.

Each unit has a context. The context differentiates between different defini-
tions of the unit. For example, the standard and US survey miles are different
units of length, and the second is a unit of time and of angle. You can specify
the context for a unit by appending the context as an index to the unit, for
example, mile[US_survey]. If you do not specify a context, Maple uses the
default context.

Units are collected into systems, for example, the foot-pound-second (FPS)
system and international system, or système international, (SI). Each system
has a default set of units used for measurements. In the FPS system, the foot,
pound, and second are used to measure the dimensions of length, mass, and
time. The unit of speed is the foot/second. In SI, the meter, kilogram, and
second are used to measure the dimensions of length, mass, and time. The
units of speed, magnetic flux, and power are the meter/second, weber, and
watt.

Conversions

To convert a value measured in a unit to the corresponding value in a different
unit, use the Units Calculator.
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• In the worksheet, enter ?UnitsCalculator.

The Units Calculator application (Figure 3.6) opens.

Figure 3.6: Unit Converter Assistant

To perform a conversion:

1. In the Convert text field, enter the numeric value to convert.

2. In the Dimension drop-down list, select the dimensions of the unit.

3. In the From and To drop-down lists, select the original unit and the unit
to which to convert.

4. Click Perform Unit Conversion.

Maple inserts the corresponding convert/units command into the document.

> 

Important: Using the Units Calculator, you can convert temperatures and
temperature changes.
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• To perform a temperature conversion, in the Dimension drop-down list,
select temperature(absolute).

• To perform a temperature change conversion, in the Dimension drop-
down list, select temperature(relative).

To convert temperature changes, the Units Calculator uses the convert/units
command. For example, an increase of 32 degrees Fahrenheit corresponds
to an increase of almost 18 degrees Celsius.

> 

To convert absolute temperatures, the Unit Converter uses the convert/tem-
perature command. For example, 32 degrees Fahrenheit corresponds to 0
degrees Celsius.

> 

Applying Units to an Expression

To insert a unit, use the Units palettes. The Units (FPS) palette (Figure 3.7)
contains important units from the foot-pound-second system of units. The
Units (SI) palette (Figure 3.8) contains important units from the international
system of units.
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Figure 3.8: Units (SI) PaletteFigure 3.7: Units (FPS) Palette

To insert a unit:

• In a Units palette, click a unit symbol.

> 

To insert a unit that is unavailable in the palettes:

1. In a Units palette, click the unit symbol . Maple inserts a Unit
object with the placeholder selected.

2. In the placeholder, enter the unit name (or symbol).

For example, to enter  standard (the default context) miles, you can

specify the unit name, mile, or symbol, mi.

> 
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The context of a unit is displayed only if it is not the default context.

Important: In 1-D Math input, the quantity and unit (entered using the top-
level Unit command) are a product, not a single entity. The following calling
sequences define different expressions.

> 1*Unit(m)/2*Unit(s);> 1*Unit(m)/(2*Unit(s));

Some units support prefixes. For example, SI units support prefixes to names
and symbols. You can specify 1000 meters using kilometer or km. For more
information, refer to the ?Units/prefixes help page.

> 

Performing Computations with Units

In the default Maple environment, you cannot perform computations with
quantities that have units. You can perform only unit conversions. For more
information about the default environment, refer to the ?Units/default help
page.

To compute with expressions that have units, you must load a Units envir-
onment, Natural or Standard. It is recommended that you use the Standard
environment.

> 

In the Standard Units environment, commands that support expressions
with units return results with the correct units.
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> 

> 

(3.10)

> 

(3.11)

> 

For information on differentiation and integration, see Calculus (page 151).

Changing the Current System of Units

If a computation includes multiple units, all units are expressed using units
from the current system of units.

> 

(3.12)

By default, Maple uses the SI system of units, in which length is measured
in meters and time is measured in seconds.
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> 

To view the name of the default system of units, use the Units[UsingSystem]
command.

> 

> 

To change the system of units, use the Units[UseSystem] command.

> 

> 

Extensibility

You can extend the set of:

• Base dimensions and units

• Complex dimensions

• Complex units

• Systems of units

For more information, refer to the ?Units[AddBaseUnit], ?Units[AddDi-
mension], ?Units[AddUnit], and ?Units[AddSystem] help pages.

For more information about units, refer to the ?Units help page.
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Scientific Constants and Element Properties

Computations often require not only units (see Units (page 96)), but also the
values of scientific constants, including properties of elements and their
isotopes. Maple supports computations with scientific constants. You can
use the built-in constants and add custom constants.

Overview of Scientific Constants and Element Properties

The ScientificConstants package provides the values of constant physical
quantities, for example, the velocity of light and the atomic weight of sodium.
The ScientificConstants package also provides the units for the constant
values, allowing for greater understanding of the equation as well as unit-
matching for error checking of the solution.

The quantities available in the ScientificConstants package are divided into
two distinct categories.

• Physical constants

• Chemical element (and isotope) properties

Scientific Constants

Maple contains many built-in scientific constants, which you can easily in-
clude in your computations.

List of Scientific Constants

You have access to scientific constants important in engineering, physics,
chemistry, and other fields. Table 3.5 lists some of the supported constants.
For a complete list of scientific constants, refer to the ?ScientificCon-
stants/PhysicalConstants help page.
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Table 3.5: Scientific Constants

SymbolName

GNewtonian_constant_of_gravitation

hPlanck_constant

eelementary_charge

a[0]Bohr_radius

mu[d]deuteron_magnetic_moment

N[A]Avogadro_constant

FFaraday_constant

You can specify a constant using either its name or symbol.

Accessing Constant Definition

The GetConstant command in the ScientificConstants package returns the
complete definition of a constant.

To view the definition of the Newtonian gravitational constant, specify the
symbol G (or its name) in a call to the GetConstant command.

> 

> 

For information on accessing a constant's value, units, or uncertainty, see
Value, Units, and Uncertainty (page 107).

Element Properties

Maple also contains element properties and isotope properties.
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Elements

Maple supports the first 112 elements of the periodic table, plus elements
number 114 and 116. Each element has a unique name, atomic number, and
chemical symbol. You can specify an element using any of these labels. For
a complete list of supported elements, refer to the ?ScientificConstants/ele-
ments help page.

Maple supports key element properties, including atomic weight (atomic-
weight), electron affinity (electronaffinity), and density. For a complete list
of element properties, refer to the ?ScientificConstants/properties help
page.

Isotopes

Isotopes, variant forms of an element that contain the same number of protons
but a different number of neutrons, exist for many elements.

To see the list of supported isotopes for an element, use the GetIsotopes
command.

> 

Maple supports isotopes and has a distinct set of properties for isotopes, in-
cluding abundance, binding energy (bindingenergy), and mass excess
(massexcess). For a complete list of isotope properties, refer to the ?Scien-
tificConstants/properties help page.

Accessing an Element or Isotope Property Definition

The GetElement command in the ScientificConstants package returns the
complete definition of an element or isotope.
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> 

> 

Value, Units, and Uncertainty

To use constants or element properties, you must first construct a Scientific-
Constants object.

To construct a scientific constant, use the Constant command.

> 

To construct an element (or isotope) property, use the Element command.

> 
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Value

To obtain the value of a ScientificConstants object, use the evalf command.

> 

> 

Note: The value returned depends on the current system of units. For inform-
ation on controlling the system of units, see Changing the Current System
of Units (page 102).

Units

To obtain the units for a ScientificConstants object, use the GetUnit com-
mand.

> 

> 

For information on changing the default system of units, for example, from
SI to foot-pound-second, see Changing the Current System of Units (page 102).
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Value and Units

If performing computations with units, you can access the value and units
for a ScientificConstants object by specifying the units option when con-
structing the object, and then evaluating the object.

> 

> 

Uncertainty

The value of a constant is often determined by direct measurement or derived
from measured values. Hence, it has an associated uncertainty. To obtain
the uncertainty in the value of a ScientificConstants object, use the GetError
command.

> 

> 

Performing Computations

You can use constant values in any computation. To use constant values
with units, use a Units environment as described in Performing Computations
with Units (page 101). For information on computing with quantities that
have an uncertainty, see the following section.
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Modification and Extensibility

You can change the definition of a scientific constant or element (or isotope)
property.

For more information, refer to the ?ScientificConstants[ModifyConstant]
and ?ScientificConstants[ModifyElement] help pages.

You can extend the set of:

• Constants

• Elements (and isotopes)

• Element (or isotope) properties

For more information, refer to the ?ScientificConstants[AddConstant],
?ScientificConstants[AddElement], and ?ScientificConstants[AddProp-
erty] help pages.

For more information about constants, refer to the ?ScientificConstants
help page.

Uncertainty Propagation

Some computations involve uncertainties (or errors). Using the ScientificEr-
rorAnalysis package, you can propagate the uncertainty in these values
through the computation to indicate the possible error in the final result.

The ScientificErrorAnalysis package does not perform interval arithmetic.
That is, the error of an object does not represent an interval in which possible
values must be contained. (To perform interval arithmetic, use the Tolerances
package. For more information, refer to the ?Tolerances help page.) The
quantities represent unknown values with a central tendency. For more in-
formation on central tendency, refer to any text on error analysis for the
physical sciences or engineering.
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Quantities with Uncertainty

Creating To construct quantities with uncertainty, use the Quantity com-
mand. You must specify the value and uncertainty. The uncertainty can be
defined absolutely, relatively, or in units of the last digit. For more informa-
tion on uncertainty specification, refer to the ?ScientificErrorAnalys-
is[Quantity] help page.

The output displays the value and uncertainty of the quantity.

> 

> 

> 

(3.13)

To specify the error in units of the last digit, the value must be of floating-
point type.

> 

To access the value and uncertainty of a quantity with uncertainty, use the
evalf and ScientificErrorAnalysis[GetError] commands.

> 

> 
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Rounding To round the error of a quantity with uncertainty, use the ApplyR-
ule command. For a description of the predefined rounding rules, refer to
the ?ScientificErrorAnalysis/rules help page.

> 

Units Quantities with errors can have units. For example, the scientific
constants and element (and isotope) properties in the ScientificConstants
packages are quantities with errors and units.

To construct a new quantity with units and an uncertainty, include units in
the Quantity calling sequence.

For an absolute error, you must specify the units in both the value and error.

> 

> 

For a relative error, you can specify the units in only the value.

> 

For information on the correlation between, variance of, and covariance
between quantities with uncertainty, refer to the ?ScientificErrorAnalysis
help page.

Performing Computations with Quantities with Uncertainty

Many Maple commands support quantities with uncertainty.
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> 

> 

Compute the value of the derivative of  at .

> 

> 

To convert the solution to a single quantity with uncertainty, use the com-
bine/errors command.

> 

The value of the result is:

> 

The uncertainty of the result is:

> 

Additional Information

For information on topics including:

• Creating new rounding rules

• Setting the default rounding rule
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• Creating a new interface to quantities with uncertainty

refer to the ?ScientificErrorAnalysis help page.

3.6  Restricting the Domain
By default, Maple computes in the complex number system. Most computa-
tions are performed without any restrictions or assumptions on the variables.
Maple often returns results that are extraneous or unsimplified when comput-
ing in the field of complex numbers. Using restrictions, you can more easily
and efficiently perform computations in a smaller domain.

Maple has facilities for performing computations in the real number system
and for applying assumptions to variables.

Real Number Domain

To force Maple to perform computations in the field of real numbers, use
the RealDomain package.

The RealDomain package contains a small subset of Maple commands re-
lated to basic precalculus and calculus mathematics, for example, arccos,
limit, and log, and the symbolic manipulation of expressions and formulae,
for example, expand, eval, and solve. For a complete list of commands,
refer to the ?RealDomain help page.

After you load the RealDomain package, Maple assumes that all variables
are real. Commands return simplified results appropriate to the field of real
numbers.

> 
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> 

> 

Some commands that generally return NULL instead return a numeric result
when you use the RealDomain package.

> 

Complex return values are excluded or replaced by undefined.

> 

> 
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Assumptions on Variables

To simplify problem solving, it is recommended that you always apply any
known assumptions to variables. You can impose assumptions using the
assume command. To apply assumptions for a single computation, use the
assuming command.

Note: The assume and assuming commands are not supported by the
RealDomain package.

The assume Command

You can use the assume command to set variable properties, for example,
x::real, and relationships between variables, for example, x < 0 or x < y.
For information on valid properties, refer to the ?assume help page. For in-
formation on the double colon (::) operator, refer to the ?type help page.

The assume command allows improved simplification of symbolic expres-
sions, especially multiple-valued functions, for example, computing the
square root.

To assume that x is a positive real number, use the following calling sequence.

Then compute the square root of .

> 

The trailing tilde (~) on the name x indicates that it carries assumptions.

When you use the assume command to place another assumption on x, all
previous assumptions are removed.

> 

116   •   3  Performing Computations



Displaying Assumptions To view the assumptions on an expression, use
the about command.

> 

Originally x, renamed x~: is assumed to be: RealRange(-infinity,Open(0))

Imposing Multiple Assumptions To simultaneously impose multiple con-
ditions on an expression, specify multiple arguments in the assume calling
sequence.

> 

To specify additional assumptions without replacing previous assumptions,
use the additionally command. The syntax of the additionally calling se-
quence is the same as that of the assume command.

> 

Originally x, renamed x~: is assumed to be: 1

The only integer in the open interval (0, 2) is 1.

Testing Properties To test whether an expression always satisfies a condi-
tion, use the is command.

> 

The following test returns false because there are values of x and y (x = 0,
y = 10) that satisfy the assumptions, but do not satisfy the relation in the is
calling sequence.

> 
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To test whether an expression can satisfy a condition, use the coulditbe
command.

> 

Removing Assumptions To remove all assumptions on a variable, unassign
its name.

> 

For more information, see Unassigning Names (page 57).

For more information on the assume command, refer to the ?assume help
page.

The assuming Command

To perform a single evaluation under assumptions on the names in an expres-
sion, use the assuming command.

The syntax of the assuming command is expression assuming <property
or relation>. Properties and relations are introduced in The assume Com-
mand (page 116).

The frac command returns the fractional part of an expression.

> 

Using the assuming command is equivalent to imposing assumptions with
the assume command, evaluating the expression, and then removing the as-
sumptions.
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> 

x: nothing known about this object

If you do not specify the names to which to apply a property, it is applied to
all names.

> 

Assumptions placed on names using the assume command are ignored by
the assuming command, unless you include the additionally option.

> 

> 

> 

The assuming command does not affect variables inside procedures. (For
information on procedures, see Procedures (page 338).) You must use the
assume command.

f := proc(x) sqrt(a^2) + x end proc;>

> 
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> 

For more information on the assuming command, refer to the ?assuming
help page.
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4  Mathematical Computations
As discussed in previous chapters, Maple contains numerous built-in re-
sources for computations.

These resources—and others on the Maplesoft Web site—are available for
the areas discussed in this chapter, and many more. Your first step in solving
a problem should be to review the related Maple resources available. This
will help you to quickly and easily solve problems. See Table 4.1.

Table 4.1: Maple Resources for Mathematical Computation

DescriptionResource

Graphical interfaces with buttons and sliders to easily per-
form a computation, create a plot, or perform other opera-
tions.

• From the Tools menu, select Assistants.

Point-and-click assistants

Pop-up menu of common operations for the selected object,
based on its type.

• Select the expression in 2-D Math input or output, and
then right-click (for Macintosh, Control-click).

Context menus

Collections of related items that you can insert by clicking
or dragging. Some palettes contain mathematical operations
with placeholders for parameters.

• From the View menu, select Palettes, and then Expand
Docks.

Palettes

Set of commands with placeholders that you can use to
quickly perform a task. Some tasks contain graphical com-
ponents such as buttons.

• From the Tools menu, select Tasks, and then Browse.

Task templates

Provides detailed information about mathematical functions,
for example, definitions, identities, and mathematical prop-
erties.

• Refer to the ?FunctionAdvisor help page.

FunctionAdvisor command
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DescriptionResource

Over 5000 help pages and example worksheets with an in-
tegrated search engine.

• From the Help menu, select Maple Help.

Maple Help System

A complete list of the over 100 Maple packages, which
contain thousands of commands.

• From the Help menu, select Manuals, Dictionary, and
more, and then List of Packages.

Package index help page

A complete list of the over 600 top-level Maple commands.

• From the Help menu, select Manuals, Dictionary, and
more, and then List of Commands.

Command index help page

Maple Application Center - Free documents and point-and-
click Maplet applications for mathematics, engineering,
finance, and science.

• Visit http://www.maplesoft.com/applications

Toolboxes - Add-on products from Maplesoft, for example,
the Global Optimization Toolbox.

• Visit http://www.maplesoft.com/products/toolboxes

Third-Party Products - Add-on products developed by the
Maple user community for specialized computation.

• Visit http://www.maplesoft.com/products/thirdparty

Maplesoft Web site

(http://www.maplesoft.com)

For instructor and student resources, see Table 4.10 (page 178).

For information on basic computations, including integer operations and
solving equations, see Performing Computations (page 65).
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4.1  In This Chapter
TopicsSection

• Polynomial AlgebraAlgebra - Performing algebra computations

• Creating Matrices and Vectors

• Accessing Entries in Matrices and Vec-
tors

• Linear Algebra Computations

• Student LinearAlgebra Package

Linear Algebra - Performing linear algebra
computations

• Limits

• Differentiation

• Series

• Integration

• Differential Equations

• Calculus Packages

Calculus - Performing calculus computations

• Point-and-Click Interface

• Efficient Computation

• MPS(X) File Support

Optimization - Performing optimization
computations using the Optimization pack-
age

• Probability Distributions and Random
Variables

• Statistical Computations

• Plotting

Statistics - Performing statistics computations
using the Statistics package

• Table of Student and Instructor Resources

• Student Packages and Tutors

Teaching and Learning with Maple - Student
and Instructor resources for using Maple in
an academic setting
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4.2  Algebra
Maple contains a variety of commands that perform integer operations, such
as factoring and modular arithmetic, as described in Integer Opera-
tions (page 71). In addition, it supports polynomial algebra.

For information on matrix and vector algebra, see Linear Algebra (page 133).

Polynomial Algebra

A Maple polynomial is an expression in powers of an unknown. Univariate

polynomials are polynomials in one unknown, for example, .

Multivariate polynomials are polynomials in multiple unknowns, such as

.

The coefficients can be integers, rational numbers, irrational numbers,
floating-point numbers, complex numbers, variables, or a combination of
these types.

> 

Arithmetic

The polynomial arithmetic operators are the standard Maple arithmetic oper-
ators excluding the division operator (/). (The division operator accepts
polynomial arguments, but does not perform polynomial division.)

Polynomial division is an important operation. The quo and rem commands
find the quotient and remainder of a polynomial division. See Table 4.2.
(The iquo and irem commands find the quotient and remainder of an integer
division. For more information, see Integer Operations (page 71).)
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Table 4.2: Polynomial Arithmetic Operators

ExampleOperatorOperation

> Addition

> Subtraction

> *Multiplication1

> 

> 

quo

rem

Division: Quotient
and Remainder

> ^Exponentiation2

1You can specify multiplication explicitly by entering *, which displays in 2-D Math as
. In 2-D Math, you can also implicitly multiply by placing a space character between

two expressions. In some cases, the space character is optional. For example, Maple inter-
prets a number followed by a name as an implicit multiplication.
2In 2-D Math, exponents display as superscripts.

To expand a polynomial, use the expand command.
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> 

If you need to determine whether one polynomial divides another, but do
not need the quotient, use the divide command. The divide command tests
for exact polynomial division.

> 

Important: You must insert a space character or a multiplication operator
( ) between adjacent variables names. Otherwise, they are interpreted as

a single variable.

For example,  does not divide the single variable .

> 

But,  divides the product of  and .

> 

For information on polynomial arithmetic over finite rings and fields, refer
to the ?mod help page.

Sorting Terms

To sort the terms of a polynomial, use the sort command.
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> 

> 

Note: The sort command returns the sorted polynomial, and updates the
order of the terms in the polynomial.

The terms of p1 are sorted.

> 

To specify the unknowns of the polynomial and their ordering, include a list
of names.

> 

> 

By default, the sort command sorts a polynomial by decreasing total degree
of the terms.

> 

> 
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The first term has total degree 4. The other two terms have total degree 3.
The order of the final two terms is determined by the order of their names
in the list.

To sort the terms by pure lexicographic order, that is, first by decreasing
order of the first unknown in the list option, and then by decreasing order of
the next unknown in the list option, specify the 'plex' option.

> 

For information on enclosing keywords in right single quotes ('), see
Delaying Evaluation (page 317).

The first term has a power of  to the 3. The second, a power of  to the

2. The third, a power of  to the 0.

Using context menus, you can perform operations, such as sorting, for
polynomials and many other Maple objects.

To sort a polynomial:

1. Right-click (Control-click, for Macintosh) the polynomial.

2. The context menu displays. From the Sorts menu, select:

• Single-variable, and then the unknown

• Two-variable (or Three-variable), Pure Lexical or Total Degree, and
then the sort priority of the unknowns

See Figure 4.1.
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Figure 4.1: Sorting a Polynomial Using a Context Menu

Maple sorts the polynomial.

In Worksheet mode, Maple inserts the calling sequence that performs the
sort followed by the sorted polynomial.

> 

> 

4.2  Algebra   •   129



You can use context menus to perform operations on 2-D Math content in-
cluding output. For more information, see Context Menus (page 20) (for
Document mode) or Context Menus (page 46) (for Worksheet mode).

Collecting Terms

To collect the terms of polynomial, use the collect command.

> 

Coefficients and Degrees

Maple has several commands that return coefficient and degree values for
a polynomial. See Table 4.3.

Table 4.3: Polynomial Coefficient and Degree Commands

ExampleDescriptionCommand

> Coefficient of specified degree termcoeff

> Leading coefficientlcoeff
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ExampleDescriptionCommand

> Trailing coefficienttcoeff

> Sequence of all coefficients in increasing
degree order.

Note: It does not return zero coeffi-
cients.

coeffs

> (Highest) degreedegree

> Lowest degree term with a non-zero
coefficient

ldegree

Factorization

To express a polynomial in fully factored form, use the factor command.

> 

The factor command factors the polynomial over the ring implied by the
coefficients, for example, integers. You can specify an algebraic number
field over which to factor the polynomial. For more information, refer to the
?factor help page. (The ifactor command factors an integer. For more in-
formation, see Integer Operations (page 71).)
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To solve for the roots of a polynomial, use the solve command. For inform-
ation on the solve command, see Solving Equations and Inequa-
tions (page 78). (The isolve command solves an equation for integer solutions.
For more information, see Integer Equations (page 93).)

Other Commands

Table 4.4 lists other commands available for polynomial operations.

Table 4.4: Select Other Polynomial Commands

DescriptionCommand

Content (multivariate polynomial)content

Decompositioncompoly

Discriminantdiscrim

Greatest common divisor (of two polynomials)gcd

Extended Euclidean algorithm (for two polyno-
mials)

gcdex

Interpolating polynomial (for list of points)CurveFitting[PolynomialInterpolation]

See also the CurveFitting Assistant
(Tools>Assistants>Curve Fitting)

Least common multiple (of two polynomials)lcm

Normnorm

Pseudo-remainder (of two multivariate polyno-
mials)

prem

Primitive part (multivariate polynomial)primpart

Random polynomialrandpoly

Determine whether self-reciprocalPolynomialTools[IsSelfReciprocal]

Resultant (of two polynomials)resultant

Exact roots (over algebraic number field)roots
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DescriptionCommand

Square free factorization (multivariate polyno-
mial)

sqrfree

Additional Information

Table 4.5: Additional Polynomial Help

ResourceTopic

?polynom help pageGeneral polynomial information

?PolynomialTools package overview help pagePolynomialTools package

?SNAP (Symbolic-Numeric Algorithms for
Polynomials) package overview help page

Algebraic manipulation of numeric poly-
nomials

?SDMPolynom (Sparse Distributed Multivari-
ate Polynomial data structure) help page

Efficient arithmetic for sparse polynomials

Maple Help System Table of Contents: Math-
ematics>Algebra>Polynomials section

Polynomial information and commands

4.3  Linear Algebra
Linear algebra operations act on Matrix and Vector data structures.

You can perform many linear algebra operations using task templates. In the
Task Browser (Tools>Tasks>Browse), expand the Linear Algebra folder.

Creating Matrices and Vectors

You can easily define matrices using the Matrix palette. To define vectors,
use the angle-bracket (<>) notation.

Creating Matrices

To create a matrix, use the Matrix palette. See Figure 4.2.
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Figure 4.2: Matrix Palette

In the Matrix palette, you can specify the matrix size (see Figure 4.3) and
properties. To insert a matrix, click the Insert Matrix button.
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Figure 4.3: Matrix Palette: Choosing the Size

After inserting the matrix:

1. Enter the values of the entries. To move to the next entry placeholder,
press Tab.

2. After specifying all entries, press Enter.
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> 

Creating Vectors

To create a vector, use angle brackets (< >).

To create a column vector, specify a comma-delimited sequence, <a, b, c>.
The number of elements is inferred from the number of expressions.

> 

To create a row vector, specify a vertical-bar-delimited (|) sequence, <a | b
| c>. The number of elements is inferred from the number of expressions.

> 

Editing and Viewing Large Matrices and Vectors

Matrices  and smaller, and vectors with 10 or fewer elements display

in the document. Larger objects are displayed as a placeholder.

For example, insert a  matrix.
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In the Matrix palette:

1. Specify the dimensions: 15 rows and 15 columns.

2. In the Type drop-down list, select a matrix type, for example, Custom
values.

3. Click Insert Matrix. Maple inserts a placeholder.

> 

To edit or view a large matrix or vector, double-click the placeholder. This
launches the Matrix Browser. See Figure 4.4.
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Figure 4.4: Matrix Browser

To specify the value of entries using the Matrix Browser:

1. Select the Table tab.

2. Double-click an entry, and then edit its value. Press Enter.

3. Repeat for each entry to edit.

4. When you have finished updating entries, click Done.
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You can view the matrix or vector as a table or as an image, which can be
inserted into the document. For more information, refer to the ?Mat-
rixBrowser help page.

To set the maximum dimension of matrices and vectors displayed inline:

• Use the interface command with the rtablesize option.

For example, interface(rtablesize = 15).

For more information, refer to the ?interface help page.

Creating Matrices and Vectors for Large Problems

By default, matrices and vectors can store any values. To increase the effi-
ciency of linear algebra computations, create matrices and vectors with
properties. You must specify the properties, for example, the matrix or vector
type or the data type, when defining the object.

The Matrix palette (Figure 4.2) supports several properties.

To specify the matrix type:

• Use the Shape and Type drop-down lists.

To specify the data type:

• Use the Data type drop-down list.

For example, define a diagonal matrix with small integer coefficients.

In the Matrix palette:

1. Specify the size of the matrix, for example, .

2. In the Shapes drop-down list, select Diagonal.

3. In the Data type drop-down list, select integer[1].

4. Click the Insert Matrix button.
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5. Enter the values in the diagonal entries.

> 

Note: To create a matrix with randomly-generated entries, select the Random
Type.

You cannot specify properties when defining vectors using the angle-
bracket notation. You must use the Vector constructor.

To define a column vector using the Vector constructor, specify:

• The number of elements. If you explicitly specify all element values,
this argument is not required.

• A list of expressions that define the element values.

• Parameters such as shape, datatype, and fill that set properties of the
vector.

The following two calling sequences are equivalent.

> 

> 
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To create a row vector using the Vector constructor, include row as an index.

> 

> 

The Matrix palette does not support some properties. To set all properties,
use the Matrix constructor.

To define a matrix using the Matrix constructor, specify:

• The number of rows and columns. If you explicitly specify all element
values, these arguments are not required.

• A list of lists that define the element values row-wise.

• Parameters such as shape, datatype, and fill that set properties of the
matrix.

For example:

> 

The Matrix palette cannot fill the matrix with an arbitrary value. Use the
fill parameter.

> 
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For more information on the constructors, including other calling sequence
syntaxes and parameters, refer to the ?storage, ?Matrix, and ?Vector help
pages.

See also Numeric Computations (page 150).

Accessing Entries in Matrices and Vectors

To select an entry in a vector, enter the vector name with a non-zero integer
index.

> 

> 

Negative integers select entries from the end of the vector.

> 

To create a Vector consisting of multiple entries, specify a list or range of
integers in the index. For more information, refer to the ?list and ?range
help pages.

142   •   4  Mathematical Computations



> 

> 

Similarly, you can access submatrices using an index. In the following two-
dimensional matrix, the first entry selects rows and the second, columns.

> 

> 

Linear Algebra Computations

You can perform matrix and vector computations using context menus and
the LinearAlgebra package.

Matrix Arithmetic

The matrix and vector arithmetic operators are the standard Maple arithmetic
operators up to the following two differences.
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• The scalar multiplication operator is the asterisk (*), which displays in
math as . The noncommutative matrix and vector multiplication op-

erator is the period (.).

• There is no division operator (/) for matrix algebra. (You can construct

the inverse of a matrix using the exponent .)

See Table 4.6.

> 

Table 4.6: Matrix and Vector Arithmetic Operators

ExampleOperatorOperation

> Addition

> Subtraction

> .Multiplication
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ExampleOperatorOperation

> 

> 

*Scalar Multiplication1

> 

> 

^Exponentiation2

1 You can specify scalar multiplication explicitly by entering *, which displays in 2-D

Math as . In 2-D Math, you can also implicitly multiply a scalar and a matrix or vector

by placing a space character between them. In some cases, the space character is optional.
For example, Maple interprets a number followed by a name as an implicit multiplication.
2In 2-D Math, exponents display as superscripts.

A few additional matrix and vector operators are listed in Table 4.7.

Define two column vectors.

> 
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Table 4.7: Select Matrix and Vector Operators

ExampleOperatorOperation

> ^%T1Transpose

> 
^%H1Hermitian Transpose

> 

> 

&x2Cross Product

(3-D vectors only)

1Exponential operators display in 2-D Math as superscripts.
2 After loading the LinearAlgebra package, the cross product operator is available as the
infix operator &x . Otherwise, it is available as the LinearAlgebra[CrossProduct] com-
mand.

For information on matrix arithmetic over finite rings and fields, refer to the
?mod help page.

Point-and-Click Interaction

Using context menus, you can perform many matrix and vector operations.

Matrix operations available in the context menu include the following.
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• Standard operations: determinant, inverse, norm (1, Euclidean, infinity,
or Frobenius), transpose, and trace

• Compute eigenvalues, eigenvectors, and singular values

• Compute the dimension or rank

• Convert to the Jordan form, or other forms

• Perform Cholesky decomposition and other decompositions

For example, compute the infinity norm of a matrix. See Figure 4.5.

Figure 4.5: Computing the Infinity Norm of a Matrix

In Document mode, Maple inserts a right arrow followed by the norm. See
Figure 4.6.
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Figure 4.6: Computing Norm in Document Mode

Vector operations available in the context menu include the following.

• Compute the dimension

• Compute the norm (1, Euclidean, and infinity)

• Compute the transpose

• Select an element

For more information on context menus, see Context Menus (page 20) (for
Document mode) or Context Menus (page 46) (for Worksheet mode).

LinearAlgebra Package Commands

The LinearAlgebra package contains commands that construct and manip-
ulate matrices and vectors, compute standard operations, perform queries,
and solve linear algebra problems.

Table 4.8 lists some LinearAlgebra package commands. For a complete
list, refer to the ?LinearAlgebra/Details help page.

Table 4.8: Select LinearAlgebra Package Commands

DescriptionCommand

Return a basis for a vector spaceBasis

Compute the cross product of two vectorsCrossProduct

Delete the rows of a matrixDeleteRow

Determine the dimension of a matrix or a vectorDimension

Compute the eigenvalues and eigenvectors of a matrixEigenvectors

Reduce a matrix to Frobenius formFrobeniusForm
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DescriptionCommand

Perform Gaussian elimination on a matrixGaussianElimination

Reduce a square matrix to Hessenberg formHessenbergForm

Construct a generalized Hilbert matrixHilbertMatrix

Test if a matrix is orthogonalIsOrthogonal

Compute the least-squares approximation to A . x = bLeastSquares

Solve the linear system A . x = bLinearSolve

Compute the inverse of a square matrix or pseudo-inverse of a non-
square matrix

MatrixInverse

Compute a QR factorization of a matrixQRDecomposition

Construct a random matrixRandomMatrix

Construct the Sylvester matrix of two polynomialsSylvesterMatrix

For information on arithmetic operations, see Matrix Arithmetic (page 143).

For information on selecting entries, subvectors, and submatrices, see Access-
ing Entries in Matrices and Vectors (page 142).

Example Determine a basis for the space spanned by the set of vectors {(2,
13, -15), (7, -2, 13), (5, -4, 9)}. Express the vector (25, -4, 9) with respect to
this basis.

> 

> 

Find a basis for the vector space spanned by these vectors, and then construct
a matrix from the basis vectors.

> 
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To express (25, -4, 9) in this basis, use the LinearSolve command.

> 

Numeric Computations

You can very efficiently perform computations on large matrices and vectors
that contain floating-point data using the built-in library of numeric linear
algebra routines. Some of these routines are provided by the Numerical Al-
gorithms Group (NAG®). Maple also contains portions of the CLAPACK
and optimized ATLAS libraries.

For information on performing efficient numeric computations using the
LinearAlgebra package, refer to the ?EfficientLinearAlgebra help page.

See also Creating Matrices and Vectors for Large Problems (page 139).

Student LinearAlgebra Package

The Student package contains subpackages that help instructors teach con-
cepts and allow students to visualize and explore ideas. These subpackages
also contain computational commands.
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In the Student[LinearAlgebra] subpackage, the environment differs from
that of the LinearAlgebra package in that floating-point computations are
generally performed using software precision, instead of hardware precision,
and symbols are generally assumed to represent real, rather than complex,
quantities. These defaults, and others, can be controlled using the SetDefault
command. For more information, refer to the ?Student[LinearAlgebra][Set-
Default] help page.

For information on using Maple as a teaching and learning tool, see Teaching
and Learning with Maple (page 178).

4.4  Calculus
The Task Browser (Tools>Tasks>Browse) contains numerous calculus
task templates. For a list of tasks, navigate to one of the related folders, such
as Calculus, Differential Equations, Multivariate Calculus, or Vector
Calculus.

This section describes the key Maple calculus commands, many of which
are used in task templates or available in the context menus.

For a complete list of calculus commands, refer to the Mathematics (includ-
ing Calculus, Differential Equations, Power Series, and Vector Calculus
subfolders) and Student Package sections of the Maple Help System Table
of Contents.

Limits

To compute the limit of an expression as the independent variable ap-
proaches a value:

1. In the Expression palette, click the limit item .

2. Specify the independent variable, limit point, and expression, and then
evaluate it.
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For example:

> 

The limit Command

By default, Maple searches for the real bidirectional limit (unless the limit
point is ∞ or -∞). To specify a direction, include one of the options left,
right, real, or complex in a call to the limit command. See Table 4.9.

Table 4.9: Limits

OutputCommand SyntaxLimit

undefined> 

> 

> 

Using the limit command, you can also compute multidimensional limits.

> 

For more information on multidimensional limits, refer to the ?limit/multi
help page.
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Numerically Computing a Limit

To numerically compute a limit:

• Use the evalf(Limit(arguments)) calling sequence.

Important: Use the inert Limit command, not the limit command. For more
information, refer to the ?limit help page.

The Limit command accepts the same arguments as the limit command.

For example:

> 

For information on the evalf command, see Numerical Approxima-
tion (page 313).

The Limit command does not compute the limit. It returns an unevaluated
limit.

> 

For more information on the Limit command, refer to the ?Limit help page.

Differentiation

Maple can perform symbolic and numeric differentiation.
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To differentiate an expression:

1. In the Expression palette, click the differentiation item  or the

partial differentiation item .

2. Specify the expression and independent variable, and then evaluate it.

For example, to differentiate  with respect to :

> 

You can also differentiate using context menus. For more information, see
Context Menus (page 20).

To calculate a higher order or partial derivative, edit the derivative symbol

inserted. For example, to calculate the second derivative of 

with respect to :

> 

To calculate the mixed partial derivative of :

> 
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The diff Command

Maple computes derivatives using the diff command. To directly use the
diff command, specify the expression to differentiate and the variable.

> 

(4.1)

> 

For information on equation labels such as (4.1), see Equation La-
bels (page 59).

To calculate a higher order derivative, specify a sequence of differentiation
variables. Maple recursively calls the diff command.

> 

To calculate a partial derivative, use the same syntax. Maple assumes that
the derivatives commute.

> 

To enter higher order derivatives, it is convenient to use the sequence oper-
ator ($). For more information, refer to the ?$ help page.
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To compute the nth derivative of an expression f in the independent variable

t, you can use the syntax .

For example:

> 

Differentiating an Operator

You can also specify a mathematical function as a functional operator (a
mapping). For a comparison of operators and other expressions, see Distinc-
tion between Functional Operators and Other Expressions (page 293).

To find the derivative of a functional operator:

• Use the D operator.

The D operator returns a functional operator.

For example, find the derivative of an operator that represents the mathem-

atical function .

First, define the mathematical function  as the operator F.

1. In the Expression palette, click the single-variable function definition

item .

2. Enter placeholder values.

• To move to the next placeholder, press the Tab key. Note: If pressing

the Tab key inserts a tab, click the Tab icon  in the toolbar.

> 

Now, define the operator, G, that maps  to the derivative of .
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> 

F and G evaluated at  return the expected values.

> 

For more information on the D operator, refer to the ?D help page. For a
comparison of the diff command and D operator, refer to the ?diffVersusD
help page.

Directional Derivative

To compute and plot a directional derivative, use the Directional Derivative
Tutor. The tutor computes a floating-point value for the directional derivat-
ive.

To launch the tutor:

From the Tools menu, select Tutors, Calculus - Multi-Variable, and then
Directional Derivatives. Maple launches the Directional Derivative Tutor.
See Figure 4.7.
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Figure 4.7: Directional Derivative Tutor

To compute a symbolic value for the directional derivative, use the Stu-
dent[MultivariateCalculus][DirectionalDerivative] command. The first
list of numbers specifies the point at which to compute the derivative. The
second list of numbers specifies the direction in which to compute the deriv-
ative.

For example, at the point [1, 2], the gradient of  points in the direction

[2, 4], which is the direction of greatest increase. The directional derivative
in the orthogonal direction [-2, 1] is zero.

> 
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> 

> 

Series

To generate the Taylor series expansion of a function about a point, use the
taylor command.

> 

Note: If a Taylor series does not exist, use the series command to find a
general series expansion.

For example, the cosine integral function does not have a taylor series expan-
sion about 0. For more information, refer to the ?Ci help page.

> 

Error, does not have a taylor expansion, try series()

To generate a truncated series expansion of a function about a point, use the
series command.

> 

4.4  Calculus   •   159



By default, Maple performs series calculations up to order 6. To use a differ-
ent order, specify a non-negative integer third argument.

> 

To set the order for all computations, use the Order environment variable.

For information about the Order variable and the  term, refer to the

?Order help page.

The expansion is of type series. Some commands, for example, plot, do not
accept arguments of type series. To use the expansion, you must convert it
to a polynomial using the convert/polynom command.

> 
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For information on Maple types and type conversions, see Maple Expres-
sions (page 285).

For information on plotting, see Plots and Animations (page 187).

Integration

Maple can perform symbolic and numeric integration.

To compute the indefinite integral of an expression:

1. In the Expression palette, click the indefinite integration item .

2. Specify the integrand and variable of integration, and then evaluate it.

For example, to integrate  with respect to x:

> 

Recall that you can also enter symbols, including  and , using symbol

completion.

• Enter the symbol name (or part of the name), for example, int and d, and
then press the completion shortcut key.

For more information, see Symbol Names (page 16).

You can also compute an indefinite integral using context menus. For more
information, see Context Menus (page 20).
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To compute the definite integral of an expression:

1. In the Expression palette, click the definite integration item .

2. Specify the endpoints of the interval of integration, integrand expression,
and variable of integration, and then evaluate it.

For example, to integrate  over the interval (0, ∞):

> 

(4.2)

Maple treats the parameter a as a complex number. As described in Assump-
tions on Variables (page 116), you can compute under the assumption that a
is a positive, real number using the assuming command.

> 

The int Command

 and  use the int command. To use the int command directly,

specify the following arguments.

• Expression to integrate

• Variable of integration
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> 

(4.3)

> 

For a definite integration, set the variable of integration equal to the interval
of integration.

> 

Numeric Integration

To perform numeric integration:

• Use the evalf(Int(arguments)) calling sequence.

Important: Use the inert Int command, not the int command. For more in-
formation, refer to the ?int help page.

In addition to the arguments accepted by the int command, you can include
optional arguments such as method, which specifies the numeric integration
method.

For example:

> 
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Note: To enter an underscore character (_) in 2-D Math, enter \_.

For information on the evalf command, see Numerical Approxima-
tion (page 313).

For information on numeric integration, including iterated integration and
controlling the algorithm, refer to the ?evalf/Int help page.

To compute iterated integrals, line integrals, and surface integrals, use the
task templates (Tools>Tasks>Browse) in the Multivariate and Vector
Calculus folders.

Differential Equations

Maple has a powerful set of solvers for ordinary differential equations (ODEs)
and partial differential equations (PDEs), and systems of ODEs and PDEs.

For information on solving ODEs and PDEs, see Other Specialized Solv-
ers (page 88).

Calculus Packages

In addition to top-level calculus commands, Maple contains calculus pack-
ages.

VectorCalculus Package

The VectorCalculus package contains commands that perform multivariate
and vector calculus operations on VectorCalculus vectors (vectors with an
additional coordinate system attribute) and vector fields (vectors with addi-
tional coordinate system and vectorfield attributes), for example, Curl, Flux,
and Torsion.

> 

> 

164   •   4  Mathematical Computations



> 

Find the curl of VectorField1.

> 

Find the flux of VectorField1 through a sphere of radius r at the origin.

> 

Compute the torsion of a space curve. The curve must be a vector with
parametric function components.

> 

For information on the assuming command, see The assuming Com-
mand (page 118).

For more information on the VectorCalculus package, including a complete
list of commands, refer to the ?VectorCalculus help page.
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To find other calculus packages, such as VariationalCalculus, refer to the
?index/package help page.

Student Calculus Packages

The Student package contains subpackages that help instructors teach con-
cepts and allow students to visualize and explore ideas. These subpackages
also contain computational commands. The Student calculus subpackages
include Calculus1, MultivariateCalculus, and VectorCalculus. The Stu-
dent[VectorCalculus] package provides a simple interface to a limited
subset of the functionality available in the VectorCalculus package.

For information on using Maple as a teaching and learning tool, and some
computational examples, see Teaching and Learning with Maple (page 178).

4.5  Optimization
Using the Optimization package, you can numerically solve optimization
problems. The package uses fast Numerical Algorithms Group (NAG) al-
gorithms to minimize or maximize an objective function.

The Optimization package solves constrained and unconstrained problems.

• Linear programs

• Quadratic programs

• Nonlinear programs

• Linear and nonlinear least-squares problems

The Optimization package contains local solvers. In addition, for univariate
finitely-bounded nonlinear programs with no other constraints, you can
compute global solutions using the NLPSolve command. To find global
solutions generally, purchase the Global Optimization Toolbox. For more
information, visit http://www.maplesoft.com/products/toolboxes.
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Point-and-Click Interface

The primary method for solving optimization problems is the Optimization
Assistant.

To launch the Optimization Assistant:

• From the Tools menu, select Assistants, and then Optimization.

Maple inserts the Optimization[Interactive]() calling sequence (in Worksheet
mode), and launches the Optimization Assistant. See Figure 4.8.

Figure 4.8: Optimization Assistant

To solve a problem:

1. Enter the objective function, constraints, and bounds.

4.5  Optimization   •   167



2. Select the Minimize or Maximize radio button.

3. Click the Solve button. The solution is displayed in the Solution text box.

You can also enter the problem (objective function, constraints, and bounds)
in the calling sequence.

For example, find the maximum of  subject to the constraints

.

> 

After finding a solution, you can plot it. To plot a solution:

In the Optimization Assistant window, click the Plot button. The Optimiz-
ation Plotter window is displayed. See Figure 4.9.
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Figure 4.9: Optimization Assistant Plotter Window

For information on the algorithms used to solve optimization problems, refer
to the ?Optimization/Methods help page.

Large Optimization Problems

The Optimization Assistant accepts input in an algebraic form. You can
specify input in other forms, described in the ?Optimization/InputForms
help page, in command calling sequences.
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The Matrix form, described in the ?Optimization/MatrixForm help page,
is more complex but offers greater flexibility and efficiency.

For example, solve the quadratic program:

maximize  subject to , where  is the vector of

problem variables.

Define the column vector, c, of the quadratic objective function.

> 

Define the symmetric Hessian matrix, H, of the quadratic objective function.

> 

Define the matrix A, the coefficient matrix for the linear inequality con-
straints.

> 

Define the column vector b, the linear inequality constraints.

> 

The QPSolve command solves quadratic programs.

> 

Note: For information on creating matrices and vectors (including how to
use the Matrix palette to easily create matrices), see Linear Al-
gebra (page 133).
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For additional information on performing efficient computations, refer to
the ?Optimization/Computation help page.

MPS(X) File Support

To import linear programs from a standard MPS(X) data file, use the Import-
MPS command.

Additional Information

For a complete list of commands and other Optimization package informa-
tion, refer to the ?Optimization help page.

4.6  Statistics
The Statistics package is a collection of commands and the point-and-click
Data Analysis Assistant—refer to the ?Statistics[InteractiveDataAnalysis]
help page—for performing computations in mathematical statistics and data
analysis. The package supports a wide range of common statistical tasks in-
cluding quantitative and graphical data analysis, simulation, and curve fitting.

In addition to standard data analysis tools, the Statistics package provides
a wide range of symbolic and numeric tools for computing with random
variables. The package supports over 35 major probability distributions and
can be extended to include new distributions.

Probability Distributions and Random Variables

The Statistics package supports:

• Continuous distributions, which are defined along the real line by prob-
ability density functions. Maple supports many continuous distributions,
including the normal, Student-t, Laplace, and logistic distributions.

• Discrete distributions, which have nonzero probability only at discrete
points. A discrete distribution is defined by a probability function. Maple
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supports many discrete distributions, including the Bernoulli, geometric,
and Poisson distributions.

For a complete list of distributions, refer to the ?Statistics/Distributions
help page.

You can define random variables by specifying a distribution in a call to the
RandomVariable command.

> 

> 

Find the probability distribution function for X. (For information on statistics
computations, see Statistical Computations (page 173)).

> 

 represents the Dirac delta function. For more information, refer to the

?Dirac help page.

Adding Custom Distributions

To add a new distribution, specify a probability distribution in a call to the
Distribution command.

> 

To construct a piecewise-continuous function in 1-D Math, use the piecewise
command, for example, t -> piecewise(t < 0, 0, t < 3, 1/3, 0).
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Define a new random variable with this distribution.

> 

Calculate the mean value of the random variable.

> 

For more information, refer to the ?Statistics/Distributions help page.

Statistical Computations

In addition to basic functions, like mean, median, standard deviation, and
percentile, the Statistics package contains commands that compute, for ex-
ample, the interquartile range and hazard rate.

Examples

Example 1

Compute the average absolute range from the interquartile of the Rayleigh
distribution with scale parameter 3.

> 

To compute the result numerically:
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• Specify the 'numeric' option.

> 

Example 2

Compute the hazard rate of the Cauchy distribution with location and scale
parameters a and b at an arbitrary point t.

> 

You can specify a value for the point t.

> 

You can also specify that Maple compute the result numerically.

> 
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For more information, refer to the ?Statistics/DescriptiveStatistics help
page.

Plotting

You can generate statistical plots using the visualization commands in the
Statistics package. Available plots include:

• Bar chart

• Frequency plot

• Histogram

• Pie Chart

• Scatter Plot

For example, create a scatter plot for a distribution of points that vary from

 by a small value determined by a normally distributed sample.

> 

> 

> 

> 

> 
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For information on plotting options, such as title, see Plots and Anima-
tions (page 187).

To fit a curve to the data points, include the optional fit equation parameter.

Using the plots[display] command, create a plot that contains the:

• Scatter plot of the data points

• Quartic polynomial fit ted to the data points:

• Function 

> 
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> 

> 

For more information on statistical plots, refer to the ?Statistics/Visualization
help page.

For an overview of plotting, see Plots and Animations (page 187).

Additional Information

For more information on the Statistics package, including regression analysis,
estimation, data manipulation, and data smoothing, refer to the ?Statistics
help page.
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4.7  Teaching and Learning with
Maple
Table 4.10 resources for instructors and students. For additional resources
see Table 4.1 (page 121).

Table 4.10: Student and Instructor Resources

DescriptionResource

The Student package contains computational and visual-
ization (plotting and animation) functionality, and
point-and-click interfaces for explaining and exploring
concepts (Tools>Tutors). For more information, refer to
the ?Student help page.

Student Packages and Tutors

The Maple Help System has an integrated dictionary of
over 5000 mathematics and engineering terms. You can
search the dictionary using the Help System search engine.

(Help>Manuals, Dictionary, and more>Dictionary)

Mathematics and Engineering
Dictionary

The Maple Application Center contains tutorials and ap-
plications that help instructors begin using Maple and use
Maple in the classroom. Browse the many resources in
the Education and Education PowerTools categories.

(http://www.maplesoft.com/applications)

Maple Application CenterTM
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DescriptionResource

The Maple Student Center contains tutorials and applica-
tions that help students learn how to use Maple, explore
mathematical concepts, and solve problems. Available
resources include:

• Study guides - Complete lessons with examples for
academic courses, including precalculus and calculus.
For example, the Interactive Precalculus Study Guide
contains worked problems, each solved as in a stand-
ard textbook, using Maple commands and custom
Maplet graphical interfaces.

• Free course lessons for many subjects including pre-
calculus to vector calculus; high school, abstract, and
linear algebra; engineering; physics; differential
equations; cryptography; and classical mechanics.

(http://www.maplesoft.com/academic/students)

Maple Student CenterTM

Student Packages and Tutors

The Student package is a collection of subpackages for teaching and learning
mathematics and related subjects. The Student package contains packages
for a variety of subjects, including precalculus, calculus, and linear algebra.

Instructors can:

• Teach concepts without being distracted by the mechanics of the compu-
tations.

• Create examples and quickly update them during a lesson to demonstrate
different cases or show the effect of the variation of a parameter.

• Create plots and animations to visually explain concepts, for example,
the geometric relationship between a mathematical function and its de-
rivatives (Tools>Tutors>Calculus - Single Variable>Derivatives). See
Figure 4.10.
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Figure 4.10: Student[Calculus1] Derivatives Tutor

Students can:

• Perform step-by-step computations, for example, compute a derivative
by applying differentiation rules using commands or a tutor
(Tools>Tutors>Calculus - Single Variable>Differentiation Methods).
See Figure 4.11.

• Perform computations.

• Visually explore concepts.
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Figure 4.11: Student[Calculus1] Differentiation Methods Tutor

Tutors provide point-and-click interfaces to the Student package functional-
ity.

To launch a tutor:

1. From the Tools menu, select Tutors.

2. Select a subject, for example, Calculus - Multi-Variable.

3. Select a tutor, for example, Gradients.
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Maple inserts the Student[MultivariateCalculus][GradientTutor]() calling
sequence (in Worksheet mode), and launches the Multivariate Calculus
Gradient Tutor.

By rotating the three-dimensional plot, you can show that the gradient points
in the direction of greatest increase of the surface (see Figure 4.12) and show
the direction of the gradient vector in the x-y plane (see Figure 4.13).

Figure 4.12: Multivariate Calculus Gradient Tutor
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Figure 4.13: Multivariate Calculus Gradient Tutor Showing x-y Plane

When you close the tutor, Maple inserts the 3-D plot.

> 
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Many Student package commands can return a value, mathematical expres-
sion, plot, or animation. This allows you to compute the final answer, see
the general formula applied to a specific problem, or visualize the underlying
concepts.

For example, the Student[VectorCalculus][LineInt] (line integral) command
can return the following.

• Plot that visually indicates the vector field, path of integration, and tangent
vectors to the path

• Unevaluated line integral

• Numeric value of the line integral

> 

> 
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> 

(4.4)

To evaluate the integral returned by the output = integral calling sequence,
use the value command.

> 

By default, the LineInt command returns the value of the integral.

> 
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For more information on the Student package, refer to the ?Student help
page.
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5  Plots and Animations
Maple can generate many forms of plots, allowing you to visualize a problem
and further understand concepts.

• Maple accepts explicit, implicit, and parametric forms to display 2-D
and 3-D plots and animations.

• Maple recognizes many coordinate systems.

• All plot regions in Maple are active; therefore, you can drag expressions
to and from a plot region.

• Maple offers numerous plot options, such as axes styles, title, colors,
shading options, surface styles, and axes ranges, which give you complete
control to customize your plots.

5.1  In This Chapter
TopicsSection

• Interactive Plot Builder

• Context Menu

• Dragging to a Plot Region

• The plot and plot3d Commands

• The plots Package

• Multiple Plots in the Same Plot Re-
gion

Creating Plots - Interactive and command-driven
methods to display 2-D and 3-D plots

• Interactive Plot Builder Options

• Context Menu Options

• The plot and plot3d Command Op-
tions

Customizing Plots - Methods for applying plot
options before and after a plot displays
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TopicsSection

• Point Probe

• Rotate

• Pan

• Zoom

Analyzing Plots - Plot analyzing tools

• Interactive Plot Builder

• The plots[animate] Command

Creating Animations - Interactive and command-
driven methods to display animations

• Animation Context BarPlaying Animations - Tools to run animations

• Interactive Plot Builder Animation
Options

• Context Menu Options

• The animate Command Options

Customizing Animations - Methods for applying
plot options before and after an animation dis-
plays

• Saving Plots to File FormatsExporting - Methods for exporting plots

• Accessing Code for the Color PlatesCode for Color Plates - Information on color
plates

5.2  Creating Plots
Maple offers several methods to easily plot an expression. These methods
include:

• The Interactive Plot Builder

• Context menus

• Dragging to a plot region

• Commands

Each method offers a unique set of advantages. The method you use depends
on the type of plot to display, as well as your personal preferences.

188   •   5  Plots and Animations



Interactive Plot Builder

The Interactive Plot Builder is a point-and-click interface to the Maple
plotting functionality. The interface displays plot types based on the expres-
sion you specify. The available plot types include plots, interactive plots,
animations, or interactive animations. Depending on the plot type you select,
you can create a:

• 2-D / 3-D plot

• 2-D / 3-D conformal plot of a complex-valued function

• 2-D / 3-D complex plot

• 2-D density plot

• 2-D gradient vector-field plot

• 2-D implicit plot

Using the Interactive Plot Builder, you can:

(1) Specify the plotting domain before you launch the graph

(2) Specify the endpoints of the graph as symbolic, for example, Pi, sqrt(2)

(3) Select different kinds of graphs such as animations, and interactive with
slider control of the parameter, that is, customize and display a plot by select-
ing from the numerous plot types and applying plot options without any
knowledge of plotting command syntax

(4) Apply the discont=true option for a discontinuous graph

The output from the Interactive Plot Builder is a plot of the expression or
the command used to generate the plot in the document.

To launch the Interactive Plot Builder:

• From the Tools menu, select Assistants, and then Plot Builder. Note:
The Tools menu also offers tutors to easily generate plots in several
academic subjects. For more information, see Teaching and Learning
with Maple (page 178).
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Table 5.1: Windows of the Interactive Plot Builder

2. Select Plot Type window1. Specify Expressions window

1. Specify Expressions window - Add, edit, or remove expressions and
variables. Once finished, you can advance to the Select Plot Type window.

2. Select Plot Type window - Select the plot type and corresponding plot,
and edit the ranges. Once finished, you can display the plot or advance to
the Plot Options window.
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3. Plot Options window

3. Plot Options window - Apply plot options. Once finished, you can display
the plot or return the command that generates the plot to the document.
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Example 1 - Display a plot of a single variable expression

Maple can display two-dimensional graphs and offers numerous plot options
such as color, title, and axes styles to customize the plot.

Table 5.2: Displaying a Plot of a Single Variable Expression

DetailsStep

1. Ensure the cursor is in a Maple input region.

2. From the Tools menu, select Assistants, and then 

Plot Builder.

Notes: 1. Maple inserts plots[interactive](); in the 

               Maple document. Entering this command  

               at the Maple prompt also invokes the Plot 

               Builder.

            2. Interaction with the document is disabled 

                while the Plot Builder is running.

Launch the Interactive Plot
Builder.

1. In the Specify Expressions window:

          a. Add the expression, sin(x)/x.

          b. Click Done to proceed to the Select Plot Type

              window.

Enter an expression.
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DetailsStep

1. In the Select Plot Type window, notice the default 

setting of a 2-D plot type and an x axis range, -10 .. 10. 

Notice also the various plot types available for this 

expression.

2. Click Plot. 

Plot the expression.

To see the Maple syntax used to generate this plot, see Maple commands
from Creating Plots: Interactive Plot Builder (page 207)

Example 2 - Display a plot of multiple expressions of 1 variable

Maple can display multiple expressions in the same plot region to compare
and contrast. The Interactive Plot Builder accepts multiple expressions.
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Table 5.3: Displaying a Plot of Multiple Expressions of 1 Variable

DetailsStep

1. Launch the Interactive Plot Builder.

The Plot Builder accepts expressions and performs basic 

calculations on expressions. For example, entering 

diff(sin(x^2), x) in the Specify Expression window 

performs the calculation and displays the expression 

as 2*cos(x^2)*x in the Expression group box. 

2. In the Specify Expressions window: 

          a. In three separate steps, add the expressions 

              sin(x^2), diff(sin(x^2),x), and int(sin(x^2), x).

Launch the Interactive Plot
Builder and enter the expres-
sions.

In the Select Plot Type window:

          a. Change the x Axis range to -3 .. 3.

          b. Click Options to proceed to the Plot Options

              window.

Change the x-axis range.

Click Command.Launch the Plot Options win-
dow and return the plot com-
mand syntax to the document.

Execute the inserted command, that is, display the plot.Display the actual plot.
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By default, Maple displays each plot in a plot region using a different color.
You can also apply a line style such as solid, dashed, or dotted for each ex-
pression in the graph. For more information, refer to the ?plot/options help
page. To see the Maple syntax used to generate this plot, see Maple com-
mands from Creating Plots: Interactive Plot Builder (page 207)

Example 3 - Display a plot of a multi-variable expression

Maple can display three-dimensional plots and offers numerous plot options
such as light models, surface styles, and shadings to allow you to customize
the plot.

Table 5.4: Displaying a Plot of a Multi-variable Expression

DetailsStep

Add the expression (1+sin(x*y))/(x^2+y^2).Launch the Interactive Plot
Builder and enter an expression.
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DetailsStep

In the Select Plot Type window: 

          a. Notice the available plot types for an expression 

              with 2 variables, as well as the plot objects for 

              each type.

          b. Click Options.

Launch the Plot Options win-
dow.

In the Plot Options window:

          a. From the Variables column, change the 

              Range fields to 0 .. 0.05.

          b. From the Labels column, enter z.

          c. From the Color group box, select Light

              Model, and then green-red. 

          d. From the Color group box, select Shading, 

              and then z (grayscale).

          e. From the Style group box, select patch w/o 

              grid.

          f. From the Miscellaneous group box, select 

             Grid Size, and then 40, 40.

Set plot options.

Click Plot.Plot the expression.
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To see the Maple syntax used to generate this plot, see Maple commands
from Creating Plots: Interactive Plot Builder (page 207)

Example 4 - Display a conformal plot

Maple can display a conformal plot of a complex expression mapped onto
a two-dimensional grid or plotted on the Riemann sphere in 3-D.

Table 5.5: Displaying a Conformal Plot

DetailsStep

Add the expression z^3.Launch the Interactive Plot
Builder and enter an expression.
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DetailsStep

In the Select Plot Type window: 

          a. From the Select Plot group box, select 2-D            

              conformal plot of a complex-valued 

              expression.

          b. Change the range of the z parameter to 

               0 .. 2+2*I.

Select a plot type.

In the Plot Options window: 

          a. From the Axes group box, select normal.

          b. From the Miscellaneous group box, select 

              the Grid Size drop-down menu option 30, 30.

Set plot options.

Click Plot.Plot the expression.
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Example 5 - Display a plot in polar coordinates

Cartesian (ordinary) coordinates is the Maple default. Maple also supports
numerous other coordinate systems, including hyperbolic, inverse elliptic,
logarithmic, parabolic, polar, and rose in two-dimensions, and bipolar cyl-
indrical, bispherical, cylindrical, inverse elliptical cylindrical, logarithmic
cosh cylindrical, Maxwell cylindrical, tangent sphere, and toroidal in three-
dimensional plots. For a complete list of supported coordinate systems, refer
to the ?coords help page.

Table 5.6: Displaying a Plot in Polar Coordinates

DetailsStep

Add the expression 1+4*cos(4*theta).Launch the Interactive Plot
Builder and enter an expression.

In the Select Plot Type window:

          a. Change the x axis range to 0 .. 8*Pi.

Change the x-axis range.

In the Plot Options window: 

          a. From the Coordinate System group box, 

              select polar. 

          b. From the Color group box drop down menu, 

              select magenta.

Set plot options.

Click Plot.Plot the expression.
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To see the Maple syntax used to generate this plot, see Maple commands
from Creating Plots: Interactive Plot Builder (page 207)

Example 6 - Interactive Plotting

Using the Interactive Plot Builder, you can plot an expression with several
of its variables set to numeric values. The Interactive Parameter window
allows you to interactively adjust these numeric values within specified
ranges to observe their effect.
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Figure 5.1: Interactive Parameter Window

Table 5.7: Interactive Plotting

DetailsSteps

Add the expression x+3*sin(x*t).Launch the Interactive Plot
Builder and enter an expres-
sion.
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DetailsSteps

In the Select Plot Type window: 

          a. From the Select Plot group box, select 

              Interactive Plot with 1 parameter.

          b. Change the range of the x-axis to 0 .. 5.

          c. Change the t range to 0 .. 10.

          d. Click Plot to launch the Interactive Parameter

              window.

Note: To apply plot options before interactively adjusting 

the plot, click Options to launch the Plot Options window. 

After setting the plot options, click Plot to display the 

Interactive Parameter window.

Select a plot type.

1. To adjust the numeric values, use the slider.

2. Click Done to return the plot to the Maple document.

Adjust the plot.
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To see the Maple syntax used to generate this plot, see Maple commands
from Creating Plots: Interactive Plot Builder (page 207)

For information on customizing plots using the Interactive Plot Builder,
refer to Customizing Plots : Interactive Plot Builder Options (page 215).

Context Menu

A context menu in Maple displays a list of commands to manipulate, display,
or calculate using a Maple expression. The commands in the menu depend
on the type of the expression. To display the context menu for a Maple ex-
pression, right-click (for Macintosh, Control-click) the expression.

For expressions, the context menu lists:

• 2-D or 3-D plot

• 2-D or 3-D implicit plot

• Interactive Plot Builder

based on the expression selected.
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By invoking the Interactive Plot Builder through the context menu, the
expression automatically passes to the builder and Maple does not display
the Specify Expression window.

One advantage of using the context menu is the simplicity of creating an
expression using menus. By using this method, you do not need any know-
ledge of plot command syntax.

1. Enter and evaluate an expression, for example, 

2. Right-click (Control-click for Macintosh) the expression.

3. From the context menu, select Plots > 3-D Plot > x,y.
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> 
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For information on customizing plots using the context menu, see Context
Menu Options (page 216).

Dragging to a Plot Region

To use the drag-and-drop method, use the plot region created by one of the
other methods or insert an empty plot region into the document. Empty plot
regions can be two-dimensional or three-dimensional.

Advantages of the drag-and-drop method include the ease of adding and re-
moving plots and the independence from plotting command syntax.

1. From the Insert menu, select Plot, and then 2D.

2. Enter the expression sin(x) in an input region.

3. Select the full expression in the input region and drag it into the plot region.

4. Repeat steps 2 and 3 using the following expressions: sin(2*x), sin(x+2),
and sin(x)^2.

5. To remove an expression from the plot region, drag-and-drop the expres-
sion plot from the plot region to a Maple input region.
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The plot and plot3d Commands

The final method for creating plots is entering plotting commands.

The main advantages of using plotting commands are the availability of all
Maple plot structures and the greater control over the plot output. Plot options
are discussed in Customizing Plots (page 215).

Table 5.8: The plot and plot3d Commands

plot(plotexpression, x=a..b, ...)

plot3d(plotexpression, x=a..b, y=a..b, ...)

• plotexpression - expression to be plotted

• x=a..b - name and horizontal range

• y=a..b - name and vertical range

Maple commands from Creating Plots: Interactive Plot Builder

The following examples show the plotting commands returned by the ex-
amples in Interactive Plot Builder (page 189).

Example 1 - Display a plot of a single variable expression

> 
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Example 2 - Display a plot of multiple expressions of 1 variable

To display multiple expressions in a plot, include the expressions in a list.

To enter and use the Expression palette. For more

information, see Entering Expressions (page 10).

> 

Example 3 - Display a plot of a multi-variable expression

> 

Example 4 - Display a conformal plot

A collection of specialized plotting routines are available in the plots package.
For access to a single command in a package, use the long form of the
command.

> 

Example 5 - Display a plot in polar coordinates

> 

Example 6 - Interactive Plotting

> 

For more information on the plot options described in this section, refer to
the ?plot/options and ?plot3d/options help pages.
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Display a Parametric Plot

Some graphs cannot be specified explicitly. In other words, you cannot write
the dependent variable as a function of the independent variable, y=f(x). One
solution is to make both the x-coordinate and the y-coordinate depend upon
a parameter.

> 

Display a 3-D Plot

Maple can plot an expression of two variables as a surface in three-dimen-
sional space. To customize the plot, include plot3d options in the calling
sequence. For a list of plot options, see The plot and plot3d Options (page 219).
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> 

The plots Package

The plots package contains numerous plot commands for specialized plotting.
This package includes: animate, contourplot, densityplot, fieldplot, ode-
plot, matrixplot, spacecurve, textplot, and tubeplot. For details about this
package, refer to the ?plots help page.

> 

The pointplot Command

To plot numeric data, use the pointplot command in the plots package with
the data organized in a list of lists structure of the form [[x1, y1], [x2, y2],
..., [xn, yn]]. By default, Maple does not connect the points. To draw a line
through the points, use the style = line option. For further analysis of data
points, use the Curve Fitting Assistant, (Tools>Assistants>CurveFitting)
which fits and plots a curve through the points. For more information, refer
to the ?CurveFitting[Interactive] help page.
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> 

The matrixplot Command

The matrixplot command plots the values of a plot object of type Matrix.
The matrixplot command accepts options such as heights and gap to control
the appearance of the plot. For more information on Matrices, see Linear
Algebra (page 133).

> 

> 
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> 

> 
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The contourplot Command

The contourplot command generates a topographical map for an expression
or function. To create a smoother, more precise plot, increase the number of
points using the numpoints option.

> 

Multiple Plots in the Same Plot Region

List of Expressions

To display multiple expressions in the same plot region, enter the expressions
in a list data structure. To distinguish the surfaces, apply different shading
options, styles, or colors to each surface.
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> 

The display Command

To display different types of plots in the same plot region, use the display
command in the plots package.

This example plots a curve over a hill with the shadow of the curve projected
onto the hill.

> 

> 

> 

> 

> 

Maple can draw curves in three-dimensional space.
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> 

> 

> 

> 

Now that you have seen how easy it is to incorporate a plot into your work,
the next section illustrates how to customize plots.

5.3  Customizing Plots
Maple provides many plot options to display the most aesthetically pleasing,
illustrative results. Plot options include line styles, colors, shadings, axes
styles, and titles where applicable. Plot options are applied using the Inter-
active Plot Builder, the context menus, or as options in the command syntax.

Interactive Plot Builder Options

The Interactive Plot Builder offers most of the plot options available in
Maple in an easy-to-use interface.
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Table 5.9: Customizing Plots Using Interactive Plot Builder

DetailsSteps

Add the expression 2*x^5-10*x^3+6*x-1. For information
on interacting with the Interactive Plot Builder, see Ex-
ample 1 - Display a plot of a single variable expres-
sion (page 192)

Launch the Interactive Plot
Builder and enter the expres-
sion.

In the Select Plot Type window, change the x-axis range to
-2 .. 2.

Set the x-axis range.

In the Plot Options window: 

          a. From the Line group box, select dot.

          b. From the Color group box, select blue.

          c. From the Axes group box, select frame.

          d. From the Title group box, enter My Plot in the 

              text field. 

Set plot options.

Click Plot.Plot the expression.

Context Menu Options

Using the context menu, you can alter a plot by right-clicking (for Macintosh,
Control-clicking) the plot output. You can also access a large subset of plot
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options using the Plot toolbar and Plot menu options. These menus display
when a plot region is selected. Regardless of the method used to insert a plot
into Maple, you can use the context menu to apply different plot options.
For a list of options available when plotting in two and three dimensions,
see The plot and plot3d Options (page 219).

2-D Plot Options

Some plots do not display as you would expect using default option values.
A expression with a singularity is one such example.

> 

In the previous plot, all interesting details of the plot are lost because there
is a singularity at x = 1. The solution is to view a narrower range, for example,
from y = 0 to 7.

Table 5.10: Customizing 2-D Plots Using the Context Menu

DetailsSteps

1. Right-click the plot region. Select Axes, and then Range.

2. In the Axes Ranges dialog, in the y group box, select the
bottom radio button and enter 0 and 7 in the text regions
provided.

Alter the y-axis range.
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DetailsSteps

Place the mouse pointer on the curve and right-click (Con-
trol-click, for Macintosh). Note: The curve is selected when
it becomes highlighted. Select Color, and then Green.

Change the color.

Select Style, and then Point.Change the line style.

3-D Plot Options

By default, Maple displays the graph as a shaded surface and scales the plot
to fit the window. To change these options, use the context menu.

> 

Maple has many preselected light source configurations.

Table 5.11: Customizing 3-D Plots Using the Context Menu

DetailsSteps

Right-click the plot region. Select Style, and then Patch
(Without Grid).

Change the style.

Select Lighting, and then Light Scheme 1.Apply a light scheme.

Select Color, and then Z (Grayscale).Change the color.
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DetailsSteps

Select Axes, and then Boxed.Change the axes style.

Select Glossiness. Using the slider, adjust the level of
glossiness.

Alter the glossiness.

The plot and plot3d Options

If you are using commands to insert a plot, you can specify plot options as
arguments at the end of the calling sequence. You can specify the options
in any order. Applying plot options in the command syntax offers a few more
options and greater control than what is available in the Interactive Plot
Builder and context menus.

Table 5.12: Popular Plot Options

DescriptionOption

Defines the type of axes, one of: boxed, frame, none, or normalaxes

Defines the caption for the plotcaption

Defines a color for the curves to be plottedcolor

Defines the font for text objects in the plotfont

Controls the amount of light reflected from the surfaceglossiness (3-D)

Defines gridlines in the plotgridlines (2-D)

Controls the light model to illuminate the plot, one of: none, light1,
light2, light3, or light4

lightmodel (3-D)

Defines the dash pattern used to render lines in the plot, one of: dash,
dashdot, dot, or solid

linestyle

Defines a legend for the plotlegend (2-D)

Controls the minimum total number of points generatednumpoints

Controls the scaling of the graph, one of: constrained or uncon-
strained

scaling
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DescriptionOption

Defines how the surface is colored, one of: xyz, xy, z, zgrayscale,
zhue, or none

shading (3-D)

Defines how the surface is to be drawn, one of: line, point, polygon,
or polygonoutline for 2-D plots; contour, point, surface, surfacecon-
tour, surfacewireframe, wireframe, or wireframeopaque for 3-D
plots

style

Defines the symbol for points in the plot, one of: asterisk, box, circle,
cross, diagonalcross, diamond, point, solidbox, solidcircle, or
soliddiamond for 2-D plots; asterisk, box, circle, cross, diagonal-
cross, diamond, point, solidsphere, or sphere for 3-D plots

symbol

Defines a title for the plottitle

Defines the thickness of lines in the plotthickness

Controls the transparency of the plot surfacetransparency (3-D)

Defines the minimum and maximum coordinate values of the curve
displayed on the screen

view

For a complete list of plot options, refer to the ?plot/options and
?plot3d/options help pages.
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> 

To create a smoother or more precise plot, calculate more points using the
numpoints option.

> 
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5.4  Analyzing Plots

Point Probe, Rotate, Pan, and Zoom Tools

To gain further insight into a plot, Maple offers various tools to analyze plot
regions. These tools are available in the Plot menu menu, Context Bar and
in the context menu under Transform when the plot region is selected.

Table 5.13: Plot Analysis Options

DescriptionIconName

Display the coordinates corresponding to the cursor position on a
two-dimensional plot in the context bar (upper left-hand corner)

Point probe

(2-D)

Rotate a three-dimensional plot to see it from a different point of
view

Rotate

(3-D)

Pan the plot by changing the view ranges for 2-D plots. Smartplots
will resample to reflect the new view. Change the position of the
plot in the plot region for 3-D plots

Pan

Zoom into or out of the plot by changing the view ranges for 2-D
plots. Smartplots will resample to reflect the new view. Make the
plot larger or smaller in the plot window for 3-D plots

Zoom

5.5  Creating Animations
Plotting is an excellent way to represent information. Animations allow you
to emphasize certain graphical behavior, such as the deformation of a boun-
cing ball, clearer then in a static plot. A Maple animation is a number of plot
frames displayed in sequence, similar to the action of movie frames. To
create an animation, use the Interactive Plot Builder or commands.
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Interactive Plot Builder

Table 5.14: Creating Animations Using the Interactive Plot Builder

DetailsSteps

Add the expression sin(i*sqrt(x^2+y^2)/10). For information
on interacting with the Interactive Plot Builder, see Example
1 - Display a plot of a single variable expression (page 192).

Launch the Interactive Plot
Builder and enter the expres-
sion.

In the Select Plot Type window: 

          a. From the Select Plot Type drop-down menu, 

              select Animation.

          b. Change the x Axis range to -6 .. 6.

          c. Change the y Axis range to -6 .. 6.

          d. Change the Animation Parameter (i) range to 

              1 .. 30.

Set axes and animation
parameter range.

In the Plot Options window:

          a. From the Style group box, select Surface.

          b. From the Color group box, in the Light Model

              drop-down menu select red-turquoise.

          b. From the Color group box, in the Shading

              drop-down menu select z (grayscale).

          c. In the View group box, select the Constrained

              Scaling check box.

Set plot options.
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DetailsSteps

Click Plot.Plot the expression.

> 

For information on playing the animation, see Playing Animations (page 226).
To see the Maple syntax used to generate this plot, see Maple Syntax for
Creating Animations: Interactive Plot Builder Example (page 225).

The plots[animate] Command

You can also use the animate command, in the plots package, to generate
animations.
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Table 5.15: The animate Command

animate(plotcommand, plotarguments, t=a..b, ...)

animate(plotcommand, plotarguments, t=L, ...)

• plotcommand - Maple procedure that generates a 2-D or 3-D plot

• plotarguments - arguments to the plot command

• t=a..b - name and range of the animation parameter

• t=L - name and list of real or complex constants

To access the command, use the short form name after invoking the
with(plots) command.

> 

Maple Syntax for Creating Animations: Interactive Plot Builder
Example

The following example shows the plotting command returned by the example
in Interactive Plot Builder  (page 223).

> 

Animate a 2-D plot

> 
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For more information on the animate command, refer to the ?plots[animate]
help page.

5.6  Playing Animations

Animation Context Bar

To run the animation, click the plot to display the Animate context bar.

Table 5.16: Animation Options

DescriptionIconName

View the previous
frame in the animation.

Previous
Frame

Stop the animation.Stop

Play the selected anim-
ation.

Play

View the next frame in
the animation.

Next Frame
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DescriptionIconName

Slider control for
viewing individual
frames of an animated
plot. The frame speed
in frames per second
(FPS) is displayed
when increasing or de-
creasing the animation
speed of a plot.

Current
Frame

• Forward - Play the
animation forward.

• Oscillate - Play the
animation forward
and backward.

• Backward - Play
the animation
backward.

Forward

Oscillate

Backward

• Single - Run the
animation in single
cycle mode. The
animation is dis-
played only once.

• Continuous - Run
the animation in
continuous mode.
The animation re-
peats until you stop
it.

Single

Continuous

Set the animation to
play at a faster or
slower speed.

Frames per
second

You can also run the animation using the context menu or the Plot menu.
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5.7  Customizing Animations
The display options that are available for static plots are also available for
Maple animations.

Interactive Plot Builder Animation Options

Using the Interactive Plot Builder, you can apply various plot options
within the Plot Options window. See the Interactive Plot Builder  (page 223)
example.

Context Menu Options

As with static plots, you can apply plot options to the animation by right-
clicking (for Macintosh, Control-clicking) the animation output.

> 

> 
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Table 5.17: Customizing Animations Using the Context Menu

DetailsStep

Right-click the plot region. Select Style, and then Point.Change the line style

Select Axes, and then None.Remove the axes

The animate Command Options

The animate command offers a few options that are not available for static
plots. Refer to the ?animate help page for information on these additional
options. By default, a two-dimensional animation consists of sixteen plots
(frames) and a three-dimensional animation consists of eight plots (frames).
To create a smoother animation, increase the number of frames using the
frames option.

Note: Computing more frames increases time and memory requirements.

> 

> 
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5.8  Exporting
You can export a generated graph or animation to an image in various file
formats, including DXF, EPS, GIF, JPEG/JPG, POV, Windows BMP, and
WMF. Exporting an animation to GIF produces an animated image file. The
exported images can be included in presentations, Web pages, Microsoft
Word, or other software.

To export an image:

1. Right-click the plot region (for Macintosh, Control-click).

2. Select Export and the file format.

Alternatively:

1. Click the plot.

2. From the Plot menu, select Export, and then the file format.

Maple has various plot drivers. By setting the plotdevice, a file can be
automatically created without returning the image to the document. For more
information, refer to the ?plotdevice help page.

5.9  Code for Color Plates
Generating impressive graphics in Maple can require only a few lines of
code, as shown by the examples in this chapter. However, other graphics
require many lines of code. Code for the color plates is available at the Maple
Application Center.

From the Help menu, select Manuals, Dictionary, and more, On the Web,
and then Application Center.

To access the color plate code:

1. Go to the Maple Application Center.

2. Search for Color Plates.

230   •   5  Plots and Animations



6  Creating Mathematical
Documents
Maple allows you to create powerful documents as business and education
tools, technical reports, presentations, assignments, and handouts.

You can:

• Place instructions and equations side by side

• Format text for reports or course material

• Insert hyperlinks to other Maple files, Web sites, or email addresses

• Insert images, tables, and symbols

• Generate two- and three-dimensional plots and animations

• Sketch in the document

• Copy, cut, and paste information

• Bookmark specific areas

• Easily update, revise, and distribute your documents

This User Manual was written using Maple.
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6.1  In This Chapter
TopicsSection

• Quick Character Formatting

• Quick Paragraph Formatting

• Copy and Paste

• Sections

• Displaying Hidden Formatting Attributes

• Indentation and the Tab Key

• Character and Paragraph Styles

• Document Blocks

• Typesetting

• Using Tables for Layout

• Formatting Lists: Bullets, Numbers, Indent

• Bookmarks

• Inserting Images

• Show or Hide Document Content

Document Formatting - Add various
formatting elements

• Adding Graphical Interface Components

• Editing Component Properties

• Removing Graphical Interface Components

• Example Component Properties

• Printing and Exporting with Embedded Compon-
ents

Embedded Components - Insert
buttons, sliders, and more in your
document

• Creating a Question

• Viewing Questions in Maple

• Saving Test Content

Creating Graded Assignments -
Create documents for automated
testing and assessment
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TopicsSection

• Setting the Auto-Execute Feature

• Removing the Auto-Execute Setting

• Repeating Auto-Execution

• Security Levels

Auto-execute - Execute selected re-
gions of your document

• Insert a Canvas

• Drawing

• Canvas Style

• Erase or Clear Content

• Selection Tool

Canvas- Sketch an idea in the docu-
ment by inserting a canvas

• How to Use the Spellcheck Utility

• Selecting a Suggestion

• Spellcheck Usage and the Document

• User Dictionary

Spell Checking - Verify text with
the Maple spell checking utility

• Inserting a Hyperlink in the Document

• Linking to an Email Address, Dictionary Topic,
Help Page, Maplet Application, Web Page, or
Document

Hyperlinks - Add hyperlinks to
various sources

• Compatibility IssuesWorksheet Compatibility - Classic
Worksheet interface does not sup-
port all Standard Worksheet inter-
face features

6.2  Document Formatting

Quick Character Formatting

The Format>Character menu provides access to the following quick
formatting features: Bold, Italic, Underline, Superscript, Subscript, font
Color, and Highlight Color.

6.2  Document Formatting   •   233



To modify text:

1. In the document, select the text to modify.

2. From the Format menu, select Character, and then the appropriate feature.

Alternatively, use the context bar icons.

• Font Color Context Bar Icon 

• Highlight Color Context Icon 

For font and highlight colors, you can select from Swatches, HSB, or RGB
values. See Figure 6.1.

Figure 6.1: Select Color Dialog
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Attributes Submenu: Setting Fonts, Character Size, and Attributes

You can change various character attributes such as font, character size,
style, and color in one dialog.

To modify text:

1. In the document, select text to modify.

2. From the Format menu, select Character, and then Attributes. The
Character Style dialog opens. See Figure 6.2.

Figure 6.2: Character Style Dialog

Quick Paragraph Formatting

The Format>Paragraph menu provides access to the following quick
alignment features: Align Left, Center, Align Right, and Justify.

To modify a paragraph:

1. In the document, select the paragraph to modify.

2. From the Format menu, select Paragraph, and then the appropriate fea-
ture.
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Attributes Submenu: Spacing, Indent, Alignment, Bullets, Line
Break, and Page Break

You can change various paragraph attributes in one dialog.

• From the Format menu, select Paragraph, and then Attributes. The
Paragraph Style dialog opens. See Figure 6.3.

• When changing spacing, you must indicate units (inches, centimeters,
or points) in the Units drop-down list.

Figure 6.3: Paragraph Style Dialog

Copy and Paste

You can cut, copy, and paste content in Maple documents.

To copy an expression, or part of an expression, to another location on
the document:

1. Select the expression, or part of the expression, to copy.
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2. From the Edit menu, select Copy.

3. Place the cursor at the insertion point.

4. From the Edit menu, select Paste.

If you paste into an input region, Maple interprets all the pasted content as
input. If you paste into a text region, Maple interprets all the pasted content
as text. Note, however, that 2-D Math retains its format in both input and
text regions.

When you copy and paste to another application, in general, Maple retains
the original structure.

Sections

You can organize your document into sections.

Using the Insert Menu to Add Sections

1. Place the cursor in the paragraph or execution group above the location
at which to insert a new section.

• If the cursor is inside a section, Maple inserts the new section after the
current section.

• If the cursor is in an execution group, Maple inserts the new section after
the execution group.

2. From the Insert menu, select Section. An arrow marks the start of the
section.
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3. Enter the section heading.

4. Press the Enter key.

5. Enter the body of the section.

Using the Indent and Outdent Toolbar Icons

You can shift sections to create or remove subsections.

Enclose the selection in a subsection

Outdent the selection

Display Hidden Formatting Attributes

You can display icons that indicate the presence of hidden formatting attrib-
utes in the document, such as document block boundaries, execution groups
marked for autoexecute, and bookmarks.

To activate the marker feature:

• From the View menu, select Markers. A vertical bar is displayed along
the left pane of the document. Icons for hidden elements are displayed
in the vertical bar next to the associated content in the document.

Indentation and the Tab Key

The Tab icon allows you to set the Tab key to move between placeholders
or to indent.

Tab icon off. Allows you to move between placeholders using the Tab key.
As an illustration, click the exponent button in the Expression palette. The
expression is inserted with the first placeholder highlighted. To move to
the next placeholder, use the Tab key.
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The Tab icon is disabled when using 2-D Math (Math mode), and as such,
the Tab key allows you to move between placeholders.

Tab icon on. Allows you to indent in the document using the Tab key.

Character and Paragraph Styles

Maple has predefined styles for characters and paragraphs. A style is a set
of formatting characteristics that you can apply to text in your document to
change the appearance of that text. When you apply a style, you apply a
group of formats in one simple action.

• A paragraph style controls all aspects of a paragraph's appearance, such
as text alignment, line spacing, and indentation. In Maple, each paragraph
style includes a character style.

• A character style controls text font, size, and color, and attributes, such
as bold and italic. To override the character style within a paragraph
style, you must apply a character style or character formatting.

Figure 6.4: Style Management Dialog

Applying Character Styles

By using the drop-down list in the document context bar, you can apply:

• Existing Maple character styles.
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• New styles that you have created through the Style Management (Figure
6.4) and Character Style (Figure 6.5) dialogs.

To apply a character style to text in your document:

1. Select the text to modify.

2. In the styles drop-down list in the context bar of your document, select
an appropriate character style. All character styles are preceded by the letter
C. The selected text now reflects the attributes of the character style you
have chosen.

3. (Optional) If necessary, you can remove this style. From the Edit menu,
select Undo.

Creating Character Styles

You can create custom character styles to apply to text. New styles are listed
in the styles drop-down list in the context bar of your document.

1. From the Format menu, select Styles. The Style Management dialog
opens. See Figure 6.4.

2. Click Create Character Style. The Character Style dialog opens. See
Figure 6.5.

3. In the Style group box, enter a style name in the blank text field.

4. Select the properties for the new character style, such as Font, Size, At-
tributes, and Color. In the Attributes group box, the Superscript and
Subscript check boxes are mutually exclusive. When you select one of the
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two check boxes, the other is disabled. You must clear one before selecting
the other.

Note: A preview of the style is displayed in the Example group box at the
bottom of the Character Style dialog.

5. To create the style, click OK or to abandon creation, click Cancel.

Figure 6.5: Character Style Dialog

Modifying Character Styles

To modify character styles:

1. From the Format menu, select Styles. The Style Management dialog
opens. See Figure 6.4.

2. From the style list, select the style to modify.

3. Click Modify. The Character Style dialog opens with the current attributes
displayed. See Figure 6.5.
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4. Select the properties to modify, such as Font, Size, Attributes, and Color.
In the Attributes group box, the Superscript and Subscript check boxes
are mutually exclusive. When you select one of the two check boxes, the
other is disabled. You must clear one before selecting the other.

A preview of the style is displayed in the Example group box at the bottom
of the Character Style dialog.

5. To accept changes, click OK or to cancel changes, click Cancel.

Applying Paragraph Styles

By using the drop-down list in the document context bar, you can apply:

• Existing Maple paragraph styles.

• New styles that you have created through the Style Management (Figure
6.4) and Paragraph Style (Figure 6.6) dialogs.

To apply a Maple paragraph style to text in your document:

1. Select the text to modify.

2. In the styles drop-down list in the context bar of your document, select
an appropriate paragraph style. All Maple paragraph styles are preceded by
the letter P. The selected text now reflects the attributes of the paragraph
style you have chosen.

3. (Optional) If necessary, you can remove this style. From the Edit menu,
select Undo.
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Creating Paragraph Styles

You can create custom paragraph styles to apply to text. New styles are listed
in the styles drop-down list in the context bar of your document.

1. From the Format menu, select Styles. The Style Management dialog
opens. See Figure 6.4.

2. Click Create Paragraph Style. The Paragraph Style dialog opens. See
Figure 6.6.

3. In the Style group box, enter the new paragraph style name in the blank
text field.

4. In the Units drop-down list, select the units used to determine spacing
and indentation. Select from inches (in), centimeters (cm), or points (pt).

5. Select the properties to use for this paragraph style, such as Spacing, In-
dent, Justification, Bullet Style, Linebreak, and Page Break Before.

6. To add a font style, click Font. The Character Style dialog opens. For
detailed instructions, see Creating Character Styles (page 240).

7. To create the style, click OK, or to abandon creation, click Cancel.
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Figure 6.6: Paragraph Style Dialog

Modifying Paragraph Styles

To modify a paragraph style:

1. From the Format menu, select Styles. The Style Management dialog
opens. See Figure 6.4.

2. Select a paragraph style to modify, and click Modify. The Paragraph
Style dialog opens with the current attributes displayed.

3. Select the properties you want to modify, such as Spacing, Indent, Justi-
fication, and Bullet, Linebreak, and Units.

4. To modify the existing font style, click Font.

5. To accept changes, click OK, or to cancel changes, click Cancel.
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Style Set Management: Saving Styles for Future Use

You can use the style set of a particular document as the default style for all
documents.

Figure 6.7: Style Set Management Dialog

Creating and Applying Style Sets

• Task 1 - Create Styles

• Task 2 - Create a New Style Set

• Task 3 - Apply a (New) Style Set

TASK 1 - Create Styles:

• Create paragraph or character styles for the current document.

TASK 2 - Create a New Style Set:

1. From the Format menu, select Manage Style Sets. The Style Set Man-
agement dialog opens. See Figure 6.7.

2. In the Style Set Operations group box, click New Style Set. The Choose
Styles dialog opens. See Figure 6.8.
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Figure 6.8: Choose Styles Dialog

3. Select all the styles that are part of your document style set. For example,
if you modified the Author paragraph style to justify left versus the default
style of centered, ensure that you have selected the Author check box in the
Choose Styles dialog.

4. Click OK. The Choose Filename dialog opens.

5. Save your style set. The style is now available for future use in other
documents.

TASK 3 - Apply a (New) Style Set:

1. From the Format menu, select Manage Style Sets. The Style Set Man-
agement dialog opens. See Figure 6.7.

2. In the Style Set Operations group box, click Apply Style Set. The Choose
Filename dialog opens.

3. Select the style file and click Open. The Choose Styles dialog opens. At
this point, you can overwrite all the styles in your current document with the
new style set or apply only a few.

4. Click OK. The style set is applied to your document.

Reverting to a Style Set

At any point, you can revert your document style set to the Default Maple
Style Set or to a User-defined Style Set.
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To revert to a style set:

1. From the Format menu, select Manage Style Sets. The Style Set Man-
agement dialog opens.

2. In the Current Style Set group box, select the Default Maple Style Set
or User-defined Style Set. For user-defined style sets, navigate (click
Browse) to the file (Choose Filename dialog) and open the file (click Open).

3. In the Style Set Operations group box, click Revert to StyleSet.

4. In the Choose Styles dialog, select all the styles to revert, that is, overwrite
with either the Default Maple Style Set or the User-defined Style Set.

5. Click OK.

Document Blocks

With document blocks, you can create documents that present text and math
in formats similar to those found in business and education documents.

In a document block an input prompt or execution group is not displayed.

By hiding Maple input such that only text and results are visible, you create
a document with better presentation flow. Before using document blocks, it
is recommended that you display Markers. A vertical bar is displayed along
the left pane of the document. Icons representing document blocks are dis-
played in this vertical bar next to associated content.

To activate Markers:

• From the View menu, select Markers.
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Applying Document Blocks: General Process

Important: The following instructions are for Worksheet mode.

To apply a document block to selected content:

1. Enter input at the Maple command prompt, creating input that can be
referenced elsewhere in the document. See the ?EquationLabels help page.

2. Execute the area, creating output that can be referenced elsewhere in the
document.

3. Intersperse the area with content that is to remain visible, adding references
to the input and output in the appropriate locations.

4. Select the entire area (text and math content) to format.

5. From the Format menu, select Create Document Block.

6. Select the entire area. From the View menu, select Inline Document
Output.
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The block displays text and output only. You can select areas to display input
only.

7. Select the output region you want to display as input. From the View
menu, select Toggle Input/Output Display. The selected region displays
input.

Working in Document Mode

You can work work directly in Document mode, entering text and expres-
sions, and then evaluating expressions.

To start a document in Document mode:

1. From the File menu, select New, and then Document Mode. A document
opens with the Document mode markers indicated in the left margin. Note
that margin markers are visible if you select View>Markers.

2. Enter text and an expression to evaluate.

3. Select the expression and right-click (Control-click, for Macintosh) to
display the context menu.

4. Click the Evaluate and Display Inline menu item. The expression is
evaluated.

Note: Each time you press Enter, a new document block appears. Documents
consist of a series of document blocks.

In the following figures, note how the expression is entered as part of the
text and then evaluated with the context menu option Evaluate and Display
Inline.
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Before

After

Figure 6.9: Working in Document Mode

View Document Code

To view the contents, that is, all code and expanded execution groups within
a document block, you must expand the document block.

1. Place the cursor in the document block region.

2. From the View menu, select Expand Document Block.

3. To hide code again, select View>Collapse Document Block.

Expand an Execution Group within a Document Block

An execution group is a grouping of Maple input with its corresponding
Maple output. It is distinguished by a large square bracket at the left called
a group boundary.
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As document blocks can contain many execution groups, you can select to
expand an execution group within a document block.

1. Place the cursor in the document block region.

2. From the View menu, select Expand Execution Group.

3. To hide the group, select View>Collapse Execution Group.

Switch between Input and Output

1. Place the cursor in the document block region.

2. From the View menu, select Toggle Input-Output Display.

Input is displayed in one instance, or only output is displayed.

Inline Document

Document blocks can display content inline, that is, text, input, and output
in one line as presented in business and education documents.

To display content inline:

1. Place the cursor in the document block.

2. From the View menu, select Inline Document Output.
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Typesetting

You can control typesetting and 2-D Math equation parsing options in the
Standard Worksheet interface. Extended typesetting uses a customizable set
of rules for displaying expressions.

The rule-based typesetting functionality is available when Typesettinglevel
is set to Extended (Tools>Options>Display tab). This parsing functionality
applies to 2-D Math editing (Math mode) only.

To specify rules, use the Typesetting Rule Assistant.

• From the View menu, select Typesetting Rules. The Typesetting Rule
Assistant dialog opens.

For more information, see the ?Typesetting, ?TypesettingRuleAssist, and
?OptionsDialog help pages.

Using Tables for Layout

Tables allow you to organize content in a document.

Creating a Table

To create a table:

1. From the Insert menu, select Table.

2. Specify the number of rows and columns in the table creation dialog.

3. Click OK.

The default properties for the table include visible borders and auto-adjust-
ment to 100% of the document width. These options, as well as the table
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dimensions, can be modified after table creation. The following is an example
table using the default settings.

Cell Contents

Any content that can be placed into a document can also be placed into a
table cell, including other sections and tables. Table cells can contain a mix
of:

• Input commands

• 2-D Math

• Embedded components - buttons, sliders, check boxes, and more

• Plots

• Images

Navigating Table Cells

Use the Tab key to move to the next cell.

Tab icon off. Allows you to move between cells using the Tab key.

Tab icon on. Allows you to indent in the table using the Tab key.

Modifying the Structural Layout of a Table

The number of rows and columns in a table are modified using the Insert
and Delete submenus in the Table menu or by using the Cut and Paste tools.

Inserting Rows and Columns

Row and column insertion is relative to the table cell that currently contains
the cursor. If the document has an active selection, insertion is relative to
the selection boundaries.
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• Column insertion can be to the left or right of the document position
marker or selection.

• Row insertion can be above or below the marker or selection.

Deleting Rows and Columns

With deleting operations using the Delete key, the Delete Table Contents
dialog opens allowing you to specify the desired behavior. For example, you
can delete the selected rows, or delete the contents of the selected cells.

Pasting

Pasting a table subselection into a table may result in the creation of additional
rows or columns, overwriting existing cell content, or the insertion of a
subtable within the active table cell.

Merging

You can merge cells across row or column borders. See Figure 6.10. The
resultant cell must be rectangular. The contents of the individual cells in the
merge operation are concatenated in execution order. See Figure 6.11.

Figure 6.11: Merged CellsFigure 6.10: Two cells

Modifying the Physical Dimensions of a Table

The overall width of the table can be controlled in several ways.

The most direct way is to press the left mouse button (press mouse button,
for Macintosh) while hovering over the left or right table boundary and
dragging the mouse left or right. Upon release of the mouse button, the table
boundary is updated. This approach can also be used to resize the relative
width of table columns.
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Alternatively, the size of the table can be controlled from the Table Proper-
ties dialog. Select Tables>Properties. Two sizing modes are supported.

(1) Fixed percentage of page width. Using this option, the table width ad-
justs whenever the width of the document changes. This option is useful for
ensuring that the entire content of the table fits in the screen or printed page.

(2) Scale with zoom factor. This option is used to preserve the size and
layout of the table regardless of the size of the document window or the
zoom factor. If the table exceeds the width of the document window, the
horizontal scroll bar can be used to view the rightmost columns. Note: Using
this option, tables may be incomplete when printed.

Modifying the Appearance of a Table

Table Borders

The style of exterior and interior borders is set using the Table Properties
dialog. Select Table>Properties.

• You can set all, none, or only some of the borders to be visible in a table.

• You can control the visibility of interior borders by using the Group
submenu of the Table menu.

• Grouping rows or columns suppresses interior borders within the table
selection.

• Grouping rows and columns requires that the interior border style is set
by row and column group.

• Hidden borders are visible when the mouse hovers over a table. Note
that you can hide the visibility of lines on mouse pointer roll over by
using the View>Show/Hide Contents dialog, and clearing the Hidden
Table Borders check box.

Alignment Options

The table alignment tools control the horizontal alignment of columns and
vertical alignment of rows.
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For column alignment, the current selection is expanded to encompass all
rows in the selected columns. The alignment choice applies to all cells
within the expanded selection. If the document does not contain a selection,
the cursor position is used to identify the column.

Similarly, the selection is expanded to include all columns in the selected
rows for vertical alignment options. The following table illustrates the ver-
tical alignment options. The baseline option is useful for aligning equations
across multiple cells within a row of a table.

Controlling the Visibility of Cell Content

The Table Properties dialog includes two options to control the visibility
of cell content. These options allow control over the visibility of Maple input
and execution group boundaries. Thus, Maple input can be hidden in a table
even if input is set to visible for the document in the View>Show/Hide
Contents dialog.
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Printing Options

The Table Properties dialog contains options to control the placement of
page breaks when printing. You can fit a table on a single page, allow page
breaks between rows, or allow page breaks within a row.

Execution Order Dependency

The order in which cells are executed is set in the Table Properties dialog.
The following tables illustrate the effect of execution order.

Row-wise execution order

> x:=x+1;

> 

> x:=1;

> 

> x:=x+1;

> 

> x:=x+1;

> 

Column-wise execution order

> x:=x+1;

> 

> x:=1;

> 

> x:=x+1;

> 

> x:=x+1;

> 
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Tables and the Classic Worksheet

Tables are flattened on export to the Classic Worksheet interface. For ex-
ample, the following table in the Standard Worksheet appears as one column
in the Classic Worksheet interface.

Table in Classic WorksheetTable in Standard Worksheet

Examples

Table of Values

This example illustrates how to set the visibility options for cell contents to
display a table of values.

y := t -> 1/2*t^2:>

6543210t [s]

> y(6);> y(5);> y(4);> y(3);> y(2);> y(1);> y(0);y(t) [m]

Table settings:

In the Properties dialog (Table>Properties menu):

1. Set Table Size Mode to Scale with zoom factor.

2. Hide Maple input and execution group boundaries: Clear the Show input
and Show execution group boundaries check boxes.
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6543210t [s]

y(t) [m]

Formatting Table Headers

The following table uses cell merging for formatting row and column headers,
and row and column grouping to control the visibility of cell boundaries.

By default, invisible cell boundaries are visible on mouse pointer roll over.
You can hide the visibility of lines on mouse pointer roll over by using the
View>Show/Hide Contents dialog, and clearing the Hidden Table Borders
check box.

Parameter 2

HighLow

2413LowParameter 1

2918High

Table settings:

1. Insert a table with 4 rows and 4 columns.

Using the Table menu:

2. Merge the following sets of (Row,Column) cells: (R1,C1) to (R2,C2),
(R1,C3) to (R1,C4), and (R3,C1) to (R4,C1).

3. Group columns 1 and 2, and columns 3 and 4.

4. Group rows 1 and 2, and rows 3 and 4.

In the Properties dialog (Table>Properties menu):

5. Set Exterior Borders to None.
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6. (Optional) Change Table Size Mode size option to Scale with zoom
factor.

Using the Table menu:

7. Set Alignment of columns 3 and 4 to Center.

2-D Math and Plots

The following example illustrates the use of tables to display 2-D Math and
plots side by side.

Table Settings:

In the Properties dialog (Table>Properties menu):

1. Set Exterior and Interior Borders to None.

2. Hide Maple input and execution group boundaries: Clear the Show input
and Show execution group boundaries check boxes.

Using the Table menu:
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3. Change row Alignment to Center.

Table of Mathematical Expressions

This example illustrates using the baseline alignment option to align equations
across columns in a table.

f(x)

Table Settings:

In the Properties dialog (Table>Properties menu):

1. Set Exterior Border to Top and Bottom.

Using the Table menu:

2. Group columns 1 and 2.

3. Group rows 2 to 4.

4. Set row Alignment to Baseline for all rows.
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Formatting Lists: Bullets, Numbers, and Indent

Bullet, numbered, and indented lists provide an easy way to organize inform-
ation in your document.

Formatting Lists Using the Context Bar

To arrange content in a bullet list using the context bar drop-down list:

1. Select the text to be arranged.

2. In the character and paragraph style drop-down list, select P Bullet Item.
The selected text is displayed as a (dot) bullet list.

To arrange content in a numbered list using the context bar drop-down
list:

1. Select the text to be arranged.

2. In the character and paragraph style drop-down list, select P Ordered
List 1. The selected text is displayed as a numbered list.

Ordered lists have 5 default styles. See Figure 6.12. List 1 begins at the left
margin. By default, subsequent lists are indented half an inch. To change
the default, see Modifying Paragraph Styles (page 244). The numbering style
uses numbers, lowercase letters, lowercase roman numerals, uppercase letters,
uppercase Roman numerals.
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Figure 6.12: Ordered List Styles

To arrange content in an indented list using the context bar drop-down
list:

1. Select the text to be arranged.

2. In the character and paragraph style drop-down list, select P List Item.
The selected text is displayed as an indented list.

Formatting Lists Using the Paragraph Style Dialog

With the Paragraph Style dialog, you can select various list styles: dot,
dash, indent, numbers, lowercase letters, uppercase letters, lowercase Roman
numerals, and uppercase Roman numerals.

To arrange content in a list using the Paragraph Style dialog:

1. Select the text to be arranged.

2. From the Format menu, select Paragraph, and then Attributes. The
Paragraph Style dialog opens.

3. In the Bullet and Numbering drop-down list, select one of the styles.

4. If you have selected one of the numbered styles (number, letters, Roman
numerals), set an initial list value.
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5. To continue numbering this list from a previous list in your document,
select the Linked to Previous List check box.

6. Click OK to accept this style.

Bookmarks

Use a bookmark to designate a location in an active document. This bookmark
can then be accessed from other regions in your document or by using hyper-
links in other documents.

To display bookmark formatting icons, activate the Marker feature.

• From the View menu, select Markers.

Inserting, Renaming, and Deleting a Bookmark

To insert a bookmark:

1. Place the cursor at the location at which to place the bookmark.

2. From the Format menu, select Bookmarks. The Bookmark dialog opens,
listing existing bookmarks in the document.

3. Click New. The Create Bookmark dialog opens. Enter a bookmark name
and click Create.

4. The new bookmark appears in the Bookmark dialog list. Click OK.

Note: You can also rename and delete bookmarks using the Bookmark
dialog.
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Go to a Bookmark

You can automatically move the cursor to the location of the bookmark in
the active document.

1. From the Edit menu, select Go To Bookmark. The Go To Bookmark
dialog opens with the current bookmarks listed.

2. Select the bookmark and click OK. The cursor moves to the bookmark.

Inserting Images

Images help illustrate ideas and enhance presentations. You can insert images
in your document at a cursor location or in a table.

You can insert images in these file formats
into your document.

• Graphics Interchange Format - gif

• Joint Photographic Experts Group -
jpe, jpeg, jpg

• Portable Network Graphics - png

• Bitmap Graphics - bmp

• Tagged Image File Format - tif, tiff,
jfx

• Portable aNyMap - pnm

• Kodak FlashPix - fpx

To insert an image into the document at the cursor location:

1. From the Insert menu, select Image. The Load Image dialog opens.

2. Specify a path or folder name.

3. Select a filename.

4. Click Open. The image is displayed in the document.
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If the source file is altered, the embedded image does not change because
the original object is pasted into the document.

To resize an inserted image:

1. Click the image. Resizing anchors appear at the sides and corners of the
image.

2. Move the mouse over the resize anchor. Resizing arrows appear.

3. Click and drag the image to the desired size.

ImageTools Package

You can manipulate image data using the ImageTools package. This package
is a collection of utilities for reading and writing common image file formats,
and for performing basic image processing operations within Maple.

Within Maple, images are represented as dense, rectangular Arrays of 64-
bit hardware floating-point numbers. Grayscale images are 2-D, whereas
color images are 3-D (the third dimension representing the color channels).

In addition to the commands in the ImageTools package, many ordinary
Array and Matrix operations are useful for image processing.

For details about this feature, refer to the ?ImageTools help page.

Show or Hide Worksheet Content

You can hide document elements of a specific type so that they are not visible.
This does not delete them, but hides them from view. Hidden elements are
not printed or exported, but they are copied and pasted.

In a document, use the Show Contents dialog to hide all spreadsheets, input,
output, or graphics, plus section boundaries, execution group boundaries,
and hidden table borders on mouse pointer roll over. The dialog is accessed
from the View>Show/Hide Contents menu.
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Using the Show Contents Dialog

A check mark beside the item indicates that all document elements of that
type are displayed for the current document.

1. From the View menu, select Show/Hide Contents. The Show Contents
dialog opens with all items selected for display.

2. Clear the check box associated with the document components or ranges
to hide.

By clearing the Input check box, only Maple Input and 2-D Math input, that
is, 2-D Math content that has been evaluated, are hidden. Clearing the
Graphics check box ensures that a plot, an image, or the Canvas inserted
in the document by using the Insert menu option is also hidden.

Command Output Versus Insertion

Output is considered an element that results from executing a command.
Inserted components are not considered output.

Consider the following examples.

The plot resulting from executing the plot(sin) call is considered output.

• To show a plot from the plot(sin) call, select both the Output and
Graphics check boxes in the Show Contents dialog.

If you insert a plot by using the Insert menu option, that plot is not considered
output. Therefore, if you clear the Output check box in the Show Contents
dialog, that plot will be visible in the document.

• To hide an inserted plot, clear the Graphics check box in the Show
Contents dialog.

Inserted images and the Canvas are not considered output. As such, they
are not hidden if you clear the Output check box.

• To hide an inserted image or canvas, clear the Graphics check box in
the Show Contents dialog.

6.2  Document Formatting   •   267



6.3  Embedded Components
You can embed simple graphical interface components, for example, a button,
in your document. These components can then be associated with actions
that are to be executed. For example, the value of a slider component can be
assigned to a document variable, or a text field can be part of an input
equation.

Adding Graphical Interface Components

The graphical interface components can be inserted by using the Components
palette (Figure 6.13) or by cutting/copying and pasting existing components
to another area of the document. Although copied components have the same
characteristics, they are distinct.

By default, palettes are displayed when you launch Maple. If palettes are
not visible, use the following procedure.

To view palettes:

1. From the View menu, select Palettes.

2. Select Expand Docks.

3. If the Components palette is not displayed, right-click (Control-click,
for Macintosh) the palette dock. From the context menu, select Show Palette,
and then Components.

You can embed the following items.

• Button, Toggle Button

• Combo Box, Check Box, List Box

• Text Area, Label

• Slider, Plot, Function
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Figure 6.13: Components Palette

Editing Component Properties: General Process

To edit properties of components embedded in the document:

1. Right-click (Control-click, for Macintosh) the component to display the
context menu.

2. Select Component Properties. The related dialog opens.

3. Enter values and contents in the fields as necessary.

4. For actions, such as Action When Value Changes in the Slider component
dialog, click Edit. A blank dialog opens allowing you to enter Maple code
that is executed when the event occurs. For details, refer to the ?Document-
Tools  help page.

Removing Graphical Interface Components

You can remove an embedded component by:

• Using the Delete key

• Using the Backspace key

• Placing the cursor at the component and selecting from the document
menu, Edit>Delete Element
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Example Component Properties

The following example inserts a slider, and a label that indicates the current
value of the slider.

1. Place the cursor in the location where the embedded component is to be
inserted.

2. In the Components palette, click the Slider item. A slider is inserted into
the document.

3. In the Components palette, click the Label item. A label is inserted next
to the slider.

4. Right-click (Control-click, for Macintosh) the label component. Select
Component Properties. The Label Properties dialog appears.

5. Name the component SliderLabel and click Ok.

6. Right-click (Control-click, for Macintosh) the slider component. Select
Component Properties. The Slider Properties dialog opens.

7. Name the component Slider1.

8. Enter the lowest position as 0 and the highest as 100.

9. Enter minor tick marks at 10 and major tick marks at 20.

10. To define an action when the value of the slider changes, click Edit. The
Action When Value Changes dialog opens.

11. Enter the following calling sequence and click OK to close all dialogs.

DocumentTools[SetProperty ]('SliderLabel',caption,

DocumentTools[GetProperty] ('Slider1', 'value' ) );

The value from the slider as you move the arrow indicator populates the
Label caption field.
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For details on these commands, refer to the ?DocumentTools/SetProperty
and the ?DocumentTools/GetProperty help pages.

Printing and Exporting a Document with Embed-
ded Components

Printing: When printing a document, embedded components are rendered
as they appear on screen.

Exporting: Exporting a document with embedded components to other
formats produces the following results.

• HTML format - components are exported as .gif files.

• RTF format - components are rendered as bitmap images in the .rtf
document.

• LaTeX - components are exported as .eps files.

6.4  Creating Graded Assignments
You can use Maple to create graded assignments. Question types include
multiple choice, essay, true-or-false, fill-in-the-blanks, and Maple-graded.

Note: This feature can be used to create questions for Maple T.A.—an online
automated testing and assessment system. For details about Maple T.A., see
Input, Output, and Interacting with Other Products (page 363).

Creating a Question

To create a question:

1. Open the Task browser (Tools>Tasks>Browser).

2. From the Maple T.A. folder, select the appropriate question type.

3. Insert the question template into a document.

4. Enter the question content as described in the template.

5. Repeat steps 1 to 4 for each question to add to the document.

6.4  Creating Graded Assignments   •   271



Viewing Questions in Maple

To view and test your questions in Maple:

• From the View menu, select Assignment. This view displays all of the
questions in your assignment with access to hints, plotting, and grading.

After answering your questions, you can test the grading function by clicking
the Grade button. A Maplet dialog is displayed indicating if the question
was answered correctly. If hints were provided in the question, these are also
displayed.

Saving Test Content

When you save a document with test content, the authoring and assignment
modes determine what the user sees when opening your document.

• If you save the document in authoring mode (task template contents
visible), the user sees this content when opening the document.

• If you save the document in assignment mode, the users sees only the
assignment layout.

In both cases the View>Assignment menu is accessible. As such, users
(students) can switch between the original document contents and the dis-
played assignment.

6.5  Auto-Execute
An execution group is a grouping of Maple input with its corresponding
Maple output. It is distinguished by a large square bracket, called a group
boundary, at the left. An execution group may also contain any or all of the
following: a plot, a spreadsheet, and text.

Execution groups are the fundamental computation and documentation ele-
ments in the document. If you place the cursor in an input command and
press the Enter or Return key, Maple executes all of the input commands
in the current execution group.
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The Autoexecute feature allows you to designate regions of a document for
automatic execution. These regions are executed when the document opens.
This is useful when sharing documents. Important commands can be executed
as soon as the user opens your document. The user is not required to execute
all commands.

Setting the Auto-Execute Feature

1. Select the region that must be automatically executed when the document
opens.

2. From the Format menu, select Autoexecute, and then Set.

Removing the Auto-Execute Setting

To remove the setting in a region:

1. Select the region.

2. From the Format menu, select Autoexecute, and then Clear.

To remove all autoexecution in a document:

• From the Format menu, select Autoexecute, and then Clear All.

Repeating Auto-Execution

To execute all marked groups:

• From the Edit menu, select Execute, and then Repeat Autoexecution.

Security Levels
By default, Maple prompts the user before automatically executing the doc-
ument.

To set security levels for the autoexecute feature, use the Security tab in the
Options dialog. For details, refer to the ?OptionsDialog help page.
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6.6  Canvas
Maple allows you to sketch an idea in a canvas, draw on plots, or even draw
on images. See Figure 6.14. For details about the drawing feature, see the
Maple help system.

Figure 6.14: Canvas and Drawing Properties Palette

Insert a Canvas

To insert a canvas:

1. Place the cursor where the canvas is to be inserted.

2. From the Insert menu, select Canvas. A canvas with grid lines appears
in the document at the insertion point. The Drawing menu is available and
associated context bar icons are displayed.
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The tools include the following: selection tool, Pencil (free style drawing),
eraser, text insert, straight line, square, rounded square, ellipse, diamond,
alignment, launch drawing and canvas properties palettes.

Drawing

For details about the drawing feature, see the Maple help system.

To draw with the pencil tool in the canvas:

1. From the Drawing icons, select the pencil icon.

2. (Optional) Select a line thickness in the Drawing Properties palette.

3. Click and drag your mouse in the canvas to draw lines. Release the mouse
to complete the drawing.

To adjust the color of drawing tools:

1. Open the Drawing Properties palette.

2. Click the color wheel. By default, the wheel is black. Move the slider to
view more colors.

3. Select a color on the color wheel. The color is displayed in the rectangle.

Canvas Style

You can alter the Canvas in the following ways:

• Add a grid of horizontal and/or vertical lines. By default, the canvas
opens with a grid of horizontal and vertical lines.

• Change the background color.

• Change the grid line color.

• Change the spacing between grid lines.

To alter the canvas style:

1. Expand the Canvas Properties palette.
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2. For grid lines, select the appropriate grid check boxes (horizontal or ver-
tical) and adjust spacing as required using the slider.

3. For colors, click the Grid or Canvas color. The color wheel opens. Select
from various colors.

To remove gridlines:

• Clear the Show horizontal grid or Show vertical grid check boxes, and
click OK.

6.7  Spell Checking
The Spellcheck utility examines all designated text regions of your document
for potential spelling mistakes, including regions that are in collapsed sec-
tions. It does not check input, output, text in execution groups, or math in
text regions. See Figure 6.15.

Note: The Spellcheck utility uses American spelling.

Figure 6.15: Spellcheck Dialog
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How to Use the Spellcheck Utility

1. From the Tools menu, select Spellcheck. Alternatively, press the F7. The
Spellcheck dialog appears. It automatically begins checking the document
for potential spelling mistakes.

2. If the Spellcheck utility finds a word that it does not recognize, that word
is displayed in the Not Found text box.

You have six choices:

• To ignore the word, click Ignore.

• To ignore all instances of the word, click Ignore All.

• To change the word, that is, accept one of the suggested spellings for the
word, to the one that is in the Change To text box, click Change.

• To change all instances of the word, that is, accept the suggested spelling
to replace all instances of the word, click Change All.

• To add the word to your dictionary, click Add. For details, see the fol-
lowing User Dictionary section.

• To close the Spellcheck dialog, that is, quit the Spellcheck utility, click
Cancel.

3. When the Spellcheck is complete, a dialog containing the message
"spellchecking complete" appears. Click OK to close this dialog.

Selecting a Suggestion

To select one of the suggestions as the correct spelling, click the appropriate
word from the list in the Suggestions text box.

If none of the suggestions are correct, highlight the word in the Change To
text box and enter the correct spelling. Click Change to accept this new
spelling.
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Spellcheck Usage and the Document

When using the Spellcheck utility, you can fix spelling errors in the
Spellcheck dialog. You cannot change the text in the document while the
Spellcheck utility is running.

The Spellcheck utility does not check grammar.

User Dictionary

You can create and maintain a custom dictionary that works with the Maple
Spellcheck utility.

Properties of the Custom Dictionary File

• It must be a text file, that is, have the file extension .txt. For example,
mydictionary.txt.

• It is a list of words, one word per line.

• It is case sensitive. This means that integer and Integer require individual
entries in the dictionary file.

• It does not require manual maintenance. You build your dictionary file
by using the Add functionality of the Spellcheck. However, you can
manually edit the file if an error is introduced.

To specify a custom dictionary to be used with the Maple Spellcheck
utility:

1. Create a .txt file using your favorite text editor in a directory/folder of
your choice.

2. In Maple, open the Options dialog, Tools>Options, and select the Gen-
eral tab.

3. In the User Dictionary field, enter the path and name of the .txt file you
created in step 1, or click Browse to select the location and filename.
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4. To ignore Maple words that are command and function names, select the
Use Maple Words in Spellchecker check box. A check mark indicates that
the Spellcheck ignores Maple words.

5. Click Apply to Session, Apply Globally, or Cancel.

Adding a Word to Your Dictionary

When running the spellcheck, if the word in the Not Found text box is cor-
rect, you can add the word to your dictionary.

1. Click the Add button. If this is the first time you are adding a word, the
Select User Dictionary dialog opens.

2. Enter or select the custom dictionary (.txt file) you created. See User
Dictionary (page 278).

3. Click Select. The word is automatically added to your custom dictionary
file.

Note: Specifications in the Options dialog determine whether this word is
recognized in your next Maple session. If you set your custom dictionary
use to Apply to Session, then this word will not be recognized in a new
Maple session. If you set your custom dictionary use to Apply Globally,
then this new word will be recognized. See User Dictionary (page 278).

6.8  Hyperlinks
Use a hyperlink in your document to access any of the following.

• Email

• Dictionary Topic

• Help Topic

• Maplet Application

• Web Page (URL)

• Document
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Figure 6.16: Hyperlink Properties Dialog

Inserting a Hyperlink in a Document

To insert a hyperlink in the document:

1. Highlight the text that you want to make a hyperlink.

2. From the Format menu, select Hyperlink.

3. In the Hyperlink Properties dialog box, enter the text of the hyperlink
name in the Link Text edit field. See Figure 6.16.

4. Optionally, use an image as the link. Select the Include an Image check
box and Browse for the correct file. In .mw files, the image appears as the
link, while in .mws files, the Link Text you entered appears as the link. You
can resize the image as necessary. Click the image. Resizing anchors appear
at the sides and corners of the image.

5. Specify the hyperlink Type and Target as described in the appropriate
following section.

Linking to an Email Address

To link to an email address:

1. In the Type drop-down list, select Email.
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2. In the Target field, enter the email address.

3. Click OK.

Note: For information about email hyperlinks in the Classic Worksheet in-
terface, see Worksheet Compatibility (page 283).

Linking to a Dictionary Topic

To link to a Dictionary topic:

1. In the Type drop-down list, select Dictionary Topic.

2. In the Target field, enter a topic name. Dictionary topics begin with the
prefix Definition/, for example, Definition/dimension.

3. Click OK.

Linking to a Help Page

To link to a help page:

1. In the Type drop-down list, select Help Topic.

2. In the Target field, enter the topic of the help page.

(Optional) In the Bookmark drop-down list, enter or select a bookmark.

3. Click OK.

Linking to a Maplet Application

To link to a Maplet application:

1. In the Type drop-down list, select Maplet.

2. In the Target field, enter the local path to a file with the .maplet extension.
Optionally, click Browse to locate the file.
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If the Maplet application exists, clicking the link launches the Maplet applic-
ation. If the Maplet application contains syntax errors, then error messages
are displayed in a pop-up window.

When linking to a custom Maplet application, the path is absolute. When
sharing documents that contain links to Maplet applications, ensure that
target Maplet applications are in the same directory.

3. Click OK.

Note: To link to a Maplet application available on a MapleNet Web page,
use the URL hyperlink type to link to the Web page. For information on
MapleNet, see Input, Output, and Interacting with Other Products (page 363).

Linking to a Web Page

To link to a Web page:

1. In the Type drop-down list, select URL.

2. In the Target field, enter the URL, for example, www.maplesoft.com.

3. Click OK.

Linking to a Document

To link to a document:

1. In the Type drop-down list, select Worksheet.

2. In the Target field, enter the path and filename of the document or click
Browse to locate the file. (Optional) In the Bookmark drop-down list, enter
or select a bookmark.

Note: When linking to a custom document, the path is absolute. When
sharing documents that contain hyperlinks, ensure that target documents are
in the same directory.

3. Click OK.
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6.9  Worksheet Compatibility
Maple provides users with two worksheet interfaces: the Standard Worksheet
and the Classic Worksheet. Both have access to the full mathematical engine
of Maple and take advantage of the new functionality in Maple. The Classic
Worksheet has the traditional Maple worksheet look and uses less memory.

If you create a document in the Standard Worksheet interface of Maple and
then open it in the Classic Worksheet interface, you should note possible
changes to your file. For example, a bulleted list in the Standard Worksheet
will not be displayed with bullets in the Classic Worksheet.

If you are creating documents for distribution, refer to the ?Compatibility
help page.
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7  Maple Expressions
This chapter provides basic information on using Maple expressions, includ-
ing an overview of the basic data structures. Many of the commands described
in this chapter are useful for programming. For information on additional
Maple programming concepts, such as looping, conditional execution, and
procedures, see Basic Programming (page 321).

7.1  In This Chapter
TopicsSection

• Expression Sequences

• Sets

• Lists

• Tables

• Arrays

• Matrices and Vectors

• Functional Operators

• Strings

Creating and Using Data Structures - How
to define and use basic data structures

• Low-Level Operations

• Manipulating Expressions

• Evaluating Expressions

Working with Maple Expressions - Tools
for manipulating and controlling the evalu-
ation of expressions

7.2  Creating and Using Data Struc-
tures
Constants, data structures, mathematical expressions, and other objects are
Maple expressions. For more information on expressions, refer to the Maple
Help System.
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This section describes the key data structures:

• Expression sequences

• Sets

• Lists

• Tables

• Arrays

• Matrices and Vectors

• Functional operators

• Strings

Expression Sequences

The fundamental Maple data structure is the expression sequence. It is a
group of expressions separated by commas.

> 

Accessing Elements

To access one of the expressions:

• Enter the sequence name followed by the position of the expression en-
closed in brackets([ ]).

For example:

> 

Using negative integers, you can select an expression from the end of a se-
quence.

286   •   7  Maple Expressions



> 

You can select multiple expressions by specifying a range using the range
operator (..).

> 

Note: This syntax is valid for most data structures.

Sets

A set is an expression sequence enclosed in curly braces ({ }).

> 

A Maple set has the basic properties of a mathematical set.

• Each element is unique. Repeated elements are stored only once.

• The order of elements is not stored.

For example:

> 

Using Sets

To perform mathematical set operations, use the set data structure.
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> 

Note: The union operator is available in 1-D Math input as union. For more
information, refer to the ?union help page.

For more information on sets, refer to the ?set help page.

Lists

A list is an expression sequence enclosed in brackets ([ ]).

> 

Note: Lists preserve both the order and repetition of elements.

Accessing Entries

To refer to an element in a list:

• Use square brackets.

For example:

> 

For more information, see Accessing Elements (page 286).

Using Lists

Some commands accept a list (or set) of expressions.

For example, you can solve a list (or set) of equations using a context menu
or the solve command.
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> 

For more information, see Solving Equations and Inequations (page 78).

For more information on sets and lists, refer to the ?set help page.

Arrays

Conceptually, the Array data structure is a generalized list. Each element
has an index that you can use to access it.

The two important differences are:

• The indices can be any integers.

• The dimension can be greater than one.

Creating and Using Arrays

To define an Array, use the Array constructor.

Standard Array constructor arguments are:

• Expression sequences of ranges - Specify the indices for each dimension

• Nested lists - Specify the contents

For example:

> 
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> 

> 

The Array constructor supports other syntaxes. It also supports many options.
For more information on the Array constructor and the Array data structure,
refer to the ?Array help page.

Large Arrays

Only one- and two-dimensional Arrays (with at most 10 indices in each di-
mension) display in the document. Larger Arrays display as a placeholder.

> 

To view large Arrays:

• Double-click the placeholder.

The Matrix Browser displays the Array. For more information, see Editing
and Viewing Large Matrices and Vectors (page 136).

Tables

Tables are conceptually an extension of the Array data structure, but the
table data structure is implemented using hash tables. Tables can be indexed
by any values, not only integers.
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Defining Tables and Accessing Entries

> 

> 

You can also assign anything, for example, a list, to each element.

> 

> 

For more information on tables, refer to the ?table help page.

Matrices and Vectors

Matrices and Vectors are specialized data structures used in linear algebra
and vector calculus computations.

> 

For information on defining Matrices and Vectors, see Creating Matrices
and Vectors (page 133).

> 
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> 

> 

For more information on these data structures, including how to access entries
and perform linear algebra computations, see Linear Algebra (page 133).

Functional Operators

A functional operator is a mapping . The value of  is the

result of evaluating .

Using functional operators, you can define mathematical functions.

Defining a Function

To define a function of one or two variables:

1. In the Expression palette, click one of the function definition items. See
Figure 7.1. Maple inserts the function definition.

2. Replace the placeholder f with the function name. Press Tab. Note: If

pressing the Tab key inserts a tab, click the Tab icon  in the toolbar.

3. Replace the parameter placeholders, x or x1, x2, with the independent
variable names. Press Tab.

4. Replace the final placeholder, y, with the expression that defines the
function value. Press Enter.
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Figure 7.1: Function Definition Palette Items

For example, define a function that adds 1 to its input.

> 

Note: To insert the right arrow, you can enter the characters ->. In 2-D Math,
Maple replaces -> with the right arrow symbol . In 1-D Math, the
characters are not replaced.

You can evaluate the function add1 with symbolic or numeric arguments.

> 

Distinction between Functional Operators and Other Expressions

The expression  is different from the functional operator .

Assign the functional operator  to f.

> 

Assign the expression  to g.

> 

To evaluate the functional operator f at a value of x:

• Specify the value as an argument to f.
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> 

To evaluate the expression g at a value of x:

• You must use the eval command.

> 

For more information on the eval command, and using palettes and context
menus to evaluate an expression at a point, see Substituting a Value for a
Subexpression (page 310).

Multivariate and Vector Functions

To define a multivariate or vector function:

• Enclose coordinates or coordinate functions in parentheses (( )).

For example, a multivariate function:

> 

> 

A vector function:

> 

294   •   7  Maple Expressions



> 

Using Operators

To perform an operation on a functional operator, specify arguments to the
operator. For example, for the operator f, specify f(x), which Maple evaluates
as an expression. See the following examples.

Plot an Operator as an Expression Plot a three-dimensional function using
the plot3d command.

> 

> 
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For information on plotting, see Plots and Animations (page 187).

Integration Integrate a function using the int command.

> 

> 

 represents the Struve function. For more information, refer to the

?StruveH help page.

For information on integration and other calculus operations, see Calcu-
lus (page 151).
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Strings

A string is a sequence of characters enclosed in double quotes (" ").

> 

Accessing Characters

You can access characters in a string using brackets.

> 

Using Strings

The StringTools package is an advanced set of tools for manipulating and
using strings.

> 

> 

> 

> 
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7.3  Working with Maple Expressions
This section describes how to manipulate expressions using context menus,
palette items, and the underlying commands.

To display the context menu for an expression:

• Right-click (Control-click, for Macintosh) the expression.

To view the palettes:

• From the View menu, select Palettes, and then Expand Docks.

Low-Level Operations

Expression Types

A Maple type is a broad class of expressions that share common properties.
Maple contains over 200 types, including:

• `+`

• boolean

• constant

• integer

• Matrix

• trig

• truefalse

For more information and a complete list of Maple types, refer to the ?type
help page.

The type commands return true if the expression satisfies the type check.
Otherwise, they return false.
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Testing the Type of an Expression

To test whether an expression is of a specified type:

• Use the type command.

> 

> 

For information on enclosing keywords in right single quotes ('), see
Delaying Evaluation (page 317).

Maple types are not mutually exclusive. An expression can be of more than
one type.

> 

> 

For information on converting an expression to a different type, see Convert-
ing (page 307).

Testing the Type of Subexpressions

To test whether an expression has a subexpression of a specified type:

• Use the hastype command.
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> 

Testing for a Subexpression

To test whether an expression contains an instance of a specified
subexpression:

• Use the has command.

> 

> 

> 

The has command searches the structure of the expression for an exactly
matching subexpression.

For example, the following calling sequence returns false.

> 

To return all subexpressions of a particular type, use the indets command.
For more information, see Indeterminates (page 303).
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Accessing Expression Components

Left and Right-Hand Side

The lhs and rhs commands return the left and right-hand side of an equation,
inequality, or range.

To extract the left-hand side of an expression:

• Use the lhs command.

To extract the right-hand side of an expression:

• Use the rhs command.

For example:

> 

(7.1)

> 

> 

For the following equation, the left endpoint of the range is the left-hand
side of the right-hand side of the equation.

> 

(7.2)
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> 

Numerator and Denominator

To extract the numerator of an expression:

• Use the numer command.

To extract the denominator of an expression:

• Use the denom command.

> 

If the expression is not in normal form, Maple normalizes the expression
before selecting the numerator or denominator. (For more information on
normal form, refer to the ?normal help page.)

> 

> 

> 

The expression can be any algebraic expression. For information on the be-
havior for non-rational expressions, refer to the ?numer help page.
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Components of an Expression

The components of an expression are called its operands.

To count the number of operands in an expression:

• Use the nops command.

For example, construct a list of solutions to an equation.

> 

Using the nops command, count the number of solutions.

> 

For more information on the nops command and operands, refer to the ?nops
help page.

Indeterminates

To find the indeterminates of an expression:

• Use the indets command.

The indets command returns the indeterminates as a set. Because the expres-
sion is expected to be rational, functions such as sin(x), f(x), and sqrt(x) are
considered to be indeterminate.

> 
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To return all subexpressions of a particular type, specify the type as the
second argument. For information on types, see Testing the Type of an Ex-
pression (page 299).

> 

To test whether an expressions has subexpressions of a specific type (without
returning them), use the has command. For more information, see Testing
for a Subexpression (page 300).

Manipulating Expressions

This section introduces the most commonly used manipulation commands.
For additional manipulation commands, see Iterative Commands (page 333).

Simplifying

To simplify an expression:

• Use the simplify command.

The simplify command applies simplification rules to an expression. Maple
has simplification rules for various types of expressions and forms, including
trigonometric functions, radicals, logarithmic functions, exponential functions,
powers, and various special functions. You can also specify custom simpli-
fication rules using a set of side relations.

> 
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> 

To limit the simplification, specify the type of simplification to be performed.

> 

> 

You can also use the simplify command with side relations. See Substituting
a Value for a Subexpression (page 310).

Factoring

To factor a polynomial:

• Use the factor command.

> 

> 

Maple can factor polynomials over the domain specified by the coefficients.
You can also factor polynomials over algebraic extensions. For details, refer
to the ?factor help page.
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For more information on polynomials, see Polynomial Algebra (page 124).

To factor an integer:

• Use the ifactor command.

> 

For more information on integers, see Integer Operations (page 71).

Expanding

To expand an expression:

• Use the expand command.

The expand command distributes products over sums and expands expres-
sions within functions.

> 

> 

Combining

To combine subexpressions in an expression:

• Use the combine command.
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The combine command applies transformations that combine terms in sums,
products, and powers into a single term.

> 

> 

The combine command applies only transformations that are valid for all
possible values of names in the expression.

> 

To perform the operation under assumptions on the names, use the assuming
command. For more information about assumptions, see Assumptions on
Variables (page 116).

> 

Converting

To convert an expression:

• Use the convert command.

The convert command converts expressions to a new form, type (see Expres-
sion Types (page 298)), or in terms of a function. For a complete list of con-
versions, refer to the ?convert help page.
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Convert a measurement in radians to degrees:

> 

To convert measurements that use units, use the Unit Converter or the con-
vert/units command.

> 

For information on the Unit Converter and using units, see Units (page 96).

Convert a list to a set:

> 

Maple has extensive support for converting mathematical expressions to a
new function or function class.

> 

Find an expression equivalent to the inverse hyperbolic cotangent function
in terms of Legendre functions.

> 

308   •   7  Maple Expressions



 represents the Legendre function of the second kind. For more inform-

ation, refer to the ?LegendreQ help page.

For more information on converting to a class of functions, refer to the
?convert/to_special_function help page.

Normalizing

To normalize an expression:

• Use the normal command.

The normal command converts expressions into factored normal form.

> 

You can also use the normal command for zero recognition.

> 

To expand the numerator and denominator, use the expanded option.

> 

> 
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Sorting

To sort the elements of an expression:

• Use the sort command.

The sort command orders a list of values or terms of a polynomial.

> 

> 

> 

For information on sorting polynomials, see Sorting Terms (page 126).

For more information on sorting, refer to the ?sort help page.

Evaluating Expressions

Substituting a Value for a Subexpression

To evaluate an expression at a point, you must substitute a value for a vari-
able.

To substitute a value for a variable:
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1. Right-click (Control-click, for Macintosh) the expression. Maple displays
a context menu.

2. From the context menu, select Evaluate at a Point. The Evaluate at a
Point dialog is displayed.

3. In the drop-down list, select the variable to substitute.

4. In the text field, enter the value to substitute for the variable. Click OK.

Maple inserts the eval command calling sequence that performs the substitu-
tion. This is the most common use of the eval command.

For example, substitute  in the following polynomial.

> 

> 

(7.3)

To substitute a value for a variable using palettes:

1. In the Expression palette, click the evaluation at a point item .

2. Specify the expression, variable, and value to be substituted.

For example:

> 
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Substitutions performed by the eval function are syntactical, not the more
powerful algebraic form of substitution.

If the left-hand side of the substitution is a name, Maple performs the substi-
tution.

> 

If the left-hand side of the substitution is not a name, Maple performs the
substitution only if the left-hand side of the substitution is an operand of the
expression.

> 

> 

Maple did not perform the evaluation because  is not an operand of

. For information on operands, refer to the ?op help page.

For algebraic substitution, use the algsubs command, or the simplify com-
mand with side relations.
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> 

> 

Numerical Approximation

To compute an approximate numerical value of an expression:

• Use the evalf command.

The evalf command returns a floating-point (or complex floating-point)
number or expression.

> 

(7.4)

> 

> 

(7.5)
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By default, Maple calculates the result to ten digits of accuracy, but you can
specify any number of digits as an index, that is, in brackets ([ ]).

> 

For more information, refer to the ?evalf help page.

See also Numerically Computing a Limit (page 153) and Numeric Integra-
tion (page 163).

Evaluating Complex Expressions

To evaluate a complex expression:

• Use the evalc command.

If possible, the evalc command returns the output in the canonical form expr1
+ i expr2.

You can enter the imaginary unit using the following two methods.

• In the Common Symbols palette, click the i or j item. See
Palettes (page 11).

• Enter i or j, and then press the symbol completion key. See Symbol
Names (page 16).

> 

> 

In 1-D Math input, enter the imaginary unit as an uppercase i (I).

314   •   7  Maple Expressions



evalc(2^(1 + I));>

Evaluating Boolean Expressions

To evaluate an expression involving relational operators ( , ,

, , , and :

• Use the evalb command.

Note: In 1-D Math input, enter , , and  using the <>, <=, and

>= operators.

The evalb command uses a three-valued logic system. The return values are
true, false, and FAIL. If evaluation is not possible, an unevaluated expression
is returned.

> 

> 

> 

Important: The evalb command does not perform arithmetic for inequalities
involving <, , >, or , and does not simplify expressions. Ensure that

you perform these operations before using the evalb command.

> 
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> 

Levels of Evaluation

In a symbolic mathematics program such as Maple, you encounter the issue
of levels of evaluation. If you assign y to x, z to y, and then 5 to z, what is
the value of x?

At the top-level, Maple fully evaluates names. That is, Maple checks if the
name or symbol has an assigned value. If it has a value, Maple substitutes
the value for the name. If this value has an assigned value, Maple performs
a substitution, recursively, until no more substitutions are possible.

For example:

> 

> 

> 

Maple fully evaluates the name x, and returns the value 5.

> 

To control the level of evaluation of an expression:

• Use the eval command with an integer second argument.

If passed a single argument, the eval command fully evaluates that expression.
If you specify an integer second argument, Maple evaluates the expression
to that level.
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> 

> 

> 

> 

For more details on levels of evaluation, refer to the ?lastnameevaluation,
?assigned, and ?evaln help pages.

Delaying Evaluation

To prevent Maple from immediately evaluating an expression:

• Enclose the expression in right single quotes (' ').

Because right single quotes delay evaluation, they are referred to as unevalu-
ation quotes.

> 

> 
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> 

Using an Assigned Name as a Variable or Keyword

If you use an assigned name as a variable, Maple evaluates the name to its
value, and passes the value to the command.

> 

Error, (in sum) summation variable previously assigned, second argument evaluates
to 4 = 1 .. 5

Note: In general, it is recommended that you unassign a name to use it as a
variable. See Unassigning a Name Using Unevaluation Quotes (page 319).

To use an assigned name as a variable:

• Enclose the name in unevaluation quotes. Maple passes the name to the
command.

> 

Important: It is recommended that you enclose keywords in unevaluation
quotes.

For example, if you enclose the keyword left in unevaluation quotes, Maple
uses the name, not its assigned value.

> 
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> 

Full Evaluation of an Expression in Quotes

Full evaluation of a quoted expression removes one set of right single quotes.

> 

> 

(7.6)

> 

(7.7)

> 

For information on equation labels and equation label references, see Equa-
tion Labels (page 59).

Enclosing an expression in unevaluation quotes delays evaluation, but does
not prevent automatic simplification.

> 

Unassigning a Name Using Unevaluation Quotes

To unassign a name:

• Assign the name enclosed in unevaluation quotes to itself.
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> 

> 

You can also unassign a name using the unassign command. For more in-
formation, see Unassigning Names (page 57).
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8  Basic Programming
You have used Maple interactively in the previous chapters, sequentially
performing operations such as executing a single command. Because Maple
has a complete programming language, you can also use sophisticated pro-
gramming constructs.

Important: It is strongly recommended that you use the Worksheet mode
and 1-D Math input when programming or using programming commands.
Hence, all input in this chapter is entered as 1-D Math.

8.1  In This Chapter
TopicsSection

• Conditional Execution (if Statement)

• Repetition (for Statement)

Flow Control - Basic programming con-
structs

• Creating a sequence

• Adding and Multiplying Expressions

• Selecting Expression Operands

• Mapping a Command over a Set or List

• Mapping a Binary Command over Two Lists
or Vectors

Iterative Commands - Specialized, effi-
cient iterative commands

• Defining and Running Simple Procedures

• Procedures with Inputs

• Procedure Return Values

• Displaying Procedure Definitions

• Displaying Maple Library Procedure
Definitions

• Modules

Procedures - Maple programs
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8.2  Flow Control
Two basic programming constructs in Maple are the if statement, which
controls the conditional execution of statement sequences, and the for
statement, which controls the repeated execution of a statement sequence.

Conditional Execution (if Statement)

You can specify that Maple perform an action only if a condition holds. You
can also perform an action, from a set of many, depending on which condi-
tions hold.

Using the if statement, you can execute one statement from a series of
statements based on a boolean (true, false, or FAIL) condition. Maple tests
each condition in order. When a condition is satisfied, Maple executes the
corresponding statement, and then exits the if statement.

Syntax

The if statement has the following syntax.

if conditional_expression1 then
statement_sequence1

elif conditional_expression2 then
statement_sequence2

elif conditional_expression3 then
statement_sequence3

...
else

statement_sequenceN
end if;

>

The conditional expressions (conditional_expression1, conditional_expres-
sion2, ...) can be any boolean expression. You can construct boolean expres-
sions using:

• Relational operators - <, <=, =, >=, >, <>
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• Logical operators - and, or, xor, implies, not

• Logical names - true, false, FAIL

The statement sequences (statement_sequence1, statement_sequence2, ...,
statement_sequenceN) can be any sequence of Maple statements, including
if statements.

The elif clauses are optional. You can specify any number of elif clauses.

The else clause is optional.

Simple if Statements

The simplest if statement has only one conditional expression.

if conditional_expression then
statement_sequence

end if;

>

If the conditional expression evaluates to true, the sequence of statements
is executed. Otherwise, Maple immediately exits the if statement.

For example:

x := 1173:>

if not isprime(x) then
   ifactor(x);
end if;

>

else Clause

In a simple if statement with an else clause, if the evaluation of the conditional
expressions returns false or FAIL, Maple executes the statement sequence
in the else clause.
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For example:

if false then
   "if statement";
else
   "else statement";
end if;

>

elif Clauses

In an if statement with elif clauses, Maple evaluates the conditional expres-
sions in order until one returns true. Maple executes the corresponding
statement sequence, and then exits the if statement. If no evaluation returns
true, Maple exits the if statement.

x := 11:>

if not type(x, integer) then
   printf("%a is not an integer.", x);
elif x >= 10 then
   printf("%a is an integer with more than one digit.", x);
elif x >= 0 then
   printf("%a is an integer with one digit.", x);
end if;

>

11 is an integer with more than one digit.

Order of elif Clauses An elif clause's statement sequence is executed only
if the evaluation of all previous conditional expressions returns false or
FAIL, and the evaluation of its conditional expression returns true. This
means that changing the order of elif clauses may change the behavior of
the if statement.

In the following if statement, the elif clauses are in the wrong order.
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if not(type(x, integer)) then
   printf("%a is not an integer.", x);
elif x >= 0 then
   printf("%a is an integer with one digit.", x);
elif x >= 10 then
   printf("%a is an integer with more than one digit.", x);
end if;

>

11 is an integer with one digit.

elif and else Clauses

In an if statement with elif and else clauses, Maple evaluates the conditional
expressions in order until one returns true. Maple executes the corresponding
statement sequence, and then exits the if statement. If no evaluation returns
true, Maple executes the statement sequence in the else clause.

x := -12:>

if not type(x, integer) then
   printf("%a is not an integer.", x);
elif x >= 10 then
   printf("%a is an integer with more than one digit.", x);
elif x >= 0 then
   printf("%a is an integer with one digit.", x);
else
   printf("%a is a negative integer.", x);
end if;

>

-12 is a negative integer.

For more information on the if statement, refer to the ?if help page.

Repetition (for Statement)

Using repetition statements, you can repeatedly execute a statement se-
quence. You can repeat the statements in three ways.
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• Until a counter variable value exceeds a limit (for/from loop)

• For each operand of an expression (for/in loop)

• Until a boolean condition does not hold (while loop)

for/from Loop

The for/from loop statement repeats a statement sequence until a counter
variable value exceeds a limit.

Syntax

The for/from loop has the following syntax.

for counter from initial by increment to final do
statement_sequence

end do;

>

The behavior of the for/from loop is:

1. Assign the initial value to the name counter.

2. Compare the value of counter to the value of final. If the counter value
exceeds the final value, exit the loop. (This is the loop bound test.)

3. Execute the statement_sequence.

4. Increment the counter value by the value of increment.

5. Repeat steps 2 to 4, until Maple exits the loop.

The from, by, and to clauses are optional and can be in any order between
the for clause and the do keyword.

Table 8.1 lists the default clause values.
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Table 8.1: Default Clause Values

Default ValueClause

1from initial

1by increment

infinity (∞)to final

Examples

The following loop returns the square root of the integers 1 to 5 (inclusive).

for n to 5 do
   evalf(sqrt(n));
end do;

>

When the value of the counter variable n is strictly greater than 5, Maple
exits the loop.

n;>

The previous loop is equivalent to the following for/from statement.
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for n from 1 by 1 to 5 do
   evalf(sqrt(n));
end do;

>

The by value can be negative. The loop repeats until the value of the counter
variable is strictly less than the final value.

for n from 10 by -1 to 3 do
   if isprime(n) then
      print(n);
   end if;
end do;

>

n;>

for/in Loop

The for/in loop statement repeats a statement sequence for each component
(operand) of an expression, for example, the elements of a list.

Syntax

The for/in loop has the following syntax.

for variable in expression do
statement_sequence

end do;

>
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The for clause must appear first.

The behavior of the for/in loop is:

1. Assign the first operand of expression to the name variable.

2. Execute the statement_sequence.

3. Assign the next operand of expression to variable.

4. Repeat steps 2 and 3 for each operand in expression. If there are no more
operands, exit the loop. (This is the loop bound test.)

Example

The following loop returns a floating-point approximation to the sin function
at the angles (measured in degree) in the list L.

L := [23.4, 87.2, 43.0, 99.7]:>

for i in L do 
   evalf(sin(i*Pi/180));
end do;

>

while Loop

The while loop repeats a statement sequence until a boolean expression does
not hold.
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Syntax

The while loop has the following syntax.

while conditional_expression do
statement_sequence

end do;

>

A while loops repeats until its boolean expression conditional_expression
evaluates to false or FAIL. For more information on boolean expressions,
see Conditional Execution (if Statement) (page 322).

Example

The following loop computes the digits of 872, 349 in base 7 (in order of
increasing significance).

x := 872349:>

while x > 0 do 
   irem(x, 7);
   x := iquo(x, 7);
end do;

>
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To perform such conversions efficiently, use the convert/base command.

convert(872349, base, 7);>

For information on non-base 10 numbers, see Non-Base 10 Num-
bers (page 74).

General Loop Statements

You can include a while statement in a for/from or for/in loop.

The general for/from loop has the following syntax.
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for counter from initial by increment to final 
while conditional_expression do

statement_sequence
end do;

>

The general for/in loop has the following syntax.

for variable in expression 
while conditional_expression do

statement_sequence
end do;

>

After testing the loop bound condition at the beginning of each iteration of
the for loop, Maple evaluates conditional_expression.

• If conditional_expression evaluates to false or FAIL, Maple exits the
loop.

• If conditional_expression evaluates to true, Maple executes statement_se-
quence.

Infinite Loops

You can construct a loop for which there is no exit condition, for example,
a while loop in which the conditional_expression always evaluates to true.
This is called an infinite loop. Maple indefinitely executes an infinite loop
unless it executes a break, quit, or return statement or you interrupt the
computation. For more information, refer to the ?break, ?quit, ?return,
and ?interrupt help pages.

Additional Information

For more information on the for statement and looping, refer to the ?do help
page.

332   •   8  Basic Programming



8.3  Iterative Commands
Maple has commands that perform common selection and repetition opera-
tions. These commands are more efficient than similar algorithms implemen-
ted using library commands. Table 8.2 lists the iterative commands.

Table 8.2: Iterative Commands

DescriptionCommand

Create sequenceseq

Compute numeric sumadd

Compute numeric productmul

Return operands that satisfy a conditionselect

Return operands that do not satisfy a conditionremove

Return operands that satisfy a condition and separately return operands
that do not satisfy a condition

selectremove

Apply command to the operands of an expressionmap

Apply binary command to the operands of two lists or vectorszip

Creating a Sequence

The seq command creates a sequence of values by evaluating a specified
expression over a range of index values or the operands of an expression.
See Table 8.3.

Table 8.3: The seq Command

ExamplesCalling Sequence Syntax

> seq(exp(x), x=-2..0);seq(expression, name = initial .. final);
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ExamplesCalling Sequence Syntax

> seq(u, u in [Pi/4, Pi^2/2, 1/Pi]);seq(expression, name in expression);

Adding and Multiplying Expressions

The add and mul commands add and multiply sequences of expressions
over a range of index values or the operands of an expression. See Table 8.4.

Table 8.4: The add and mul Commands

ExamplesCalling Sequence Syntax

> add(exp(x), x = 2..4);

> mul(2*x, x = 1 .. 10);

add(expression, name = initial .. final);

mul(expression, name = initial .. final);

> add(u, u in [Pi/4, Pi/2, Pi]);

> mul(u, u in [Pi/4, Pi/2, Pi]);

add(expression, name in expression);

mul(expression, name in expression);

The endpoints of the index range (initial and final) in the add and mul
calling sequence must evaluate to numeric constants. For information on
symbolic sums and products, refer to the ?sum and ?product help pages.
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Selecting Expression Operands

The select, remove, and selectremove commands apply a boolean-valued
procedure or command to the operands of an expression. For information
on operands, refer to the ?op help page.

• The select command returns the operands for which the procedure or
command returns true.

• The remove command returns the operands for which the procedure or
command returns false.

• The selectremove command returns two expressions of the same type
as the input expression.

- The first consists of the operands for which the procedure or command re-
turns true.

- The second consists of the operands for which the procedure or command
returns false or FAIL.

See Table 8.5.

For information on Maple procedures, see Procedures (page 338).

Table 8.5: The select, remove, and selectremove Commands

ExamplesCalling Sequence Syntax

> select(issqr, {198331, 889249, 11751184,
9857934});

select(proc_cmd, expression);

> remove(var -> degree(var) > 3, 2*x^3*y
- y^3*x + z );

remove(proc_cmd, expression);
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ExamplesCalling Sequence Syntax

> selectremove(x -> evalb(x > round(x)),
[sin(0.), sin(1.), sin(3.)]);

selectremove(proc_cmd, expres-
sion);

For information on optional arguments to the selection commands, refer to
the ?select help page.

Mapping a Command over a Set or List

The map command applies a name, procedure, or command to each element
in a set or list. See Table 8.6.

Table 8.6: The map Command

ExamplesCalling Sequence Syntax

> map(f, {a, b, c});

> map(u -> int(cos(x), x = 0 .. u), [Pi/4, Pi/7,
Pi/3.0]);

map(name_proc_cmd, expression);

For information on mapping over the operands of other expressions, optional
arguments to the map command, and other mapping commands, refer to the
?map help page.

Mapping a Binary Command over Two Lists or
Vectors

The zip command applies a name or binary procedure or command compon-
ent-wise to two lists or vectors.
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By default, the length of the returned object is that of the shorter list or vector.
If you specify a value as the (optional) fourth argument, it is used as the
value of the missing elements of the shorter list or vector. In this case, the
length of the return value is that of the longer list or vector. See Table 8.7.

Table 8.7: The zip Command

ExamplesCalling Sequence Syntax

> zip(f, [i, j], [k, l]);

> zip(AiryAi, [1, 2], [0], 1);

zip(proc_cmd, a, b);

zip(proc_cmd, a, b, fill);

For more information on the zip command, refer to the ?zip help page.

Additional Information

For more information on looping commands, refer to the corresponding
command help page.
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8.4  Procedures
A Maple procedure is a program consisting of Maple statements. Using
procedures, you can quickly execute the contained sequence of statements.

Defining and Running Simple Procedures

To define a procedure, enclose a sequence of statements between proc(...)
and end proc statements. In general, you assign a procedure definition to a
name.

The following procedure returns the square root of 2.

p := proc() sqrt(2); end proc;>

Note: Maple returns the procedure definition.

To improve readability of procedures, it is recommended that you define a
procedure using multiple lines, and indent the lines using space characters.
To begin a new line (without evaluating the incomplete procedure definition),
press Shift+Enter. When you have finished entering the procedure, press
Enter to create the procedure.

For example:

p := proc()
   sqrt(2);
end proc:

>

To run the procedure p, enter its name followed by parentheses (( )).

p();>
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Procedures with Inputs

You can define a procedure that accepts user input. In the parentheses of the
proc statement, specify the parameter names. For multiple parameters, sep-
arate the names with commas.

geometric_mean := proc(x, y)
   sqrt(x*y);
end proc:

>

When the user runs the procedure, the parameter names are replaced by the
argument values.

geometric_mean(13, 17);>

geometric_mean(13.5, 17.1);>

For more information on writing procedures, including options and local
and global variables, refer to the ?procedure help page.

Procedure Return Values

When you run a procedure, Maple returns only the last statement result value
computed. Maple does not return the output for each statement in the proced-
ure. It is irrelevant whether you use semicolons or colons as statement sep-
arators.

p := proc(a, b)
   a + b;
   a - b:
end proc:

>
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p(1, 2);>

Displaying Procedure Definitions

Unlike simple Maple objects, you cannot display the value of a procedure
by entering its name.

geometric_mean;>

You must evaluate the name of the procedure using the print (or eval)
command.

print(geometric_mean);>

Displaying Maple Library Procedure Definitions

Maple procedure definitions are a valuable learning tool. To learn how to
program in Maple, it is recommended that you examine the procedures
available in the Maple library.

By default, the print command returns only the proc and end proc statements
and (if present) the description fields of a Maple procedure.

print(assign);>

To display a Maple library procedure definition, first set the value of the
interface verboseproc option to 2. Then re-execute the print calling se-
quence. See Figure 8.1.
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interface('verboseproc' = 2):>

Figure 8.1: Displaying assign Procedure
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Modules

Maple procedures associate a sequence of commands with a single command.
The module, a more complex programming structure, allows you to associate
related procedures and data.

A key feature of modules is that they export variables. This means that the
variables are available outside the module in which they are created. Most
Maple packages are implemented as modules. The package commands are
exports of the module.

For more information on modules, refer to the ?module help page.
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9  Maplets
A Maplet is a graphical user interface that provides interactive access to the
Maple engine through buttons, text regions, slider bars, and other visual in-
terfaces. You can design custom Maplet applications to use and share with
colleagues or students, or you can take advantage of the built-in Maplets that
cover numerous academic and specialized topics. For information on some
of the built-in Maplets, see Assistants and Tutors (page 26), Teaching and
Learning with Maple (page 178), or Ordinary Differential Equations
(ODEs) (page 88). Other methods of interaction with Maple are described
in the Maple Getting Started Guide and throughout this book.

9.1  In This Chapter
TopicsSection

• Define and Run a Simple MapletSimple Maplet - Illustrating a simple Maplet

• Maplet File

• Maple Document

Using Maplets - Methods for launching a Maplet

• Maplet Builder

• Maplets Package

• Saving

Authoring Maplets - Methods for authoring and
saving a Maplet

9.2  Simple Maplet
A Maplet application can be defined using the commands in the
Maplets[Elements] package and then launched using the Maplets[Display]
command. The following commands define and run a very simple Maplet
application that contains the text string "Hello World".

with(Maplets[Elements]):>
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MySimpleMaplet:= Maplet([["Hello World"]]):>

Maplets[Display](MySimpleMaplet):>

Figure 9.1: A Simple Maplet

For more information on creating Maplets, including an overview of the
point-and-click Maplet Builder Assistant, see Authoring Maplets (page 345).

9.3  Using Maplets
Maplet applications are launched by executing Maplet code. Maplet code
can be saved in a Maplet (.maplet) file or Maple document (.mw).

Maplet File

To launch a Maplet application saved as a Maplet file:

• In Windows, double-click the file from a Windows file browser.

• In UNIX and on Macintosh, use the command-line interface. At the
command-line, enter maple -q maplet_filename.

To view and edit the Maplet code contained within the .maplet file:

1. Start Maple.

2. From the File menu, select Open. Maple displays the Open dialog.

3. In the Files of Type drop-down list, select .maplet.

4. Navigate to the location of the .maplet file and select the file.

5. Click Open.
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Maple Document

To launch a Maplet application for which the Maple code is contained in a
Maple document, you need to execute the Maplet code. To display the Maplet
application, you must use the Maplets[Display] command. Note: The Maplet
code may be quite large if the Maplet application is complex. In this case,
execute the document to ensure user-defined procedures that are referenced
in the Maplet application are also defined.

Typical procedure:

1. If present, evaluate user-defined procedures.

Myproc:=proc...

2. Load the Maplets[Elements] package.

with( Maplets[Elements] );

3. Evaluate the Maplet definition.

Maplet_name:=Maplet( Maplet_definition );

4. Display the Maplet application.

Maplets[Display]( Maplet_name );

Important: When a Maplet application is running, you cannot interact with
the Maple document.

9.4  Authoring Maplets
When authoring Maplets, you can use the Maplet Builder (GUI-based) or
the Maplets package (syntax-based). The Maplet Builder allows you to
drag and drop buttons, sliders, text regions, and other elements to define the
Maplet application and set the element properties to perform an action upon
selection or update of the element. The Maplet Builder is designed to create
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simple Maplets. The Maplets package offers more capabilities, control and
options when designing complicated Maplet applications.

Designing a Maplet application is similar to constructing a house. When
building a house, you first construct the skeletal structure (that is, foundation,
floors, and walls) and then proceed to add the windows and doors. Construct-
ing a Maplet is no different. First define the rows and columns of the Maplet
application and then proceed to add the body elements (for example, buttons,
text fields, and plotter regions).

Maplet Builder

To start the Maplet Builder:

• From the Tools menu, select Assistants, and then Maplet Builder.

Figure 9.2: Maplet Builder Interface
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The Maplet Builder is divided into four different panes.

• The Palette pane displays palettes, which contain Maplet elements, or-
ganized by category. For a description of the elements, see the
?MapletBuilder/Palette help page. The Body palette contains the most
popular elements.

• The Layout pane displays the visual elements of the Maplet.

• The Command pane displays the commands and corresponding actions
defined in the Maplet.

• The Properties pane displays the properties of an instance of a defined
element in the Maplet.
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Design a Maplet Using the Maplet Builder

In this example, shown in Figure 9.3, the Maplet user enters a function and
plots the result.

Figure 9.3: Image of the Maplet

Button element

Label element

Plotter element

TextField element

Figure 9.4: Body Elements Used When Defining This Maplet
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Define the number of rows in the Maplet

1. In the Properties pane:

            a. In the drop-down list, select BoxColumn1.

            b. Change the numrows field to 2.

Figure 9.5: Define the Number of Rows in the Maplet
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Add a plot region to row 1

1. From the Body palette, drag the Plotter element to the first row in the
Layout pane.

Figure 9.6: Add a Plot to Row 1
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Add columns to row 2

1. In the Properties pane:

            a. In the drop-down list, select BoxRow2.

            b. Change the numcolumns field to 3.

Figure 9.7: Add Columns to Row 2
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Add a label to row 2

1. From the Body palette, drag the Label element to the left column in 
the Layout pane.

2. In the Properties pane:

            a. In the drop-down list, select Label1.

            b. Change the caption field to Enter a function of x.

Figure 9.8: Add a Label to Row 2
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Add a text region to row 2

1. From the Body palette, drag the TextField element to the middle column.
The TextField element allows the Maplet user to enter input that can be re-
trieved in an action.

2. If necessary, resize the Maplet Builder to display the entire Layout pane.

Figure 9.9: Add a Text Region to Row 2
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Add a button to row 2

1. From the Body palette, drag the Button element to the right column in the Layout pane. 
2. In the Properties pane: 

            a. In the drop-down list, select Button1.

            b. Change the caption field to Plot.

            c. In the onclick property drop-down list, select <Evaluate>.

Figure 9.10: Add a Button to Row 2
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3. In the Evaluate Expression dialog that displays, the Target drop-down

list contains the defined elements to which you can send information, in this 

case, Plotter1 and TextField1. The List group box, located below the 

Expression group box, displays the defined elements to which you can

retrieve information, in this case, TextField1.

            a. In the Target drop-down list, select Plotter1. 

            b. In the Command Form tab, enter plot(TextField1, x=-10..10) in

the Expression group box. (Note: Do not  include a semicolon (;) at the end  

of the plot command). You can also double-click TextField1 in the List

group box to insert this element in the command syntax.

            c. Click Ok.
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Figure 9.11: Evaluate Expression Dialog

Run the Maplet

1. From the File menu, select Run. You are prompted to save the Maplet.
Maplets created with the Maplet Builder are saved as .maplet files.

2. Click Yes and navigate to a location to save this Maplet.

For further information on the Maplet Builder, see the ?MapletBuilder
help page. For more examples of designing Maplets using the Maplet
Builder, see ?MapletBuilder/examples.

Maplets Package

When designing a complicated Maplet, the Maplets package offers greater
control. The Maplets[Elements] subpackage contains the elements available
when designing a Maplet application. After you define the Maplet, use the
Maplets[Display] command to launch the Maplet.
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Example 1 - Design a Maplet Using the Maplets Package

To introduce the structure of designing Maplets using the Maplets package,
this example illustrates the equivalent syntax for the Design a Maplet Using
the Maplet Builder (page 348).

Load the Maplets[Elements] package.

with(Maplets[Elements]):>

Define the Maplet application. To suppress the display of the data structure
associated with the Maplet application, end the definition with a colon.
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PlottingMaplet:=Maplet(
  BoxLayout(
   BoxColumn(
     # First Box Row
         BoxRow(
       # Define a Plot region
           Plotter('reference' = Plotter1)
     # End of first Box Row
                 ),
     # Second Box Row
         BoxRow(
       # Define a Label
           Label("Enter a function of x "),   
        # Define a Text Field

TextField('reference' = TextField1),
        # Define a Button
           Button(caption="Plot", Evaluate(value = 'plot(TextField1, 
                  x = -10..10)', 'target' = Plotter1))
     # End of second Box Row  
           )
    # End of BoxColumn
      )
  # End of BoxLayout
  )
# End of Maplet
):

>

Launch the Maplet.

Maplets[Display](PlottingMaplet); >
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Example 2 - Accessing User-Defined Procedures

When designing a Maplet, you can access user-designed procedures and
send information bi-directionally to the Maplet. In this example, shown in
Figure 9.12, the user enters a function in a MathML editor region, optionally
selects a color from a color dialog, and plots the result.

Figure 9.12: Image of the Maplet
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User-Defined Procedure and Maplet Code

Define a procedure to be accessed in the Maplet.

GetColor:=proc()
local R, G, B, result;
  use Maplets[Tools] in

 # Convert the color value defined in the Color dialog
     result:=Get(ColorDialog1);
 # The result format is "#RRGGBB" in hexadecimal(base 16)
 # Convert to values in the range 0..1
     R:=convert(result[2..3], 'decimal', 16)/255;
     G:=convert(result[4..5], 'decimal', 16)/255;
     B:=convert(result[6..7], 'decimal', 16)/255;

 # Plot the function entered in the MathMLEditor region
     plot(MathML:-Import(Get(MathMLEditor1)), x=0..10, 
          color=COLOR(RGB, R, G, B));

    end use:
 end proc:

>

Load the Elements package.

with(Maplets[Elements]):>

Define the Maplet application.
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PlottingMaplet2:= Maplet(
              'onstartup' = Action(RunWindow(Window1)),
Window('reference' = Window1,
  BoxLayout(
     BoxColumn(
        BoxRow(              
           Plotter('reference' = Plotter1)),               
        BoxRow(         
           MathMLEditor('reference' = MathMLEditor1)),   
        BoxRow(                 
      # Access the GetColor procedure and plot the result
           Button("Plot", Evaluate('function' = 'GetColor', 
                  'target' = 'Plotter1')), 
      # Launch the Color dialog
           Button("Color", RunDialog('dialog' = 'ColorDialog1')), 
      # Close the Maplet
           Button("Close", Shutdown()))  
              )    
          )    
      ),      

Action('reference' = 'approveColorDialog1'),
Action('reference' = 'cancelColorDialog1'),

   ColorDialog('onapprove' = 'approveColorDialog1', 
               'oncancel' = 'cancelColorDialog1', 
               'reference' = 'ColorDialog1')
):   

>

Display the Maplet

Maplets[Display](PlottingMaplet2);>

For more information on the Maplets package, refer to the ?MapletsPackage
help page. For more examples of designing Maplets using the Maplets
package, see the ?Maplets/Roadmap help page.
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Saving

When saving a Maplet, you can save the document as an .mw file or you
can export the document as a .maplet file.

Maple Document

To save the Maplet code as an .mw file:

     1. From the File menu, select Save. 

     2. Navigate to the save location. 

     3. Enter a filename.

     4. Click Save.

If the document contains only Maplet code, it is recommended that you export
the document as a .maplet file.

Maplet File

To export the Maplet code as a .maplet file:

     1. From the File menu, select Export As.

     2. In the Files of Type drop-down list, select Maplet. 

     3. Navigate to the export location.

     4. Enter the filename.

     5. Click Save.
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10  Input, Output, and
Interacting with Other Products

10.1  In This Chapter
TopicsSection

• Saving Data to a File

• Saving Expressions to a File

Writing to Files - Saving to Maple file
formats

• Reading Data from a File

• Reading Expressions from a File

Reading from Files - Opening Maple files

• Exporting Documents

• MapleNet

• Maple T.A.

Exporting to Other Formats - Exporting
documents in file formats supported by
other software

• Translating Maple Code to Other Program-
ming Languages

• Accessing External Products from Maple

• Accessing Maple from External Products

Connectivity - Using Maple with other
programming languages and software

10.2  Writing to Files
Maple supports file formats in addition to the standard .mw file format.

After using Maple to perform a computation, you can save the results to a
file for later processing with Maple or another program.

Saving Data to a File

If the result of a Maple calculation is a long list or a large array of numbers,
you can convert it to Matrix form and write the numbers to a file using the
ExportMatrix command. This command writes columns of numerical data
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to a file, allowing you to import the numbers into another program. To convert
a list or a list of lists to a Matrix, use the Matrix constructor. For more in-
formation, refer to the ?Matrix help page.

> 

> 

If the data is a Vector or any object that can be converted to type Vector,
use the ExportVector command. To convert lists to Vectors, use the Vector
constructor. For more information, refer to the ?Vector help page.

> 

> 

> 

You can extend these routines to write more complicated data, such as
complex numbers or symbolic expressions. For more information, refer to
the ?ExportMatrix and ?ExportVector help pages.

For more information on matrices and vectors, see Linear Algebra (page 133).
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Saving Expressions to a File

If you construct a complicated expression or procedure, you can save them
for future use in Maple. If you save the expression or procedure in the Maple
internal format, Maple can retrieve it more efficiently than from a document.
Use the save command to write the expression to a .m file. For more inform-
ation on Maple internal file formats, refer to the ?file help page.

> 

In this example, small expressions are used. In practice, Maple supports ex-
pressions with thousands of terms.

> 

> 

You can save these expressions to the file qbinom.m.

> 

Clear the memory using the restart command and retrieve the expressions
using the read command.

> 
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> 

> 

For more information on writing to files, refer to the ?save help page.

10.3  Reading from Files
The most common reason for reading files is to load data, for example, data
generated in an experiment. You can store data in a text file, and then read
it into Maple using the Import Data Assistant.

Reading Data from a File

Import Data Assistant

If you generate data outside Maple, you must read it into Maple before ma-
nipulating it. This data can be an image, a sound file, or columns of numbers
in a text file. You can import this external data into Maple using the Import
Data Assistant.

To launch the Import Data Assistant:

• From the Tools menu, select Assistants, and then Import Data.

• Using the Select Data Source dialog, select the data file to import.
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Figure 10.1: Import Data Assistant (Detail)

From the main window, you can preview the selected file, and specify the
source format, source form, and behavior on close. You can also select a
different file to be imported. Additional help is available from the Help menu
of the Import Data window.

ImportMatrix Command

The Import Data Assistant provides a graphical interface to the Import-
Matrix command. For more information, including options not available in
the assistant, refer to the ?ImportMatrix help page.

Reading Expressions from a File

You can write Maple programs in a text file using a text editor, and then
import the file into Maple. You can paste the commands from the text file
into your document or you can use the read command.
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When you read a file with the read command, Maple treats each line in the
file as a command. Maple executes the commands and displays the results
in your document but it does not, by default, insert the commands from the
file in your document.

For example, the file ks.tst contains the following Maple commands.

S:= n -> sum( binomial( n, beta ) * ( ( 2*beta )! / 2^beta - beta!*beta ),
beta=1..n );

S(19);

When you read the file, Maple displays the results but not the commands.

> 

If you set the interface echo option to 2, Maple inserts the commands from
the file into your document.

> 

> 

>

S:=n->sum(binomial(n,beta)*((2*beta)!/2^beta-beta!*beta),beta=1..n);
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> S(19);

For more information, refer to the ?read and ?interface help pages.

10.4  Exporting to Other Formats

Exporting Documents

You can save your documents by selecting Save or Save As from the File
menu. By selecting Export As from the File menu, you can also export a
document in the following formats: HTML, LaTeX, Maple input, Maplet
application, Maple text, plain text, and Rich Text Format. This allows you
to access your work outside Maple.

HTML

The .html file that Maple generates can be loaded into any HTML browser.
Exported mathematical content can be displayed in one of the following
formats: GIF, MathML 2.0 Presentation, MathML 2.0 Content, or Maple
Viewer, and is saved in a separate folder. MathML is the Internet standard,
sanctioned by the World Wide Web Consortium (W3C), for the communic-
ation of structured mathematical formulae between applications. For more
information about MathML, refer to the ?MathML help page.

Maple documents that are exported to HTML translate into multiple docu-
ments when using frames. If the frames feature is not selected, Maple creates
only one page that contains the document contents.

LaTeX

The .tex file generated by Maple is ready for processing by LaTeX. All dis-
tributions of Maple include the necessary style files. By default, the LaTeX
style files are set for printing the .tex file using the dvips printer driver. You
can change this behavior by specifying an option to the \usepackage LaTeX
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command in the preamble of your .tex file. For more information, refer to
the ?exporttoLaTeX help page.

Maple Input

You can export a Maple document as Maple input so that it can be loaded
using the Maple Command-line version.

Important: When exporting a document as Maple input for use in Command-
line Maple, your document must contain explicit semicolons in 1-D Math
input. If not, the exported .mpl file will not contain semicolons, and Com-
mand-line Maple will generate errors.

Maplet Application

The Export as Maplet facility saves a Maple document as a .maplet file,
so that you can run it using the command-line interface or the
MapletViewer. The MapletViewer is an executable program that can launch
saved Maplet applications. It displays and runs Maplet applications independ-
ently of the Maple Worksheet interface.

Important: When exporting a document as a Maplet Application for use in
Command-line Maple or the MapletViewer, your document must contain
explicit semicolons. If not, the exported .maplet file will not contain semi-
colons, and Command-line Maple and the MapletViewer will generate errors.

For information on using the MapletViewer, see Using Maplets  (page 344).

Maple Text

Maple text is marked text that retains the distinction between text, Maple
input, and Maple output. Thus, you can export a document as Maple text,
send the text file by email, and the recipient can import the Maple text into
a Maple session and regenerate the computations in the original document.

Plain Text

Export a Maple document as plain text so that you can open the text file in
another application.
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Rich Text Format (RTF)

The .rtf file generated by Maple can be loaded into any word processor that
supports RTF.

Summary of Translation

Table 10.1: Summary of Content Translation When Exporting to Different
Formats

Rich
Text
Format

Plain
Text

Maple
Text

Maplet
Applica-
tion

Maple
Input

LaTeXHTMLContent

Main-
tained

Main-
tained

Preceded
by #

Preceded
by #

Preceded
by #

MaintainedMaintainedText

Static im-
age

Preceded
by >

Preceded
by >

Main-
tained

Main-
tained

MaintainedMaintained1-D Math

Static im-
age

1-D
Math or
charac-
ter-based
typeset-
ting

1-D
Math or
charac-
ter-based
typeset-
ting

1-D
Math (if
possible)

1-D
Math (if
possible)

1-D Math
or LaTeX
2e

GIF or Math-
ML

2-D Math

Static im-
age

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not ex-
ported

Postscript
file

GIFPlot

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not expor-
ted

Animated
GIF

Animation

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not expor-
ted

Not exportedHidden
content

RTF
page
break ob-
ject

Not sup-
ported

Not sup-
ported

Not sup-
ported

Not sup-
ported

Not suppor-
ted

Not suppor-
ted

Manually
inserted
page break
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Rich
Text
Format

Plain
Text

Maple
Text

Maplet
Applica-
tion

Maple
Input

LaTeXHTMLContent

Plain textPlain textPlain textPlain
text

Plain
text

Plain textLinks to help
pages be-
come plain
text. Links to
documents
are renamed
and conver-
ted to
HTML links

Hyperlink

Static im-
age

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not expor-
ted

GIFEmbedded
image or
sketch out-
put

RTF
table

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not ex-
ported

LaTeX
tables

HTML tableSpread-
sheet

RTF
style

Not ex-
ported

Not ex-
ported

Not ex-
ported

Not ex-
ported

LaTeX en-
vironments
and sec-
tions,
LaTeX 2e
macro calls

Approxim-
ated by
HTML style
attributes

Document
style

MapleNet

Overview of MapleNet

Using MapleNet, you can deploy Maple content on the Web. Powered by
the Maple computation engine, MapleNet allows you to embed dynamic
formulas, models, and diagrams as live content in Web pages. The MapleNet
software is not included with the Maple software. For more information on
MapleNet, visit http://www.maplesoft.com/maplenet.
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MapleNet Documents and Maplets

After you upload your Maple documents to the MapleNet server, it can be
accessed by anyone in the world using a Web browser. Even if viewers do
not have a copy of Maple installed, they can view documents and Maplets,
manipulate 3-D plots, and execute code at the click of a button.

Custom JavaTM Applets and JavaServer PagesTM Technology

MapleNet provides a programming interface to the Maple math engine so

commands can be executed from a JavaTM applet or using JavaServer

PagesTM technology. Embed MapleNet into your Web application, and let
Maple handle the math and visualization.

Maple T.A.

Overview of Maple T.A.

Maple T.A. is a Web-based automated testing system, based on the Maple
engine. Instructors can use pre-written questions or create custom question
banks and then choose from these questions to form quizzes and assignments.
Maple T.A. automatically grades responses as students complete assignments
and tests. For more information, visit http://www.maplesoft.com/mapleta.

Exporting Assignments to Maple T.A.

You can use Maple to create graded questions for use in Maple T.A. For in-
formation on creating and testing questions, see Creating Graded Assign-
ments (page 271). Using the Maple T.A. export feature, you can create and
test Maple T.A. content.

To export the document:

1. From the File menu, select Export As.

2. In the Export As dialog, specify a filename and the Maple T.A. (.zip)
file type. The .zip file containing your questions and assignment can be up-
loaded to Maple T.A. as a course module.
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Any document content outside Maple T.A. sections (indicated by green
section markers) is ignored by the export process.

For more details, refer to the ?exporttoMapleTA help page.

10.5  Connectivity

Translating Maple Code To Other Programming
Languages

Code Generation

The CodeGeneration package is a collection of commands and subpackages
that enable the translation of Maple code to other programming languages.
Languages currently supported include C, Fortran77, Java, MATLAB®, and
Visual Basic®.

For details on Code Generation, refer to the ?CodeGeneration help page.

Accessing External Products from Maple

External Calling

External calling allows you to use compiled C, Fortran77, or Java code in
Maple. Functions written in these languages can be linked and used as if
they were Maple procedures. With external calling you can use pre-written
optimized algorithms without the need to translate them into Maple com-
mands. Access to the NAG library routines and other numerical algorithms
is built into Maple using the external calling mechanism.

External calling can also be applied to functions other than numerical al-
gorithms. Routines exist that accomplish a variety of non-mathematical tasks.
You can use these routines in Maple to extend its functionality. For example,
you can link to controlled hardware via a serial port or interface with another
program. The Database Integration Toolbox uses external calling to allow
you to query, create, and update databases in Maple. For more information,
visit http://www.maplesoft.com/products/toolboxes.
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For more information on using external calling, refer to the ?ExternalCalling
help page.

Mathematica Translator

The MmaTranslator package provides translation tools for converting
Mathematica® expressions, command operations, and notebooks to Maple.
The package can translate Mathematica input to Maple input and Mathematica
notebooks to Maple documents. The Mma subpackage contains commands
that provide translation for Mathematica commands when no equivalent
Maple command exists. In most cases, the command achieves the translation
through minor manipulations of the input and output of similar Maple com-
mands.

Note: The MmaTranslator package does not convert Mathematica programs.

There is a Maplet interface to the MmaTranslator package. For more in-
formation, refer to the ?MmaToMaple help page.

Matlab Package

The Matlab package enables you to call selected MATLAB functions from
a Maple session, provided you have MATLAB installed on your system.

For more information, refer to the ?Matlab help page.

Accessing Maple from External Products

Microsoft Excel Add-In

Maple is available as an add-in to Microsoft Excel 2000, Excel 2003, and
Excel XP for Windows, and provides the following features.

• Access to Maple commands from Excel

• Ability to copy and paste between Maple and Excel

• Access to a subset of the Maple help pages
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• Maple Function Wizard to step you through the creation of a Maple
function call

To enable the Maple Excel Add-in in Excel 2000, Excel 2003, or Excel
XP:

1. From the Tools menu, choose Add-Ins.

2. If the Maple Excel Add-in is not listed:

• Click Browse and navigate to the directory in which Maple is installed.

• In the Excel directory, select the WMIMPLEX.xla file.

• Click OK.

3. Select the Maple Excel Add-in check box.

4. Click OK.

More information is available in the Using Maple in Excel online help file
within Excel.

To view this help file:

1. Enable the add-in.

2. From the View menu, select Toolbars, and then Maple.

3. On the Maple toolbar, click the Maple help icon .

OpenMaple

OpenMaple is a suite of functions that allows you to access Maple algorithms
and data structures in your compiled C, Java, or Visual Basic programs.
(This is the reverse of external calling, which allows access to compiled C,
Fortran77, and Java code from Maple.)

To run your application, Maple must be installed. You can distribute your
application to any licensed Maple user. For additional terms and conditions
on the use of OpenMaple, refer to extern/OpenMapleLicensing.txt in your
Maple installation.
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For more details on using OpenMaple functions, refer to the ?OpenMaple
help page.
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Index
Symbols
! toolbar icon, 10
!!! toolbar icon, 10
"", 297
%H, 146
%T, 146
&x, 146
', 57, 317
(), 338
->, 56
., 144
1-D Math, 38

switching to 2-D, 38
2-D Math, 37

converting to 1-D, 39
shortcuts, 6
switching to 1-D, 38

:, 38–39
::, 116
:=, 55
;, 38–39
<>, 136
<default>, 40, 317
>, 37
[], 142, 286, 288
^, 5, 76

entering, 76
_, 58

entering, 58
_EnvAllSolutions environment vari-
able, 82
_ZN~, 82
`, 58

{}, 287
|, 136
~, 82, 116

A
about command, 117
abs command, 73
absolute value, 73
add

word to your dictionary, 279
add command, 334
additionally command, 117
algebra, 124

linear, 133
polynomial, 124

algsubs command, 312
alignment format, 236
all content, 53
American spelling

spellcheck, 276
and operator, 323
angle brackets, 136
angles, 308
animations

creating, 222
customizing, 228

Applications
Units Calculator, 98

applications, 33
apply

character styles, 239
document blocks, 248
paragraph styles, 242

approximation, 68
least-squares, 149
numeric, 313
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arguments, 339
arithmetic, 9

finite-precision, 67
interval, 110
matrix and vector, 143
modular, 73, 75
polynomial, 124

Arrays, 289
large, 290

arrow operator, 56
assign command, 87
assigned command, 317
assignment operator (:=), 55
Assistants, 26, 121

Curve Fitting, 132
Data Analysis, 171
Import Data, 366
menu access, 26
ODE Analyzer, 88
Optimization, 167
Plot Builder, 28, 49, 189
Unit Converter, 308

assume command, 116
adding assumptions, 117
and procedure variables, 119
imposing multiple assumptions,
117
removing assumptions, 118
setting relationships between vari-
ables, 116
setting variable properties, 116
testing property, 117
using with assuming command,
119
viewing assumptions, 117

assuming command, 116, 118, 162, 
307

additionally option, 119
and procedure variables, 119
applying to all names, 119
using with assume command, 119

Attributes submenu
character, 235
paragraph, 236

auto-execute, 273
repeating, 273
security levels, 273

Avogadro constant, 105

B
bar chart, 175
basis, 149

vector space, 148
binary numbers, 74
Bohr radius, 105
bold format, 233
bookmarks

using, 264
boolean expressions, 315, 322, 330
brackets

angle, 136
break statement, 332
browser

Matrix, 137, 290
Task, 51

bullets
format, 236
list, 262

button
embedding, 268

by clause, 326
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excluding, 327
negative, 328

C
calculus, 151

multivariate, 164
Student package, 166

of variations, 166
packages, 164
study guides, 179
teaching, 166, 179
vector, 164

Student package, 166
canvas

inserting, 274
canvas style

sketch pad, 275
caret

entering, 76
central tendency, 110
character styles

creating, 240
description, 239

Cholesky decomposition, 147
choose styles dialog, 245
Classic Worksheet, xiii

tables, 258
coeff command, 130
coefficients

polynomials, 130
coeffs command, 131
collect command, 130
colon, 38–39
color

of plots, 219
combine command, 306

errors option, 113
command completion, 7

shortcut, 7
Command-line version, xiii
commands, 39

and task templates, 51
displaying procedures, 340
iterative, 333
list, 122
mapping over set or list, 336
package, 41
top-level, 40

Common Symbols palette, 11
compatibility

worksheet, 283
complex expressions, 314
compoly command, 132
components

adding GUI elements, 268
palette, 268
properties, 269

computations
assistants, 48
commands, 39
context menus, 46
errors, 70

avoiding, 70
integers, 71
interrupting, 332
linear algebra, 143
mathematics, 121
numeric, 66
palettes, 44
performing, 65, 121
Real number system, 114
symbolic, 66
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syntax-free, 19, 31
task templates, 51
tutors, 48
under assumptions, 116

single evaluation, 118
updating, 9
with uncertainty, 112
with units, 101

conditional execution, 322
constants, 10
content command, 132
context

of unit, 97
context menus, 20, 46, 121, 146, 298

customizing animations, 228
equation, 78
integer, 46, 71
Plot Builder, 28

convert command, 307
base option, 74, 331
degrees option, 308
mathematical functions, 308
polynom option, 160
set option, 308
temperature option, 99
units option, 98, 308

copy, 236
correlation, 112
coulditbe command, 118
covariance, 112
cross product, 146
Curl command, 165
Curve Fitting

Assistant, 132
package

PolynomialInterpolation com-
mand, 132

cut and paste
in tables, 254

D
D operator, 156
Data Analysis Assistant, 171
data structures, 10, 285

creating, 285
Database Integration Toolbox, 374
datatype option, 140
default content, 53
default Maple style set, 247
degree

command, 131
polynomials, 130

denom command, 302
derivatives, 153

directional, 157
partial, 154
Tutor, 179

dictionary, 33, 178
dictionary topic

adding hyperlink to, 281
diff command, 89, 155
differential equations

ordinary, 88
partial, 92

differentiation, 153
with uncertainty, 112
with units, 102

Differentiation Methods Tutor, 180
Digits environment variable, 69
dimension, 96, 147

base, 96
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Directional Derivative Tutor, 157
discrim command, 132
display

bookmark, 264
hidden formatting attributes, 238

distribution
probability, 171

divide command, 126
divisors, 73
document blocks, 31, 247
Document mode, 1

summary, 30
double colon operator, 116
dsolve command, 92

E
e-notation, 68
eigenvalues, 147
eigenvectors, 147
elementary charge, 105
elements, 104

definition, 106
isotopes, 106

definition, 106
properties, 106

list, 106
properties

list, 106
uncertainty, 109
units, 108
using, 105
value, 108
value and units, 109

elif clauses, 324
order, 324

else clause, 323

email
adding hyperlink to, 280

embedded components, 268
end do keywords, 326, 328, 330
end if keywords, 322
end proc keywords, 338
environment variables

_EnvAllSolutions, 82
Digits, 69
Order, 160

equation labels, 59
displaying, 59
features, 62
numbering schemes, 61
references to, 59
versus names, 62
with multiple outputs, 61

equations
solving, 78

for real solutions, 114
numerically, 83
symbolically, 80
transcendental, 82

errors
quantities with, 110

Euclidean algorithm, 132
eval command, 311, 340
evalb command, 315
evalc command, 314
evalf command, 69, 83, 108, 111, 313

with Int command, 163
with Limit command, 153

evaln command, 317
evaluation

boolean expressions, 315
complex expressions, 314
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delaying, 317
levels of, 316
Maple expressions, 310
of expression at a point, 310
output below, 8, 21, 31
output inline, 8, 21, 31
updated computations, 9

exact
computation, 67
numbers, 66
quantities

converting to floating-point, 69
example worksheets, 33
execution group, 38

auto-execute, 272
expand

command, 306
document block, 250
execution group, 251
series, 159

exponents
entering, 5

export, 342
to HTML, 369
to LaTeX, 369
to Maple input, 370
to Maple T.A., 373
to Maple text, 370
to Maplet application, 370
to other formats, 369
to plain text, 370
to Rich Text Format, 371
worksheets, 369

Expression palette, 12
expression sequences, 80, 286

creating, 333

expressions, 10, 285
adding, 334
evaluating, 310
manipulating, 304
multiplying, 334
versus functional operators, 293

F
factor

integers, 71
polynomials, 131
QR factorization, 149

factor command, 131, 305
factored normal form, 309
factorial command, 73
FAIL, 323, 330
false, 323, 330
Faraday constant, 105
files

image formats, 265
reading from, 366
writing to, 363

fill option, 140
finite fields, 75

solving equations, 94
finite rings, 75
floating-point

computation, 68
accuracy, 70
hardware, 70
significant digits, 69

numbers, 67
rational approximation, 47

Flux command, 165
font color, 233
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foot-pound-second (FPS) system, 25, 
97
for/from loops, 326
for/in loops, 328
formal power series solutions, 92
format lists

using paragraph styles, 263
Format menu

bookmarks, 264
document blocks, 248
quick formatting, 233

frac command, 118
fractions

approximating, 22
entering, 5

frequency plot, 175
Frobenius form

matrix, 148
from clause, 326

excluding, 327
fsolve command, 83
full evaluation, 316, 319
Function Composition Tutor, 27
FunctionAdvisor command, 41, 121
functional operators, 14, 292

differentiating, 156
plotting, 295
versus expressions, 293

functions
converting between, 308
defining, 14
defining as functional operators,
292

G
Gaussian elimination, 149

Gaussian integers, 77
GaussInt package, 77
gcd command, 132
gcdex command, 132
Getting Started Guide, 32
Global Optimization Toolbox, 166
global variables, 339
glossiness

of 3-D plots, 219
go to

bookmark, 265
gradient, 182
Gradient Tutor, 181
Graphing Calculator

Maplesoft, xiii
greatest common divisor, 73, 132

H
has command, 300
hastype command, 299
HazardRate command, 174
help

dictionary, 33
examples, 33
pages, 33
quick, 32
quick reference card, 32
task templates, 33

help page
adding hyperlink to, 281

Hermitian transpose
matrix and vector, 146

Hessenberg form, 149
hexadecimal numbers, 74
hidden formatting attributes, 238
hide

Index   •   385



worksheet content, 266
highlight color, 233
Hilbert Matrix, 149
histogram, 175
hyperlinks

in worksheet, 279

I
i

entering, 18, 77
if statement, 322
ifactor command, 71, 73, 306
igcd command, 73
images

adding hyperlink to, 280
file format, 265
inserting, 265

imaginary unit
entering, 18, 77

implies operator, 323
Import Data Assistant, 366
indent

format, 236
list, 262

indeterminates, 303
indets command, 303
indices, 40, 142
inequations

solving, 78
for real solutions, 114
symbolically, 80

infinite loops, 332
infolevel command, 93
input

1-D Math, 38
2-D Math, 37

prompt, 37
separating, 39
setting default mode, 38

insert
bookmark, 264
hyperlink, 280
images, 265
row and columns in tables, 253
section, 237
sketch pad, 274
table, 252

instructor resources, 178
Int command, 163
int command, 162
integers

commands, 73
computations, 71
context menu, 46
factoring, 71
Gaussian, 77
modulo m, 75
solving equations, 93
solving modular equations, 94

integration, 12, 18, 20, 44, 161
definite, 162
functional operators, 296
indefinite, 161
iterated, 164
line, 164, 184
numeric, 163
surface, 164
with units, 102

Interactive Plot Builder Assistant,
28, 49

creating animations, 223
creating plots, 189

386   •   Index



customizing animations, 228
customizing plots, 215

interface command
rtablesize option, 139
verboseproc option, 340

international system (SI), 97
InterquartileRange command, 173
interval arithmetic, 110
iquo command, 73
iroot command, 73
is command, 117
isprime command, 73
isqrt command, 73
italic format, 233

J
j

entering, 77
Jordan form, 147

L
labels, 59
last name evaluation, 317
Layout palette, 11
lcm command, 132
lcoeff command, 130
ldegree command, 131
least-squares, 149
left single quotes, 58
left-hand side, 301
levels of evaluation, 316
lexicographic order, 128
lhs command, 301
Limit command, 153
limit command, 152
limits, 151

multidimensional, 152
line break, 236
line integrals, 184
linear algebra, 133

computations, 143
efficiency, 139, 150
LinearAlgebra package, 148
teaching, 150, 179

linear systems
solving, 94, 149

LinearAlgebra package, 146
commands, 148
numeric computations, 150

LinearSolve command, 94
lists, 142, 288

formatting, 262
returning solutions as, 80

local variables, 339
logical operators, 323
loops, 325

general, 331
infinite, 332

M
Macintosh

command/symbol completion, 7
manuals

Getting Started Guide, 32
online, 32

map command, 336
Maple Application Center, 122, 178
Maple Getting Started Guide, 32
Maple Student Center, 179
Maplesoft Graphing Calculator, xiii
Maplesoft Web site, 32, 121
Maplet Builder
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launching, 346
Maplet authoring, 346

Maplets
adding hyperlink to, 281
authoring, 345

Maplet Builder, 346
Maplets package, 356

launching
Maple worksheet, 345
Maplet file type, 344

Maplets package
Display command, 356
Elements subpackage, 356
Maplet authoring, 356

saving
Maple worksheet, 362
maplet file, 362

using, 344
markers

bookmarks, 264
displaying, 238
for document blocks, 247

Math mode, 4
shortcuts, 6

mathematical functions
list, 41

mathematics
computations, 121
teaching and learning, 178

matrices, 291
arithmetic, 143
context menus, 146
data type, 139, 141
defining, 133
efficiency, 139
filling, 141

Hermitian transpose, 146
image, 139
large, 137
multiplication, 144
operations, 146
random, 140
scalar multiplication, 145
selecting submatrices, 143
shape, 139, 141
transpose, 146
type, 139

Matrix
Browser, 136–137, 290
constructor, 141
data structure, 133
palette, 12, 94, 133, 139

max command, 73
maximize, 166
maximum, 73
Mean command, 173
merge

table cells, 254
min command, 73
minimal content, 53
minimize, 166
minimum, 73
mod command, 73
mod operator, 75
modes

Document, 1
Math, 4
switching between, 4
Text, 4
Worksheet, 1

modify
character styles, 241
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table, 253
modp command, 75
mods command, 75
modular arithmetic, 73, 75
modules, 342
MPS(X) files, 171
msolve command, 94
mul command, 334
multiplication

implied, 6

N
names, 10, 55

adding assumptions, 116
and symbols, 16
assigned, 317
assigning values to, 55
logical, 323
previously assigned, 318
protected, 57
removing assumptions, 118
reserved, 57
unassigning, 57, 118, 319
valid, 58
versus equation labels, 62
with assumptions, 116

new style set, 245
nops command, 303
norm command, 132, 147
normal command, 309
normal form, 309
not operator, 323
numbered list, 262
numbers, 10

exact, 66
floating-point, 67

non-base 10, 74
numer command, 302
numeric

approximation, 313
computation, 67

numtheory[divisors] command, 73

O
ODE Analyzer Assistant, 88
operands, 303

selecting, 335
operators, 10

functional, 292
logical, 323
relational, 322

optimization, 166
efficiency, 169
plotting, 168
point-and-click interface, 167

Optimization Assistant, 167
Plotter, 168

Options dialog, 53
or operator, 323
Order environment variable, 160
ordinary differential equations

plotting solution, 91
solving, 88

orthogonal matrix, 149
output

suppressing, 38
updating, 31

P
packages, 40

list, 122
loading, 42
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unloading, 43, 58
warnings, 43

page break, 236
palettes, 11, 20, 44, 121, 298, 311

Common Symbols, 11
docks, 15

adding palettes, 15
expanding, 15
Expression, 12
finding items, 15
inserting items, 12
Layout, 11
Matrix, 12, 133, 139
moving, 15
Symbol Recognition, 15
Units, 24, 99
viewing, 15

paragraph styles
creating, 243
description, 239
format lists, 263

parameters, 339
parametric solutions, 83
partial differential equations

solving, 92
paste, 237
PDEs, 92
pdsolve command, 92
pencil

sketch pad, 275
pi

inserting, 12
pie chart, 175
piecewise command, 172
placeholders, 12
Planck constant, 105

Plot Builder Assistant, 28, 49
plot command, 160
plot3d command, 295
plots

analyzing, 222
pan, 222
point probe, 222
rotate, 222
scale, 222

code for color plates, 230
creating, 188

context menu, 203
displaying multiple plots, 213
insert plot, 206
Interactive Plot Builder, 28, 49, 
189
plot command, 207
plot3d command, 207
plots package, 210

creating animations
animate command, 224
Interactive Plot Builder, 223

customizing, 215
context menu, 216
Interactive Plot Builder, 215
plot options, 219
plot3d options, 219

customizing animations, 228
command-line options, 229
context menu, 228
Interactive Plot Builder, 228

exporting, 230
functional operators, 295
gradient, 183
line integral, 184
ODEs
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numeric solution, 90
symbolic solution, 91

optimization problem, 168
playing animations, 226
plots package

animate command, 224
contourplot command, 213
display command, 214
matrixplot command, 211
pointplot command, 210

series, 160
statistics, 175
viewing animations

animate context bar, 226
polynomial equations

solving, 82
numerically, 84

polynomials
algebra, 124
arithmetic, 124
coefficients, 130
collecting terms, 130
degree, 130
division, 124, 126
efficient arithmetic, 133
expanding, 125
factoring, 131
implied multiplication, 126
numeric

algebraic manipulation, 133
operations, 132
sorting, 126

pure lexicographic, 128
total degree, 127

PolynomialTools package, 133
IsSelfReciprocal command, 132

powers
entering, 5

precalculus
teaching, 179

precision, 69
prem command, 132
previously assigned, 318
primality testing, 73
primpart command, 132
print

command, 340
table, 257

probability distribution, 171
proc key word, 338
procedures, 338

and assumptions, 119
calling, 338
defining, 338
displaying, 340
inputs, 339
multiple lines, 338
output, 339
using, 338

product command, 334
products

entering, 5
implied, 6

programs, 321
modules, 342
procedures, 338

prompt
input, 37

properties
testing, 117

protected names, 57
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Q
QPSolve command, 170
QR factorization, 149
quadratic programs, 170
quantities with uncertainty, 111

accessing error, 111
accessing value, 111
computing with, 112
constructing, 111
element properties, 112
rounding the error, 112
scientific constants, 112
with units, 112

quick
character formatting, 233
help, 32
paragraph formatting, 235
reference card, 32

quit statement, 332
quo command, 124
quotes

double, 297
left single, 58
right single, 57, 317
unevaluation, 317

quotient
integer, 73

R
random

matrices, 140
variables, 171

randpoly command, 132
range

in plots, 217
operator, 142

rank, 147
rational expressions

entering, 5
read

from files, 366
recurrence relation

solving, 95
reference

equation labels, 59
names, 55

relational operators, 322
rem command, 124
remainder

integer, 73
remove command, 335
repetition statements, 325
reserved names, 57
restart command, 58
resultant command, 132
return

statement, 332
values, 339

rhs command, 301
right single quotes, 57, 317
right-hand side, 301
RootOf structure, 82
roots

command, 132
of equations, 83

row vector
creating, 141

rsolve command, 95

S
scatter plot, 175
scientific constants, 104
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list, 104
name, 105
symbol, 105
uncertainty, 109
units, 108
using, 105
value, 108
value and units, 109

ScientificConstants package, 104
extensibility, 110
objects, 107

ScientificErrorAnalysis package, 110
extensibility, 113
objects, 111

sections
in worksheet, 237

security levels
auto-execute, 273

security tab
options dialog, 273

select command, 335
selectremove command, 335
semicolon, 38–39
seq command, 333
series, 159

command, 159
plotting, 160
Taylor, 159
type, 160

sets, 287
shape option, 140
show

worksheet content, 266
show contents dialog

using, 267
significant digits, 69

simplify command, 304, 312
sketch pad

canvas style, 238
gridline, 276

slider
embedding, 268

solutions
assigning as expression, 87
assigning as function, 87
details, 93
formal, 92
formal power series, 92
integers, 93
real, 114
series, 92
verifying, 86

solve
equations, 78

for real solutions, 114
numerically, 83
symbolically, 80

inequations, 78
for real solutions, 114
symbolically, 80

integer equations, 93
linear system, 94, 149
modular integer equations, 94
ODEs, 88
PDEs, 92
recurrence relation, 95
transcendental equations, 82

solve command, 80, 288
finding all solutions, 82
finding parametric solutions, 83
real solutions, 114
solving procedures, 83
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sort
lists, 310
polynomials, 126, 310

sort command, 126, 310
plex option, 128

spacing format, 236
spellcheck, 276

American spelling, 276
dictionary, 279

sqrfree command, 133
square roots

entering, 7, 17
standard content, 53
Standard Units environment, 101
Standard Worksheet, xiii
statements

multiple lines, 338
Statistics package, 171

continuous distributions, 171
discrete distributions, 171
plots, 175

strings, 297
StringTools package, 297
Student package, 158, 178–179

calculus subpackages, 166
LinearAlgebra subpackage, 150
Maplets, 178
Tutors, 178

student resources, 178
study guides, 179
style set management, 245
subscripts

entering, 6
format, 233

substitute, 310
sum command, 334

superscript format, 233
Sylvester matrix, 149
symbol completion, 7

shortcut, 7
symbolic

computation, 66
objects, 67

symbols
entering, 16
finding, 15
names, 16

system of units, 97
controlling, 102

systeme international (SI), 25, 97

T
Tab

icon, 44
inserting, 44
key, 12, 44

tables, 290
alignment, 255
and Classic worksheet, 258
appearance, 255
borders, 255
contents, 253
execution order, 257
physical dimensions, 254
printing, 257
using, 252
visibility of cell content, 256

Task Browser, 51
task templates, 51, 71, 96, 121, 133, 
151

default content, 53
inserting, 52
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taylor command, 159
Taylor series, 159
tcoeff command, 131
teach, 178
temperature conversion, 98
text field

embedding, 268
Text mode, 4
text regions, 54
third-party products, 122
tilde, 82, 116
to clause, 326

excluding, 327
Tolerances package, 110
toolbar, 4
toolbox

Global Optimization, 122
toolboxes

Database Integration, 374
Global Optimization, 166

Tools menu
Assistants and Tutors, 26, 48
Tasks, 51

Torsion command, 165
total degree, 127
tour, 32
transparency

of 3-D plots, 220
transpose

matrices and vectors, 146
true, 323
Tutors, 26, 178–179, 181

Derivatives, 179
Differentiation Methods, 180
Directional Derivative, 157
Function Composition, 27

Gradient, 181
menu access, 27

type command, 299
types, 116, 298

converting, 307
series, 160
testing, 299

subexpressions, 299
typesetting rule assistant, 238

U
unapply command, 87
unassign command, 57
unassigning names, 57, 319
uncertainty, 110

quantities with, 110
underline format, 233
unevaluation quotes, 57, 317
union

of sets, 288
Unit Converter Assistant, 308
units, 24, 96, 308

adding to expressions, 25
applying to expression, 99
computing with, 101
context, 97
converting between, 97
environment, 101
evaluating with, 25
in 1-D Math, 101
inserting, 100
overview, 96
prefixes, 101
system of

controlling, 102
systems of, 97
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Units Calculator, 97
Units package, 96

environments, 101
extensibility, 103
UseSystem command, 103
UsingSystem command, 103

Units palettes, 24, 99
universal gravitational constant, 105
UNIX

command/symbol completion, 7
unwith command, 43
URL

adding hyperlink to, 282
user-defined style set, 247

V
variables, 10
variance, 112
VariationalCalculus package, 166
Vector

constructor
vectorfield attribute, 164

data structure, 133
vector fields, 164
vector spaces

basis, 148–149
VectorCalculus package, 164

Student version, 166
vectors, 291

arithmetic, 143
column, 136
context menus, 146
cross product, 146
data type, 140
defining, 136
efficiency, 139

filling, 140
large, 137
multiplication, 144
row, 136, 141
scalar multiplication, 145
selecting entries, 142
shape, 140
transpose, 146

View menu
markers, 238

W
Web page

adding hyperlink to, 282
Web site

Application Center, 122, 178
Maplesoft, 32, 121–122
Student Center, 179

while loops, 329
Windows

command/symbol completion, 7
with command, 42
worksheet

adding hyperlink to, 282
Worksheet mode, 1, 35
write

to files, 363

X
xor operator, 323

Z
zero recognition, 309
zip command, 336

396   •   Index


	Maple User Manual
	Contents
	Preface
	1  Document Mode
	1.1  Introduction
	1.2  In This Chapter
	1.3  Simple Mathematical Expressions
	Rational Expressions (Fractions)
	Powers
	Products
	Implied Multiplication

	Shortcuts for Entering Mathematical Expressions
	Other Expressions

	1.4  Evaluating Expressions
	1.5  Editing Expressions and Updating Output
	1.6  Entering Expressions
	Palettes
	Using Palettes
	Defining a Mathematical Function
	Viewing and Arranging Palettes
	Adding Palettes to the Palette Docks
	Handwriting Palette

	Symbol Names
	Using Symbol Names
	Using Partial Symbol Names
	Example: Indefinite Integral


	1.7  Performing Computations
	Computing with Palettes
	Context Menus
	Approximating the Value of an Expression
	Solving an Equation
	Using Units

	Assistants and Tutors
	Assistants
	Tutors
	Using a Context Menu to Launch the Plot Builder


	1.8  Document Mode Summary
	1.9  Getting Help

	2  Worksheet Mode
	2.1  In This Chapter
	2.2  Input Prompt
	Suppressing Output
	1-D Math Input
	Input Separators

	2.3  Commands
	The Maple Library
	Top-Level Commands
	Package Commands

	2.4  Palettes
	2.5  Context Menus
	2.6  Assistants and Tutors
	Launching an Assistant or Tutor
	Example: Using the Interactive Plot Builder

	2.7  Task Templates
	Viewing Task Templates
	Inserting a Task Template
	Performing the Task

	2.8  Text Regions
	2.9  Names
	Assigning to Names
	Mathematical Functions
	Protected Names

	Unassigning Names
	Unassigning All Names

	Valid Names

	2.10  Equation Labels
	Displaying Equation Labels
	Referring to a Previous Result
	Execution Groups with Multiple Outputs
	Label Numbering Schemes
	Features of Equation Labels


	3  Performing Computations
	3.1  In This Chapter
	3.2  Symbolic and Numeric Computation
	Exact Computations
	Floating-Point Computations
	Converting Exact Quantities to Floating-Point Values
	Sources of Error

	3.3  Integer Operations
	Non-Base 10 Numbers and Other Number Systems
	Non-Base 10 Numbers
	Finite Rings and Fields
	Gaussian Integers


	3.4  Solving Equations
	Solving Equations and Inequations
	Symbolically Solving Equations and Inequations
	Numerically Solving Equations
	Working with Solutions

	Other Specialized Solvers
	Ordinary Differential Equations (ODEs)
	Partial Differential Equations (PDEs)
	Integer Equations
	Integer Equations in a Finite Field
	Solving Linear Systems
	Solving Recurrence Relations


	3.5  Units, Scientific Constants, and Uncertainty
	Units
	Overview of Units
	Conversions
	Applying Units to an Expression
	Performing Computations with Units
	Changing the Current System of Units
	Extensibility

	Scientific Constants and Element Properties
	Overview of Scientific Constants and Element Properties
	Scientific Constants
	List of Scientific Constants
	Accessing Constant Definition

	Element Properties
	Elements
	Isotopes
	Accessing an Element or Isotope Property Definition

	Value, Units, and Uncertainty
	Value
	Units
	Value and Units
	Uncertainty

	Performing Computations
	Modification and Extensibility

	Uncertainty Propagation
	Quantities with Uncertainty
	Performing Computations with Quantities with Uncertainty
	Additional Information


	3.6  Restricting the Domain
	Real Number Domain
	Assumptions on Variables
	The assume Command
	The assuming Command



	4  Mathematical Computations
	4.1  In This Chapter
	4.2  Algebra
	Polynomial Algebra
	Arithmetic
	Sorting Terms
	Collecting Terms
	Coefficients and Degrees
	Factorization
	Other Commands
	Additional Information


	4.3  Linear Algebra
	Creating Matrices and Vectors
	Creating Matrices
	Creating Vectors
	Editing and Viewing Large Matrices and Vectors
	Creating Matrices and Vectors for Large Problems

	Accessing Entries in Matrices and Vectors
	Linear Algebra Computations
	Matrix Arithmetic
	Point-and-Click Interaction
	LinearAlgebra Package Commands
	Numeric Computations

	Student LinearAlgebra Package

	4.4  Calculus
	Limits
	The limit Command
	Numerically Computing a Limit

	Differentiation
	The diff Command
	Differentiating an Operator
	Directional Derivative

	Series
	Integration
	The int Command
	Numeric Integration

	Differential Equations
	Calculus Packages
	VectorCalculus Package
	Student Calculus Packages


	4.5  Optimization
	Point-and-Click Interface
	Large Optimization Problems
	MPS(X) File Support
	Additional Information

	4.6  Statistics
	Probability Distributions and Random Variables
	Adding Custom Distributions

	Statistical Computations
	Examples
	Example 1
	Example 2


	Plotting
	Additional Information

	4.7  Teaching and Learning with Maple
	Student Packages and Tutors


	5  Plots and Animations
	5.1  In This Chapter
	5.2  Creating Plots
	Interactive Plot Builder
	Example 1 - Display a plot of a single variable expression
	Example 2 - Display a plot of multiple expressions of 1 variable
	Example 3 - Display a plot of a multi-variable expression
	Example 4 - Display a conformal plot
	Example 5 - Display a plot in polar coordinates
	Example 6 - Interactive Plotting

	Context Menu
	Dragging to a Plot Region
	The plot and plot3d Commands
	Maple commands from Creating Plots: Interactive Plot Builder
	Example 1 - Display a plot of a single variable expression
	Example 2 - Display a plot of multiple expressions of 1 variable
	Example 3 - Display a plot of a multi-variable expression
	Example 4 - Display a conformal plot
	Example 5 - Display a plot in polar coordinates
	Example 6 - Interactive Plotting

	Display a Parametric Plot
	Display a 3-D Plot

	The plots Package
	The pointplot Command
	The matrixplot Command
	The contourplot Command

	Multiple Plots in the Same Plot Region
	List of Expressions
	The display Command


	5.3  Customizing Plots
	Interactive Plot Builder Options
	Context Menu Options
	2-D Plot Options
	3-D Plot Options

	The plot and plot3d Options

	5.4  Analyzing Plots
	Point Probe, Rotate, Pan, and Zoom Tools

	5.5  Creating Animations
	Interactive Plot Builder
	The plots[animate] Command
	Maple Syntax for Creating Animations: Interactive Plot Builder Example
	Animate a 2-D plot


	5.6  Playing Animations
	Animation Context Bar

	5.7  Customizing Animations
	Interactive Plot Builder Animation Options
	Context Menu Options
	The animate Command Options

	5.8  Exporting
	5.9  Code for Color Plates

	6  Creating Mathematical Documents
	6.1  In This Chapter
	6.2  Document Formatting
	Quick Character Formatting
	Attributes Submenu: Setting Fonts, Character Size, and Attributes

	Quick Paragraph Formatting
	Attributes Submenu: Spacing, Indent, Alignment, Bullets, Line Break, and Page Break

	Copy and Paste
	Sections
	Using the Insert Menu to Add Sections
	Using the Indent and Outdent Toolbar Icons

	Display Hidden Formatting Attributes
	Indentation and the Tab Key
	Character and Paragraph Styles
	Applying Character Styles
	Creating Character Styles
	Modifying Character Styles
	Applying Paragraph Styles
	Creating Paragraph Styles
	Modifying Paragraph Styles
	Style Set Management: Saving Styles for Future Use
	Creating and Applying Style Sets
	Reverting to a Style Set


	Document Blocks
	Applying Document Blocks: General Process
	Working in Document Mode
	View Document Code
	Expand an Execution Group within a Document Block
	Switch between Input and Output

	Inline Document

	Typesetting
	Using Tables for Layout
	Creating a Table
	Cell Contents
	Navigating Table Cells
	Modifying the Structural Layout of a Table
	Inserting Rows and Columns
	Deleting Rows and Columns
	Pasting
	Merging

	Modifying the Physical Dimensions of a Table
	Modifying the Appearance of a Table
	Table Borders
	Alignment Options
	Controlling the Visibility of Cell Content

	Printing Options
	Execution Order Dependency
	Tables and the Classic Worksheet
	Examples
	Table of Values
	Formatting Table Headers
	2-D Math and Plots
	Table of Mathematical Expressions


	Formatting Lists: Bullets, Numbers, and Indent
	Formatting Lists Using the Context Bar
	Formatting Lists Using the Paragraph Style Dialog

	Bookmarks
	Inserting, Renaming, and Deleting a Bookmark
	Go to a Bookmark

	Inserting Images
	ImageTools Package

	Show or Hide Worksheet Content
	Using the Show Contents Dialog
	Command Output Versus Insertion


	6.3  Embedded Components
	Adding Graphical Interface Components
	Editing Component Properties: General Process
	Removing Graphical Interface Components
	Example Component Properties
	Printing and Exporting a Document with Embedded Components

	6.4  Creating Graded Assignments
	Creating a Question
	Viewing Questions in Maple
	Saving Test Content

	6.5  Auto-Execute
	Setting the Auto-Execute Feature
	Removing the Auto-Execute Setting
	Repeating Auto-Execution
	Security Levels

	6.6  Canvas
	Insert a Canvas
	Drawing
	Canvas Style

	6.7  Spell Checking
	How to Use the Spellcheck Utility
	Selecting a Suggestion
	Spellcheck Usage and the Document
	User Dictionary
	Adding a Word to Your Dictionary


	6.8  Hyperlinks
	Inserting a Hyperlink in a Document
	Linking to an Email Address
	Linking to a Dictionary Topic
	Linking to a Help Page
	Linking to a Maplet Application
	Linking to a Web Page
	Linking to a Document


	6.9  Worksheet Compatibility

	7  Maple Expressions
	7.1  In This Chapter
	7.2  Creating and Using Data Structures
	Expression Sequences
	Accessing Elements

	Sets
	Using Sets

	Lists
	Accessing Entries
	Using Lists

	Arrays
	Creating and Using Arrays
	Large Arrays

	Tables
	Defining Tables and Accessing Entries

	Matrices and Vectors
	Functional Operators
	Defining a Function
	Distinction between Functional Operators and Other Expressions
	Multivariate and Vector Functions
	Using Operators

	Strings
	Accessing Characters
	Using Strings


	7.3  Working with Maple Expressions
	Low-Level Operations
	Expression Types
	Testing the Type of an Expression
	Testing the Type of Subexpressions
	Testing for a Subexpression

	Accessing Expression Components
	Left and Right-Hand Side
	Numerator and Denominator
	Components of an Expression
	Indeterminates


	Manipulating Expressions
	Simplifying
	Factoring
	Expanding
	Combining
	Converting
	Normalizing
	Sorting

	Evaluating Expressions
	Substituting a Value for a Subexpression
	Numerical Approximation
	Evaluating Complex Expressions
	Evaluating Boolean Expressions
	Levels of Evaluation
	Delaying Evaluation
	Using an Assigned Name as a Variable or Keyword
	Full Evaluation of an Expression in Quotes
	Unassigning a Name Using Unevaluation Quotes




	8  Basic Programming
	8.1  In This Chapter
	8.2  Flow Control
	Conditional Execution (if Statement)
	Syntax
	Simple if Statements
	else Clause
	elif Clauses
	elif and else Clauses

	Repetition (for Statement)
	for/from Loop
	Syntax
	Examples

	for/in Loop
	Syntax
	Example

	while Loop
	Syntax
	Example

	General Loop Statements
	Infinite Loops
	Additional Information


	8.3  Iterative Commands
	Creating a Sequence
	Adding and Multiplying Expressions
	Selecting Expression Operands
	Mapping a Command over a Set or List
	Mapping a Binary Command over Two Lists or Vectors
	Additional Information

	8.4  Procedures
	Defining and Running Simple Procedures
	Procedures with Inputs
	Procedure Return Values
	Displaying Procedure Definitions
	Displaying Maple Library Procedure Definitions
	Modules


	9  Maplets
	9.1  In This Chapter
	9.2  Simple Maplet
	9.3  Using Maplets
	Maplet File
	Maple Document

	9.4  Authoring Maplets
	Maplet Builder
	Design a Maplet Using the Maplet Builder
	Define the number of rows in the Maplet
	Add a plot region to row 1
	Add columns to row 2
	Add a label to row 2
	Add a text region to row 2
	Add a button to row 2
	Run the Maplet


	Maplets Package
	Example 1 - Design a Maplet Using the Maplets Package
	Example 2 - Accessing User-Defined Procedures
	User-Defined Procedure and Maplet Code


	Saving
	Maple Document
	Maplet File



	10  Input, Output, and Interacting with Other Products
	10.1  In This Chapter
	10.2  Writing to Files
	Saving Data to a File
	Saving Expressions to a File

	10.3  Reading from Files
	Reading Data from a File
	Import Data Assistant
	ImportMatrix Command

	Reading Expressions from a File

	10.4  Exporting to Other Formats
	Exporting Documents
	HTML
	LaTeX
	Maple Input
	Maplet Application
	Maple Text
	Plain Text
	Rich Text Format (RTF)
	Summary of Translation

	MapleNet
	Overview of MapleNet
	MapleNet Documents and Maplets
	Custom JavaTM Applets and JavaServer PagesTM Technology

	Maple T.A.
	Overview of Maple T.A.
	Exporting Assignments to Maple T.A.


	10.5  Connectivity
	Translating Maple Code To Other Programming Languages
	Code Generation

	Accessing External Products from Maple
	External Calling
	Mathematica Translator
	Matlab Package

	Accessing Maple from External Products
	Microsoft Excel Add-In
	OpenMaple



	Index

